Free! Download Now
HURRY! ENDS DEC 15th
THREE WAYS TO
HURRY! ENDS DEC 15th

Save up to $300 on a Lifetime License! Hurry Ends Dec 15th!

Advisory #1 | 03 16, 2011

Upcoming CME New Mandatory iLink Tags

Dear NinjaTrader User:

As of June 3rd, 2011, the CME mandates that all vendors connecting into its systems submit the following information:

  • Application version information
  • Flag indicating if orders were generated manually or via an automated process
  • Country of origin

To ensure compliance, our brokerage technology partners will be updating their systems/API(s) which will impact downstream applications such as NinjaTrader forcing us to update NinjaTrader as well.

Here is what this upcoming change means to you:

  • First and foremost our brokerage technology partners need to make changes to their systems and API(s) to ensure compliance with this CME requirement
  • Once we receive updated API’s, we will incorporate them into future NinjaTrader 7 releases prior to the June 3rd, 2011 deadline
  • If you trade CME markets
    • NinjaTrader 7 Users: On June 3rd, 2011 please be sure you are on the latest version as of this date.
    • NinjaTrader 6.5 users: We advise you to migrate to NinjaTrader 7 well in advance of the June 3rd, 2011 deadline (see FAQ below)

We will provide you with more information as it becomes available to us. Until then, please review the FAQ below.

Additional information on these changes from the CME can be read here.

Regards,NinjaTrader Customer Service

FAQ

Can I use NinjaTrader 6.5 to trade CME markets after June 3rd, 2011?

The majority of the NinjaTrader 6.5 code base has not been updated for several years and some of the brokerage technology API’s it uses are many revisions old. We project that by June of this year independent of this CME change, 80% of our user base would have migrated to NinjaTrader 7 and in that context, the effort and risk posed by making NinjaTrader 6.5 CME compliant is not economically viable. While at this time, we are not 100% clear of the changes required for each supported brokerage technology, it would be safe to say that most will require some updates. These updates will only be applied to NinjaTrader 7.

What will happen if I am not on the latest NinjaTrader 7 version as of June 3rd, 2011?

If you are not trading CME markets, then there is no adverse impact at all. If you are trading CME markets, any order submitted on or after June 3rd will be rejected.

What if I don’t trade CME markets?

Then you can ignore this advisory.

Apart from making sure I am on the latest NinjaTrader 7 version, is there anything else I need to do?

Nothing at this time. There may be a requirement in a future release to edit your account connection and provide geographic information.

Do I have to tell you if I am trading manually or automated?

No. This is not your responsibility and will be handled transparently for you.

I still run NinjaTrader 6.5 and have automated systems and/or indicators that I have not yet ported to NinjaTrader 7, what should I do?

If you are not trading CME markets then there is nothing for you to do. If you do trade CME markets or plan to, you have just over two months to convert and test your scripts. We highly advise you to get started right away. Click here for a good starting point for converting 6.5 scripts.