Required Update for FXCM NinjaTrader 8 Users

Following an update by FXCM to ensure SSL connectivity, all users connecting through FXCM must update to NinjaTrader version 8.0.24.3 or newer to connect to a demo or live trading account.

You can download the latest version of NinjaTrader 8 here.

If you have any questions or would like further assistance, please contact us at [email protected]