Required Update for NinjaTrader 8 Users to Access Historical Data

On August 7, 2021, NinjaTrader’s historical data servers will be upgraded to incorporate additional security protocols. To continue to load historical and playback data without interruption through NinjaTrader 8 servers, all users must update to version 8.0.22.0 or newer prior to August 7th.

You can download the latest version of NinjaTrader 8 here.

If you have any questions or would like further assistance, please contact us at [email protected]