Required Update for Rithmic and MB Trading Users

To accurately trade any expiry from 2018 or later using a Rithmic or MB Trading connection, users must update to a recent release of NinjaTrader as outlined below. Failure to do so will result in positions displaying with an incorrect expiry date.

Please follow the steps below to proceed with the update. All workspaces, NinjaScript files, and other user settings will be maintained.

  1. Visit https://ninjatrader.com/PlatformDirect to download the most recent version of the software. You will need to enter your NinjaTrader license key which can be located under Help > License Key.
  2. Close NinjaTrader if it is currently running.

If you have follow-up questions, please contact us at platformsupport@ninjatrader.com.