• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

RC1 and "loading data" crashes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Hi Jason,

    I just emailed you the strategy - let's hope it causes the problem.

    Thanks

    Comment


      #47
      Hello adamus,

      I imported the strategy on my end and performed the instructions at #44 once more. Unfortunately I cannot reproduce the issue.

      I selected 6 instruments in my chart manually through the instrument drop down menu in the chart toolbar. During this time, data was being loaded for the Market Analyzer as well.

      Subsequently I windowlinked the Market Analyzer to the chart and switched instruments that way. I even rapidly selected 4 instruments in the Market Analyzer. The chart loaded the first instrument I selected and then indicated 'Loading data'. However after about 30 seconds the 4th instrument I selected was loaded and displayed.

      I restarted NinjaTrader and connected to both connections again. This time I enabled the strategy for all instruments in my instrument list as well. At this point data is being loaded in the Market Analyzer and the strategies. I switched instruments in the chart again, however it does not get stuck on 'Loading data'.
      JasonNinjaTrader Customer Service

      Comment


        #48
        Hi Jason,

        I assume you are deleting and recreating those stratgies before you try it? In fact, I deleted all my strategies completely so there were none there at all, and then I recreated them.

        The 30 second hang is interesting. It's almost crashing but then recovers. I haven't seen this. Did you notice whether the status line in the Control Centre bottom right corner was blinking with the "Loading data .... $EURCAD (20/11/2010 - 20/11/2010)" message, at quite high frequency, approx 4 or 5 times a second?

        I don't know whether waiting or not waiting for the Market Analyzer to finish loading its rows is relevant. Mostly I waited for the Market Analyzer to finish. I didn't use any Market Analyzer actions to start charts.

        Comment


          #49
          Hello adamus,

          During my first test I added the strategies fresh. However once I restarted NinjaTrader, I did not remove and add the strategies in the Strategies-tab. However data was being loaded for the strategies when I enabled them. Please note that I did not enable the strategies during the first test.

          I did not experience the loading time of 30 seconds as hanging of the software. In such a situation it can take 30 seconds. Please be aware that data is loaded for the instruments in the Market Analyzer itself as well when I select 4 instruments in quick succession. The chart loads the first instrument fairly quick. It does not display the 2nd and 3rd instrument and eventually loads and displays the 4th instrument I selected.

          I did not notice such information blinking in the lower right corner of the Control Center.
          JasonNinjaTrader Customer Service

          Comment


            #50
            Hi Jason,

            the point I am trying to make about adding the strategies fresh is that this is the key trigger of the bug. If you can load data for all instruments and go back and reload the first without it hanging, then the bug obviously hasn't been triggered. At that point you should delete the strategies and add them back in again if you want a chance of triggering the bug.

            This is what happened to me. NT was working fine for over a week and then as soon as I had deleted and re-added the strategies, the bug appeared and it took me hours to get NT back to a stable state - I kept seeing the hanging on "Loading data" over and over again until I figured out how to work around it.

            And don't forget, this is not the first occurrence - the bug appeared before and caused hours of trouble.

            At the moment, I suspect that you may not be reproducing the exact situation that I have, so I would appreciate it if you could try it again.

            Thanks

            Comment


              #51
              I did add them fresh the first test and the prior tests as well. Only during the additional test I restarted NinjaTrader and did not remove and re-add the strategies.
              JasonNinjaTrader Customer Service

              Comment


                #52
                Originally posted by NinjaTrader_Jason View Post
                I did add them fresh the first test and the prior tests as well. Only during the additional test I restarted NinjaTrader and did not remove and re-add the strategies.
                In that case the additional test you did couldn't be expected to demonstrate what I am seeing.

                If you are giving up, then perhaps you can say what your opinion is about the cause of the bug - it might help me waste less time with this if/when it happens again in future.

                Thanks

                Comment


                  #53
                  Unfortunately I have no idea why NinjaTrader gets stuck on 'Loading data' on your end.
                  JasonNinjaTrader Customer Service

                  Comment

                  Latest Posts

                  Collapse

                  Topics Statistics Last Post
                  Started by TazoTodua, Today, 12:52 PM
                  0 responses
                  1 view
                  0 likes
                  Last Post TazoTodua  
                  Started by Bluebeep, Today, 12:26 PM
                  0 responses
                  3 views
                  0 likes
                  Last Post Bluebeep  
                  Started by Johnny90, Today, 12:12 PM
                  0 responses
                  1 view
                  0 likes
                  Last Post Johnny90  
                  Started by login_dejavu, Today, 10:55 AM
                  0 responses
                  5 views
                  0 likes
                  Last Post login_dejavu  
                  Started by learningnt, Today, 08:47 AM
                  0 responses
                  205 views
                  0 likes
                  Last Post learningnt  
                  Working...
                  X