• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Unable to compile after upgrading to NT8.002

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Unable to compile after upgrading to NT8.002

    Hey guys - just upgraded to the new release and I am seeing errors when compiling now. Please see the enclosed. How is it possible that all this changed since the first release? Seems those are method signature conflicts. I must be missing something....

    To be clear - I haven't touched that code and it was running fine with the first beta release. Any help would be appreciated.
    Attached Files

    #2
    Alright - it seems that you guys simplified the method signatures and added helpers in order to avoid having to specify package names (good call!!!). I also have changed StringAlignment to TextAlignment - now what is the best replacement for 'StringAlignment.Near'? Currently I'm using TextAlignment.Justified - seems to look fine but any input would be appreciated.
    Last edited by molecool; 05-29-2015, 06:42 AM.

    Comment


      #3
      Was there an email that went out with a hint as to what the changes were? I only got notified regarding the new beta when I launched the old one. I assume I'm on the mailing list?

      Comment


        #4
        Same thing with System.Drawing.Drawing2D.DashStyle

        Hi guys.
        I continue your post with the same kind of error.
        if I try this sample code (from your doc) :
        Code:
        Draw.Line(this,"tag1",false,10,1000,0,1001,Brushes.LimeGreen,DashStyleHelper.Dot,2);
        It doesn't compile and give me the attached error.

        In the 8.0.0.2 (Beta) Release Notes it is said :
        System.Drawing.Drawing2D.DashStyle
        - changed to NinjaTrader.Gui.DashStyleHelper, any Draw method that used DashStyle will need to be updated

        But it seems not working (sorry if I'm missing something).

        Regards,

        -----------------------------------------------
        Christophe - Ninja-Addons.com
        CEO Azur Investment Technologies "AzurITEC" sas
        http://www.ninja-addons.com
        3rd Party Add-On Vendor
        Attached Files
        Last edited by AzurITec_Chris; 05-29-2015, 07:39 AM.

        Comment


          #5
          Make sure you remove all the DRAWING "using" statements from the top of your script. Sounds like there might be a conflict in name spaces.

          Comment


            #6
            Originally posted by molecool View Post
            Was there an email that went out with a hint as to what the changes were? I only got notified regarding the new beta when I launched the old one. I assume I'm on the mailing list?
            There is no mailing list for updates, there was just an in product annoucnement and a post on our fourm - http://www.ninjatrader.com/support/f...ad.php?t=74507

            The code breaking changes are at the top of the release notes
            MatthewNinjaTrader Product Management

            Comment


              #7
              Originally posted by molecool View Post
              Alright - it seems that you guys simplified the method signatures and added helpers in order to avoid having to specify package names (good call!!!). I also have changed StringAlignment to TextAlignment - now what is the best replacement for 'StringAlignment.Near'? Currently I'm using TextAlignment.Justified - seems to look fine but any input would be appreciated.
              There isn't exactly a concept of 'near' with TextAlignment. Justified should work ok though in my experience.
              MatthewNinjaTrader Product Management

              Comment


                #8
                Originally posted by AzurITec_Chris View Post
                Hi guys.
                I continue your post with the same kind of error.
                if I try this sample code (from your doc) :
                Code:
                Draw.Line(this,"tag1",false,10,1000,0,1001,Brushes.LimeGreen,DashStyleHelper.Dot,2);
                It doesn't compile and give me the attached error.

                In the 8.0.0.2 (Beta) Release Notes it is said :
                System.Drawing.Drawing2D.DashStyle
                - changed to NinjaTrader.Gui.DashStyleHelper, any Draw method that used DashStyle will need to be updated

                But it seems not working (sorry if I'm missing something).

                Regards,

                -----------------------------------------------
                Christophe - Ninja-Addons.com
                CEO Azur Investment Technologies "AzurITEC" sas
                http://www.ninja-addons.com
                3rd Party Add-On Vendor
                Hmm, not sure - that compiles out of the box for me just fine. As another member suggested, check your using statements, or if you can upload your script I'll be happy to look it over to get you on your way.
                MatthewNinjaTrader Product Management

                Comment


                  #9
                  The way I obtained this error is simply :
                  1. Click on Add new indicator to open the indicator wizard.
                  2. Click Next then Generate. So I get the basic auto generated code from the wizard (did'nt modify anything, even the name MyCustomIndicator
                  3. Then I copy and paste the code given in the documentation inside the OnBarUpdate()
                  4. And then compile and get this error.

                  I attached the code ("wizard generated").

                  Thanks for your help.

                  -----------------------------------------------
                  Christophe - Ninja-Addons.com
                  CEO Azur Investment Technologies "AzurITEC" sas
                  http://www.ninja-addons.com
                  3rd Party Add-On Vendor
                  Attached Files

                  Comment


                    #10
                    I just tried this code on my BETA2 system and it compiled fine. Did you install BETA1 prior to BETA2? You might be still running BETA1 or some hybrid if something failed during the installation. You should probably re-install BETA2.

                    Originally posted by AzurITec_Chris View Post
                    The way I obtained this error is simply :
                    1. Click on Add new indicator to open the indicator wizard.
                    2. Click Next then Generate. So I get the basic auto generated code from the wizard (did'nt modify anything, even the name MyCustomIndicator
                    3. Then I copy and paste the code given in the documentation inside the OnBarUpdate()
                    4. And then compile and get this error.

                    I attached the code ("wizard generated").

                    Thanks for your help.

                    -----------------------------------------------
                    Christophe - Ninja-Addons.com
                    CEO Azur Investment Technologies "AzurITEC" sas
                    http://www.ninja-addons.com
                    3rd Party Add-On Vendor

                    Comment


                      #11
                      It truly looks like you may still have a B1 assembly installed... what version is shown under Help-> About?
                      MatthewNinjaTrader Product Management

                      Comment


                        #12
                        I just insalled BETA2. Never used BETA1 or installed it before.
                        I will try to re-install BETA2 to see if the problem is solved.

                        Originally posted by NJA_MC View Post
                        I just tried this code on my BETA2 system and it compiled fine. Did you install BETA1 prior to BETA2? You might be still running BETA1 or some hybrid if something failed during the installation. You should probably re-install BETA2.

                        -----------------------------------------------
                        Christophe - Ninja-Addons.com
                        CEO Azur Investment Technologies "AzurITEC" sas
                        http://www.ninja-addons.com
                        3rd Party Add-On Vendor

                        Comment


                          #13
                          I reinstalled and it works fine now.
                          Sorry for that...

                          Originally posted by NinjaTrader_Matthew View Post
                          It truly looks like you may still have a B1 assembly installed... what version is shown under Help-> About?

                          -----------------------------------------------
                          Christophe - Ninja-Addons.com
                          CEO Azur Investment Technologies "AzurITEC" sas
                          http://www.ninja-addons.com
                          3rd Party Add-On Vendor

                          Comment


                            #14
                            Glad to hear it's working
                            MatthewNinjaTrader Product Management

                            Comment

                            Latest Posts

                            Collapse

                            Topics Statistics Last Post
                            Started by ericson, Today, 08:14 PM
                            0 responses
                            5 views
                            0 likes
                            Last Post ericson
                            by ericson
                             
                            Started by user1986, Today, 07:28 PM
                            1 response
                            7 views
                            0 likes
                            Last Post user1986  
                            Started by jertrade, Today, 06:57 PM
                            0 responses
                            5 views
                            0 likes
                            Last Post jertrade  
                            Started by Emma1, Today, 02:42 PM
                            1 response
                            17 views
                            0 likes
                            Last Post NinjaTrader_DrewO  
                            Started by fx.practic, Today, 03:10 PM
                            1 response
                            6 views
                            0 likes
                            Last Post NinjaTrader_Jesse  
                            Working...
                            X