Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Indicator does not show up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Indicator does not show up

    Hi there, am I missing something?

    I've created a AAAA indicator. Copied the code from Swing indicator with no change to the code itself keeping only the class name AAAA, compiled fine, however when I am trying to add the indicator to a chart nowhere to be found...

    I can open it in the editor, change, compile yet not on the list of indicators...

    Did quickly the same steps in NT 7, and got the expected result but not in NT 8 B4.

    Please advise and thanks,

    atata

    #2
    I think it needs a save as a work around.

    Comment


      #3
      Thanks, well some more experiment...

      Scenario #1
      1/ Open Swing indicator
      2/ "Save as..." AAASwing
      3/ Compile

      Does not show up in the indicator list

      Scenario #2
      1/ Open Swing indicator
      2/ "Save as..." AAASwung
      3/ Compile

      Does show up

      Scenario #3
      1/ Open Swing indicator
      2/ "Save as..." AAASwing
      3/ Change a text in quotes in the property section of the code
      4/ Save
      5/ Compile

      Does show up

      I wonder if this by design?

      atata

      Comment


        #4
        That's what I thought. Definitely not needed in nt7.compile suffices.

        Comment


          #5
          Originally posted by atata View Post

          Scenario #1
          1/ Open Swing indicator
          2/ "Save as..." AAASwing
          3/ Compile

          Does not show up in the indicator list

          Scenario #2
          1/ Open Swing indicator
          2/ "Save as..." AAASwung
          3/ Compile

          Does show up
          Can you please elaborate on the difference between Scenario 1 and Scenario 2? Just to be clear, are you saying that it shows up when you use a "u" in the class name, but not when you use an "i"?
          Dave I.NinjaTrader Product Management

          Comment


            #6
            Dave, can't reproduce the issue... Now anytime I do the same steps I am seeing the Indicator...
            However, as you can see on the screenshot, AAASwung indicator does not exist anymore yet it is on the chart and an empty row which I don't seem to be able to remove manually is under the "Configured" section as I guess a place holder... so I guess some has to get done still here...
            I am upgrading to b05 this afternoon and do the same experiment see what happens...
            Hope this helps,

            atata

            Comment


              #7
              Thank you -- I'll be very interested to hear if you see the same thing in B5.
              Dave I.NinjaTrader Product Management

              Comment


                #8
                Well, can't connect to Rithmic... there is another thread is open regards to that issue. -> can't test in B05

                Comment


                  #9
                  Hi atata,

                  Thanks, we are aware of this issue and are looking into solutions; it seems to relate to an issue with live license keys, so feel free to use the sim key in the meantime to test this:

                  @SIM-A82F-D583-40B1-AE74-B79F-705D-1952
                  Alex C.NinjaTrader Customer Service

                  Comment


                    #10
                    Alex, indeed this works as per the connection goes however it shows only Sim account... well we'll live with it for now.

                    Thanks,

                    atata

                    Comment


                      #11
                      B05 tests

                      I've tested the indicator issue I've experienced with B04 in B05 and did not find any issues when I've followed the steps below:

                      1/ I've opened the Swing indicator in Script Editor.
                      2/ Save as AAASwing and compile.
                      3/ I was able to add it to a chart.
                      4/ I've removed the indicator from the chart.
                      5/ I've deleted the AAASwing indicator through the script editor.
                      Everything seemed to work fine at that point.

                      However with an unintended usage I could corrupt the chart as below:
                      1/ I've opened the Swing indicator in Script Editor.
                      2/ Save as AAASwing and compile.
                      3/ I was able to add it to a chart.
                      4/ I've deleted the AAASwing indicator through the script editor.
                      4a/ First time I was able to remove it from the chart.
                      4b/ Second time the chart became corrupted, restart did not help had to delete it. No charting at all, could not reload data etc... before restart when I've tried to go to "Indicators" I've got an error message what I am going to attach.

                      Hope this helps,

                      atata
                      Attached Files

                      Comment


                        #12
                        Originally posted by NinjaTrader_Dave View Post
                        Can you please elaborate on the difference between Scenario 1 and Scenario 2? Just to be clear, are you saying that it shows up when you use a "u" in the class name, but not when you use an "i"?
                        I came across something probably related -

                        in strategies - I did a SaveAs... and compile - strategy doesn't show up.

                        What I found is that the OnStateChange - Name is used for the Strategy list, not the name of the strategy.

                        I had 2 strategies with the same name in my Strategy Selection!

                        Changing the Name property resolved my issue.

                        Is the Name property supposed to update on a Save As? or is that a free for all - all the time?

                        Comment


                          #13
                          Originally posted by sledge View Post
                          Is the Name property supposed to update on a Save As? or is that a free for all - all the time?
                          Doing a Save As will not update the Name property. Keep in mind that doing a Save As will only change the file name and class name. There are three names to keep in mind: the file name, the class name, and the Name property. The Name property determines what will be displayed in the Strategies window, and that must always be set in code.
                          Last edited by NinjaTrader_DaveI; 09-28-2015, 09:06 AM.
                          Dave I.NinjaTrader Product Management

                          Comment


                            #14
                            atata, I'm not seeing the same behavior on my end with your second scenario. After deleting the SwingAAA indicator, I can then remove it from the chart with no problems. Could there be something else going on in your scenario? Are you using any custom scripts that rely on SwingAAA, for example?
                            Dave I.NinjaTrader Product Management

                            Comment


                              #15
                              Originally posted by NinjaTrader_Dave View Post
                              Doing a Save As will not update the Name property. Keep in mind that doing a Save As will only change the file name. There are three names to keep in mind: the file name, the class name, and the Name property. The Name property determines what will be displayed in the Strategies window, and that must always be set in code.
                              Actually Save As ... also changes the class name.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Stanfillirenfro, Today, 05:31 AM
                              1 response
                              33 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Started by Rosario, Today, 12:50 AM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Started by Ithinkimlost, Yesterday, 08:50 PM
                              2 responses
                              12 views
                              0 likes
                              Last Post Ithinkimlost  
                              Started by sidlercom80, Today, 04:45 AM
                              0 responses
                              4 views
                              0 likes
                              Last Post sidlercom80  
                              Started by NT-Roland, Today, 04:44 AM
                              0 responses
                              4 views
                              0 likes
                              Last Post NT-Roland  
                              Working...
                              X