• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Rollover Offset is not applied

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Rollover Offset is not applied

    Today Ninjatrader notified me that NG10-15 should be rolled over into NG11-15.
    So i looked at the daily volume of both contracts over the last days and found that yesterday had still more volume in NG10-15 and today had more volume in NG11-15.
    So i went into the rollover editor of Ninjatrader for NG. NT8 had the 23rd as the rollover date so i changed it to the 24th(today) and deleted the value from the Offset field to let NT8 determine the new offset value. After that i went to my NG10-15 chart and typed NG11-15 to rollover.
    After that the chart appears to have not applied any offset value because there was a gap between yesterday and today. I then went back into the rollover editor and found that NT8 had filled the Offset field with 0.069. When looking at the chart i found that this is exactly the difference needed for an adjusted rollover to remove the gap. NT8 seems to not apply the offset after i changed the rollover date.
    (Image attached)
    I then used Tools->Database to reset my instruments and rollovers. After i restarted NT8 and reloaded historical data NT8 had a rollover without a gap for the 23rd.
    So rollover works normally when i keep the rollover date that NT8 provides but it fails to apply the offset when i manually change the rollover to a different date.
    Edit: There is definitely a problem with the Offset. If i open a chart with NG 11-15, then type ng 10-15 to load the old contract, wait for it to load, then type NG 11-15, then the gap gets bigger by 1x the offset value. So if i do this 3x then the gap is 3x the offset value.

    Sidenote: After this i tested some more around with changing the rollover date and the more often i changed the date the more gaps i could create in the chart. This could not be fixed with 'Reload historical data'. Only me manually deleting the entries under \db\cache\#tradinghourstemplate#\tick\#Instrument# fixed the gaps.
    Attached Files
    Last edited by Tiixo; 09-24-2015, 03:37 PM.

    #2
    Hi Tiixo,

    I'm giving this a test and if I am able to reproduce I will get this sent in to development to be fixed.

    I appreciate your patience as I test and gather information to provide to development.
    Chelsea B.NinjaTrader Customer Service

    Comment


      #3
      I tested around some more today and it seems that the issue is caused by the TimeZone setting in the TradingHours that is being used.
      Below i attached 2 Screenshots. The first used the Default 24x7 TradingHours with US Eastern as Timezone and the Rollover looks fine.
      The second used the Default 24x7 TradingHours with CEST as Timezone and on the rollover date the rollover offset was not applied.

      My local pc is in the CEST Timezone. Maybe this plays a role as well.
      Attached Files

      Comment


        #4
        Hi Tiixo,

        I am not able to reproduce.

        Whenever I change the offset or change the rollover date save the changes, then reload the chart, the chart is affected by the change.

        However, with .069 on 9/24 with UTC+2 as the time zone I am not getting this gap.

        I would like to give you a call and test on your end.

        Please send an email to platformsupport [at] ninjatrader [dot] com. In the email please include a link to this forum thread.
        Chelsea B.NinjaTrader Customer Service

        Comment


          #5
          Still happening on Beta6. Can you give me the issue id? And will the fix be in beta7?

          Comment


            #6
            Hi Tiixo,

            May I confirm that you have submitted an email to platformsupport [at] ninjatrader [dot] com with a link to this forum thread?

            I have not entered this as a bug report as I am not able to reproduce on my end.

            I have looked but I have not found an email that has a link to this forum thread.
            Chelsea B.NinjaTrader Customer Service

            Comment


              #7
              Yes i have sent the mail on September 29th.
              After a remote support session on the same day the last mail i got from you guys was this.

              RE: NT8B5 - Rollover Offset not applied Issue {1394482}

              Hello Nico,
              Thank you for your patience.
              I was able to reproduce the issue once tick replay was enabled.
              I have forwarded this issue to the NinjaTrader development department.
              Please let me know if you do discover any further issues with NinjaTrader 8.


              Sincerely,
              Chelsea
              NinjaTrader Customer Service

              Comment


                #8
                Hi Tiixo,

                That was exactly what I needed.

                This issue has not been resolved and is currently tracked with ID QA-1161 but this will eventually change.
                Chelsea B.NinjaTrader Customer Service

                Comment


                  #9
                  What is the issue ID of this?
                  Because it is still happening in Beta7.

                  Comment


                    #10
                    Hello Tiixo,

                    This was being tracked with ID #NTEIGHT-8908.

                    While I was able to reproduce a change in the data using Beta 6, I am no longer able to reproduce this using Beta 7.

                    So that I may try and reproduce:

                    What instrument and expiry are you using?
                    (I'm using NG 01-16 with the most recent data and also checking the NG 11-15 with the data around September 25th 2015.)

                    What is the bar type and interval?

                    Who are you connecting to for data?

                    May I have a before screenshot and an after enabling Tick Replay screenshot?
                    Chelsea B.NinjaTrader Customer Service

                    Comment


                      #11
                      Have you used a custom TradingHours template that has a european timezone like UTC+1 for Germany?

                      I attached that screenshots that show that it only happens with the custom TradingHours that have UTC+1 as their timezone.
                      MergePolicy was Merge non back adjusted.
                      Attached Files

                      Comment


                        #12
                        Hi Tiixo,

                        My local time zone is set to UTC +1 Amsterdam time.

                        In your screenshot you are using <use instrument settings> as the session template. I am also using <use instrument settings>.

                        Have you modified the default session template for this instrument in the Instruments window?

                        It is expected that different session templates will have different data that appears on the chart.

                        However, I am focusing on the bars after the start of Nov 18th. If the offset was not being applied correctly, these wouldn't be at the same price.

                        Your screenshots have shown that the offset is being applied correctly for the historical data, with tick replay on and off.
                        Chelsea B.NinjaTrader Customer Service

                        Comment


                          #13
                          <use instrument settings> is set to Nymex Metals - Energy ETH.
                          Rollover Date is set to 23rd of November for 01-16.

                          The difference happens when i switch from Nymex Metals ETH to Default 24x7 where 24x7 has a timezone setting of UTC+1.

                          Changing the TimeZone of the TradingHours should not result in the rollover day(23rd of November) to be 200 Pips lower.

                          If i change my 24x7 TradingHours from UTC+1 back to Central Time then the rollover works correct.

                          Edit: i attached a screenshot of the trading hours template. Changing the timezone there leads to the wrong data on the day of the rollover.
                          Attached Files
                          Last edited by Tiixo; 12-04-2015, 04:17 PM.

                          Comment

                          Latest Posts

                          Collapse

                          Topics Statistics Last Post
                          Started by SAITON, Today, 09:03 PM
                          0 responses
                          1 view
                          0 likes
                          Last Post SAITON
                          by SAITON
                           
                          Started by suprsnipes, Today, 08:26 PM
                          0 responses
                          5 views
                          0 likes
                          Last Post suprsnipes  
                          Started by RobertoPaez, Today, 06:47 PM
                          0 responses
                          7 views
                          0 likes
                          Last Post RobertoPaez  
                          Started by catinabag, Today, 06:45 PM
                          0 responses
                          4 views
                          0 likes
                          Last Post catinabag  
                          Started by darkgreen, Today, 03:35 PM
                          0 responses
                          9 views
                          0 likes
                          Last Post darkgreen  
                          Working...
                          X