Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Can't use the dot (.) with double inputs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't use the dot (.) with double inputs

    Using 8.0.0.5 64-bit beta.

    I have two double properties in my indicator:

    Code:
            [Range(0.0, 5.0)]
            [NinjaScriptProperty]
            [Display(Name = "Offset upper band", Order = 2, GroupName = "Price band settings")]
            public double OffsetUpperBand
            { get; set; }
    
            [Range(0.0, 5.0)]
            [NinjaScriptProperty]
            [Display(Name = "Offset lower band", Order = 3, GroupName = "Price band settings")]
            public double OffsetLowerBand
            { get; set; }
    I set these to the default values of:

    Code:
    protected override void OnStateChange()
    {
      if (State == State.SetDefaults)
      {
          OffsetUpperBand = 1.005;
          OffsetLowerBand = 0.995;
      }
    }
    They look like this in the indicator's settings:

    (see attachment)

    But while they show with the decimal dot (`.`) in the inputs, I cannot type a dot myself there. So if I remove `0.995` and try to type `0.990`, the dot isn't entered and I end up with `0990` as input value. Am I doing something wrong?
    Attached Files

    #2
    Hello J_o_s,

    Thank you for your inquiry.

    I am unable to reproduce this issue on my end.

    Just to verify, are you able to type in a decimal outside of NinjaTrader?

    Is there a specific way you have deleted the value you are trying to replace? Did you highlight the entire entry and deleted it? Did you delete the characters one-by-one by just clicking at the end of the entry and holding backspace?
    Zachary G.NinjaTrader Customer Service

    Comment


      #3
      Originally posted by NinjaTrader_ZacharyG View Post
      Just to verify, are you able to type in a decimal outside of NinjaTrader?
      Yes, see the post itself. I used the dot there repeatedly. And in this post also. No keyboard problems. Or problems with the dot in other programs.

      Originally posted by NinjaTrader_ZacharyG View Post
      Is there a specific way you have deleted the value you are trying to replace? Did you highlight the entire entry and deleted it? Did you delete the characters one-by-one by just clicking at the end of the entry and holding backspace?
      Here's a video with the Windows on-screen keyboard to show which buttons I pressed:
      http://recordit.co/beMRk3HA7t

      Comment


        #4
        Here's by the way the full script. Perhaps I just made an error somewhere (I'm new to NT8).
        Attached Files

        Comment


          #5
          Hello J_o_s,

          I am still unable to reproduce this behavior on my end.

          Are you able to reproduce this behavior in NinjaTrader 7 as well, or does this only occur in NinjaTrader 8?
          Zachary G.NinjaTrader Customer Service

          Comment


            #6
            Can you also clarify what Region and Language format settings you have on your PC? If not set to English (United States), can you try switching to that default region type and let us know what you were using so we can look into that
            MatthewNinjaTrader Product Management

            Comment


              #7
              Originally posted by NinjaTrader_ZacharyG View Post
              Are you able to reproduce this behavior in NinjaTrader 7 as well, or does this only occur in NinjaTrader 8?
              I don't have NT7 installed, and I don't know much about NT7 to install it and try to replicate it there.

              Originally posted by NinjaTrader_Matthew View Post
              Can you also clarify what Region and Language format settings you have on your PC? If not set to English (United States), can you try switching to that default region type and let us know what you were using so we can look into that
              My keyboard is set to Dutch - US (international) already. Switching it to US (international) exclusive didn't change the behaviour, sadly. I also tested another keyboard in case it's related to the keyboard or driver program, but that also didn't change the behaviour.

              Copying a dot (.) into the indicator properties screen doesn't work -- the dot itself is copied, but after that dot I cannot type a decimal anymore (so just end with 0. or 1. ). It looks like a bug somewhere (NT, Windows, WPF).

              Edit: I also cannot type a dot in the standard Keltner Channel indicator (its 'Offset multiplier' input that is by default 1.5). So it doesn't seem to be caused by the indicator I've posted earlier.

              Edit 2: I have no trouble typing in a dot in the 'Label' field of the default Keltner Channel indicator:
              http://recordit.co/l5fajMukAd
              The problem only seems to happen with decimal (double) inputs, not with text (string) inputs.

              Edit 3: I can however, type in a comma and then NinjaTrader converts it to a dot for me. That's odd behaviour since decimals are shown with a dot in NinjaTrader (and not a comma), but this is a workaround for me!

              Perhaps this is designed by default, but if NinjaTrader only accepts comma's as inputs and not dots, I think the program shouldn't display dots to begin with. At least for me, displaying dots gives the impression that I should type in decimals with a dot also (if that makes sense).
              Last edited by J_o_s; 10-08-2015, 08:43 AM.

              Comment


                #8
                Hello J_o_s,

                I am now able to reproduce this on my end.

                The settings on your computer that would affect this is in the main Formats tab of the Region and Language settings in the Control Panel rather than the keyboard input language under Keyboards and Languages.

                Upon switching Dutch (Netherlands), for example, only commas are accepted into the parameters. However, upon switching back to English (United States), I am able to use periods once more.

                I will be looking into this further and will get back to you with my findings.
                Zachary G.NinjaTrader Customer Service

                Comment


                  #9
                  Originally posted by J_o_s View Post
                  I don't have NT7 installed, and I don't know much about NT7 to install it and try to replicate it there.


                  My keyboard is set to Dutch - US (international) already. Switching it to US (international) exclusive didn't change the behaviour, sadly. I also tested another keyboard in case it's related to the keyboard or driver program, but that also didn't change the behaviour.

                  Copying a dot (.) into the indicator properties screen doesn't work -- the dot itself is copied, but after that dot I cannot type a decimal anymore (so just end with 0. or 1. ). It looks like a bug somewhere (NT, Windows, WPF).

                  Edit: I also cannot type a dot in the standard Keltner Channel indicator (its 'Offset multiplier' input that is by default 1.5). So it doesn't seem to be caused by the indicator I've posted earlier.

                  Edit 2: I have no trouble typing in a dot in the 'Label' field of the default Keltner Channel indicator:
                  http://recordit.co/l5fajMukAd
                  The problem only seems to happen with decimal (double) inputs, not with text (string) inputs.

                  Edit 3: I can however, type in a comma and then NinjaTrader converts it to a dot for me. That's odd behaviour since decimals are shown with a dot in NinjaTrader (and not a comma), but this is a workaround for me!

                  Perhaps this is designed by default, but if NinjaTrader only accepts comma's as inputs and not dots, I think the program shouldn't display dots to begin with. At least for me, displaying dots gives the impression that I should type in decimals with a dot also (if that makes sense).
                  Check your "Region" settings. You are setup for a region (probably a European country), that uses the comma as a decimal delineator.

                  Comment


                    #10
                    Hello J_o_s,

                    I have reported this to development and will provide further information as it arrives.
                    Zachary G.NinjaTrader Customer Service

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by Oracletrades, Today, 09:10 PM
                    0 responses
                    1 view
                    0 likes
                    Last Post Oracletrades  
                    Started by AlyssaLindsey, Today, 09:02 PM
                    0 responses
                    1 view
                    0 likes
                    Last Post AlyssaLindsey  
                    Started by SteveAU, Today, 08:35 PM
                    0 responses
                    4 views
                    0 likes
                    Last Post SteveAU
                    by SteveAU
                     
                    Started by Lloyd143, Today, 05:24 PM
                    1 response
                    19 views
                    0 likes
                    Last Post NinjaTrader_ShawnB  
                    Started by Hagar, Today, 04:38 PM
                    1 response
                    14 views
                    0 likes
                    Last Post NinjaTrader_ShawnB  
                    Working...
                    X