Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

B7 Inactive TickCharts get stored incorrectly in the workspace

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    B7 Inactive TickCharts get stored incorrectly in the workspace

    Since installing Beta7 TickReplay charts that were not visible once get stored incorrectly when the workspace is saved.

    Setup:
    Create a workspace with 2 ChartTabs in a single window. (ES 12-15 5Min, YM 12-15 5Min, both with TickReplay enabled)
    Add a non-overlay indicator to each chart (like Stochastics)
    Make ES 12-15 the active chart tab.
    Save the workspace.
    Close the workspace.

    Steps to reproduce:
    Open the workspace.
    Close it again(with saving) without looking at the YM chart tab.
    Open workspace again.
    Select the YM chart tab.
    YM chart tab has the wrong layout where the chart candles are not seen anymore and there is a big unused area at the bottom. (See screenshot)
    Attached Files

    #2
    Hello,

    Thank you for reporting this to us with steps to reproduce. Unfortunately, I am not seeing the same behavior on my end when I follow your process. When you open the workspace for the final time, do you wait until data is fully loaded in the ES tab, or do you switch to the YM tab right away? Does the same issue result with no indicators saved on the chart? Can you think of any other unique item or step that may be coming into play on your end?
    Dave I.NinjaTrader Product Management

    Comment


      #3
      Does the same issue result with no indicators saved on the chart?
      It only occurs when there is one(or multiple) indicators that have their own chart panel.

      When you open the workspace for the final time, do you wait until data is fully loaded in the ES tab, or do you switch to the YM tab right away?
      Does not matter. Because at that point the workspace.xml file already has the wrong data stored.
      More precisely:
      Code:
      <ChartPanels>
                  <ChartPanel>
                    <Height>0</Height>
      After the following step
      'Close it again(with saving) without looking at the YM chart tab.'
      the workspace.xml file has the wrong values for the panel heights.
      From then on everytime the workspace is loaded the panel heights are loaded with the wrong values.

      Comment


        #4
        Thank you -- I was able to reproduce after a few attempts, and I can see the issue in the XML file. I am going to get this submitted to our team to investigate further (NTEIGHT-9169), and I will post back here with any updates.
        Last edited by NinjaTrader_DaveI; 12-04-2015, 04:32 PM.
        Dave I.NinjaTrader Product Management

        Comment


          #5
          I'm happy to report that we have applied a fix for this issue in our most recent internal build. Please keep this issue in mind to re-test when the Beta 8 build is released.
          Dave I.NinjaTrader Product Management

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by kawalecld, Today, 12:21 PM
          0 responses
          2 views
          0 likes
          Last Post kawalecld  
          Started by farzibopsu, Today, 11:52 AM
          0 responses
          4 views
          0 likes
          Last Post farzibopsu  
          Started by exjayess, Today, 11:04 AM
          1 response
          9 views
          0 likes
          Last Post NinjaTrader_ShawnB  
          Started by robertlaub, Today, 11:11 AM
          1 response
          3 views
          0 likes
          Last Post NinjaTrader_ShawnB  
          Started by sdauteuil, Today, 10:28 AM
          0 responses
          6 views
          0 likes
          Last Post sdauteuil  
          Working...
          X