Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

IQfeed connection fails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    IQfeed connection fails

    I started to do some first tests, downloaded the most recent BETA version of NT8 and
    I encountered, what seems to be a little issue, when using IQfeed (v5.1.3.1) and NT 8 (v8.0.0.7).

    When you configure NT8 with an IQfeed connection it seems sometimes difficult/nearly impossible to bring the connection up. This situation happens both in auto connect at startup as manual connect through the menu.

    There is absolutely no issue with the password, retrying a few times without any change sometimes works. you can also clearly see the IQ client logging on, getting all permissions before the NT8 will fire an error for the connection.

    The logic to bring the connection up just seems very buggy/unstable.

    What always works :
    - Configure NT in auto connect or manually connecting to IQfeed, when the IQ client is already running because of an other application that was started before.

    What does not work :
    - Configure a connection in NT8 and start it manually or automatically as the first client using the IQfeed.

    Not an internet connection issue, 8 msec, 80MB/s up and 80MB/s down.

    The behavior is true for both the 32 bit and the 64 bit version.

    #2
    screen shot of error message and test of internet line
    (in reality the connection has passed and authorizations were ok on IQfeed)
    Attached Files

    Comment


      #3
      Hello,

      Thank you for your note.


      Can you please uninstall your current version of IQFeed Client Software then install the required version 5.1.1.3 at the link below:

      http://www.ninjatrader.com/ninjatrad...nt_5_1_1_3.exe

      Please let me know if the issue persists after installing the version required for NinjaTrader 8.
      Christopher J.NinjaTrader Customer Service

      Comment


        #4
        Hello

        Downgrading the IQ client to an old version is not an option for me as I am using besides NT 8 also other software that uses the IQ feed and relies on the latest version.

        Thank you for your advice, i mentioned in my post, i have a work around by not starting NT 8 as the first client

        Comment


          #5
          Originally posted by rleplae View Post
          Hello

          Downgrading the IQ client to an old version is not an option for me as I am using besides NT 8 also other software that uses the IQ feed and relies on the latest version.

          Thank you for your advice, i mentioned in my post, i have a work around by not starting NT 8 as the first client

          Considering that there are others of us in the exact same boat, its not really a fix of the issue by using a glitch to work around the problem.

          NT8 connects fine to IQfeed as long as I already have Sierra Charts running using a IQfeed connection first. If Sierra charts is not running, then NT8 is S*** out of luck and does not connect.

          So NT8 will work as long as it is in conjunction with another platform already running OR we should downgrade to a older IQ client ...... because NT8 is old??? None of this makes any sense with a brand new revised platform that is supposed to be NT8.

          Comment


            #6
            I found the same issue when using IQFeed v5.2.1.0 and NinjaTrader v8.0.0.10 (32-Bits). Sometimes when using NT 64-Bits works fine.

            I can't downgrade IQFeed Client because I'm using other software that required last update of IQFeed Client (and works fine while NT fails).

            Could report this behavior to improve the next build ?

            Thanks in advance
            WL
            Last edited by Walter.L; 04-04-2016, 10:32 AM.

            Comment


              #7
              Hello,

              I will forward this request to our development team and will follow up as soon as a tracking number has been assigned.
              Christopher J.NinjaTrader Customer Service

              Comment


                #8
                Originally posted by Walter.L View Post
                I found the same issue when using IQFeed v5.2.1.0 and NinjaTrader v8.0.0.10 (32-Bits). Sometimes when using NT 64-Bits works fine.

                I can't downgrade IQFeed Client because I'm using other software that required last update of IQFeed Client (and works fine while NT fails).

                Could report this behavior to improve the next build ?

                Thanks in advance
                WL
                I have tested using the latest version of IQFeed Client software and was able to connect successfully in both 32 and 64-bit versions.

                Can you please attempt to connect on your end then after it fails please go to Help->Email Support and be sure to include Attn: Chris Jameson in the Subject line, a link to this thread in the body and a check in the box for "Log and trace files".
                Christopher J.NinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by wjadevries, Today, 03:35 PM
                1 response
                2 views
                0 likes
                Last Post NinjaTrader_ChrisL  
                Started by Mykro, Today, 03:59 PM
                0 responses
                2 views
                0 likes
                Last Post Mykro
                by Mykro
                 
                Started by venkateshdvk, Today, 01:34 PM
                1 response
                20 views
                0 likes
                Last Post NinjaTrader_Kate  
                Started by westofpluto, Today, 01:54 PM
                1 response
                6 views
                0 likes
                Last Post NinjaTrader_Jesse  
                Started by zacharydw00, Today, 02:11 PM
                3 responses
                15 views
                0 likes
                Last Post NinjaTrader_ChrisL  
                Working...
                X