• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Lagging/choppy crosshair movement

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Lagging/choppy crosshair movement

    Win 8.1 Pro 64-Bit
    Intel Core i7 950 3.1GHz (8 cores)
    AMD Radeon HD 5800
    NT 8 Beta 5, 7 and 8

    Regular cursor causes no issues when moved around on (candlestick) charts.
    Crosshair cursor with solid lines loads 2x CPU cores 10-30% + 20-40% or 1x CPU core 40-60%.
    Crosshair cursor with dotted lines loads CPU same way as solid line one but in addition it also becomes irritatingly laggy.

    YT video is here: https://youtu.be/e9z3HBtOsjg
    Because this screen was recorded at 10fps cursor lagging / movement choppiness unfortunately is not recognisable.
    Last edited by roslja; 01-26-2016, 03:33 PM.

    #2
    Hello,

    Thank you for your post!

    So that I may look into a few more settings, could you please provide your log and trace files?

    You can do this by navigating to the Control Center -> Help -> Email Support.... Please reference 'ATTN Riley' in the body of the email.
    Riley S.NinjaTrader Customer Service

    Comment


      #3
      Hello roslja, I have an update.

      I had received your log and trace files and didn't see anything out of the ordinary. I was also able to reproduce the high CPU spikes when enabling the cross hairs and the global cross hairs on my end.

      I have reported this to our Product Management team who are currently monitoring this behavior, and will update you when I have more information on this.
      Riley S.NinjaTrader Customer Service

      Comment


        #4
        Hi Guys,

        I am also experiencing crosshair lag.

        NT7 is handling the cross-hair movement much better than NT8 in terms of CPU load. When monitoring the CPU load and moving the crosshair as fast as possible over a blank NT7 chart the CPU load is about 5%, conversely in NT8 it goes as high as 10% and the difference in fluidity is obvious. (both instances mentioned above of NT are disconnected from market)

        I am running and i7 with 16gb Ram with windows 10.

        Comment


          #5
          Originally posted by marty087 View Post
          Hi Guys,

          I am also experiencing crosshair lag.


          I am running and i7 with 16gb Ram with windows 10.

          What's your GPU?

          This is what NT8 crosshairs uses more.

          See this:

          http://ninjatrader.com/support/forum...ad.php?t=80750

          Comment


            #6
            Originally posted by sledge View Post
            What's your GPU?

            This is what NT8 crosshairs uses more.

            See this:

            http://ninjatrader.com/support/forum...ad.php?t=80750
            I am running 4 x 24" monitors on 2 x NVidia Gefore 210 1GBs.

            Thanks for sending through the link. Seems there is a bit of reading up for me to do here!

            Comment


              #7
              I am getting this same crosshair 'lag' as well.... My development PC runs Radeon R7 series and Intel i7 cpu with SSD drives. Using 4 monitors

              Comment


                #8
                How many charts are your using with global cross hair? Does no indicators perform better? Is this a 1 chart per monitor setup. I didn't test full size 1 monitor charts.

                Still had a replay setup - made 3 full size charts.. Moved around - felt fine, not too laggy. Could it be slightly faster? Perhaps..but compared to where we came from - it's an improvement.
                Last edited by sledge; 01-26-2016, 03:25 PM.

                Comment


                  #9
                  Sledge....I haven't spent a whole lot of time with this specific issue...but the times I noticed it, I didn't really have many charts with 'global crosshair' activated....(2-3 charts max). I always use a 'dash' or 'dot' crosshair line, and didn't think to test the other types.

                  Comment


                    #10
                    I also noticed this cross-hair lag as soon as I switched from NT7 to NT8 Beta 9.

                    My machine is no slouch, that's for sure. DirectX Rendering=HW.

                    The chop is easy to notice when you pass horizontally across the toolbar, then across the chart. The regular pointer works great, as does the cross-hair in NT7.

                    There is a drastic difference in CPU usage in simply waving the crosshairs over an idle chart.

                    EDIT: I tested and compared the CPU readings using Windows 10 task manager.

                    NT7 Pointer waving = 1% CPU
                    NT7 Cross-hair waving 3% CPU

                    NT8 Pointer waving 3% CPU
                    NT8 Cross-hair waving 25% CPU
                    Last edited by stefan_777; 02-26-2016, 06:24 PM.

                    Comment


                      #11
                      Just checking in to see if there is any headway with the chart graphics performance issues.

                      After playing around with charts, I've noticed that even moving lines or other objects around will cause the same significant spike in CPU.

                      I do have integrated Intel HD Graphics, however I can run many 3D applications without even to close to the fuss that I am getting with these 2D charts.

                      Comment


                        #12
                        Hello, I'm not sure if this is expected.

                        I have reached out to our Product Management team and will update you when I have more information in regards to this item.

                        Thank you for your feedback.
                        Riley S.NinjaTrader Customer Service

                        Comment


                          #13
                          Yep - experiencing the same - and I am using a Nvidia Titan X graphic card with Core i7 4.5Ghz (6 Cores) processor and 32GB RAM... so there is definite a performance issue

                          Comment


                            #14
                            I just downloaded NT8. I am having the same problem. Has this issue been resolved?

                            I just ordered a new video card for my 3 monitor system. I had an old Nvidia card. It is top off the line. Will this solve the issue?

                            Jamie

                            Comment


                              #15
                              Hello All, thank you all for your feedback!

                              I had tested this with the current version and was able to reproduce. I will resubmit a QA report and will update this thread when I have more information.

                              Thank you all for your patience.
                              Riley S.NinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by sun0781, Today, 05:02 PM
                              0 responses
                              6 views
                              0 likes
                              Last Post sun0781
                              by sun0781
                               
                              Started by ronhb107, 09-12-2019, 10:09 AM
                              4 responses
                              41 views
                              0 likes
                              Last Post Mr.Trader  
                              Started by rwilliam, Today, 03:55 PM
                              0 responses
                              3 views
                              0 likes
                              Last Post rwilliam  
                              Started by asmmbillah, Today, 03:42 PM
                              2 responses
                              8 views
                              0 likes
                              Last Post asmmbillah  
                              Started by NT-Roland, Today, 03:25 PM
                              0 responses
                              7 views
                              0 likes
                              Last Post NT-Roland  
                              Working...
                              X