• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

.NET version that NT 8 uses

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    .NET version that NT 8 uses

    I am unable to find the .NET version that NT 8 is built to use. I found a thread that indicates NT7 is built to 3.5; is NT 8 using a later version? I need this information for DLL compatibility.
    Thanks

    #2
    Hello TurtleBeach,

    Thanks for your post.

    Minimum PC Requirements
    Your PC must meet the minimum requirements listed below to run NinjaTrader 8
    Windows Vista (SP2) w/ Platform Update, Windows 7, Windows 8, Windows 10, Windows Server 2008 w/ Platform Update, Windows Server 2008 R2 or later

    • 1 gigahertz (GHz) or faster 32-bit or 64-bit processor
    • 2GB RAM
    • Microsoft .NET Framework 4.5
    • (pre-installed on most PC’s and can be downloaded here: Microsoft .NET Framework)
    • Screen resolution of 1024 x 768
    • DirectX10 compatible graphics card highly recommended

    Here is the full link: http://ninjatrader.com/support/helpG...quirements.htm
    Paul H.NinjaTrader Customer Service

    Comment


      #3
      TurtleBeach,

      NinjaTrader 8 uses .Net Framework 4.5.
      BrettNinjaTrader Product Management

      Comment


        #4
        Currently, there are versions 4.5, 4.5.1, and 4.5.2 available.
        Can we develop dlls in any of them and have ninjatrader load them succesfully?
        Can we develop in 4.5.3 if/when it becomes available?

        Comment


          #5
          Hello bboyle1234,

          Thanks for your post.

          The NT editor will only work with syntax that is valid for the version NT compiles at, anything outside of that version such as an external assembly would need tested to see if it can both load and execute the code.
          Paul H.NinjaTrader Customer Service

          Comment


            #6
            Thanks Paul, to be more eplicit, which framework version should our external assemblies target?

            Comment


              #7
              Hello bboyle1234,

              Thanks for your post.

              NinjaTrader 8 uses .Net Framework 4.5.
              Paul H.NinjaTrader Customer Service

              Comment


                #8
                Originally posted by bboyle1234 View Post
                Thanks Paul, to be more eplicit, which framework version should our external assemblies target?
                At the time, your assemblies need to target 4.5.0 to work with NinjaTrader 8.
                MatthewNinjaTrader Product Management

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by login_dejavu, Today, 09:03 AM
                0 responses
                1 view
                0 likes
                Last Post login_dejavu  
                Started by MavMoney, Today, 07:17 AM
                1 response
                5 views
                0 likes
                Last Post MavMoney  
                Started by jameslee001, Today, 08:09 AM
                0 responses
                5 views
                0 likes
                Last Post jameslee001  
                Started by bertochi, Today, 07:25 AM
                1 response
                2 views
                0 likes
                Last Post bertochi  
                Started by Kentoes, Today, 07:06 AM
                0 responses
                4 views
                0 likes
                Last Post Kentoes
                by Kentoes
                 
                Working...
                X