• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

This New Release Sucks

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    This New Release Sucks

    I downloaded and installed your mandatory release regarding your SSL certification, (at least that's what I think you reported), and since that time NT8 has been crashing regularly. First I had to recompile my custom ninjascripts, then I had to delete all my workspaces and start from scratch. Now it runs for a few minutes then locks up and I have to use task manager to close it. What the heck did you do? I re-ninstalled it four times before it would even run and now it is totally buggered up.
    Can you please fix this? I know it is a beta, but really, two steps forward and five steps back.
    WTF

    #2
    Hello daven,

    The mandatory upgrade was a requirement for NinjaTrader 7 and not for NinjaTrader 8.

    Failing to update NinjaTrader 7 to version 7.0.1000.31 will cause an interruption in service as the license key will not be able to verify.

    This is completely unrelated to NinjaTrader 8 in anyway.


    There are code breaking changes from NinjaTrader 8 Beta 8.0.0.8 to NinjaTrader 8 Beta 8.0.0.9. Specifically, if Dispatcher.Invoke is used instead of Dispatcher.BeginInvoke, this will cause the NinjaTrader UI to freeze requiring a forced restart.

    May I confirm that you have re-coded all scripts that have this code to work with the code breaking changes?
    Chelsea B.NinjaTrader Customer Service

    Comment


      #3
      I went back and looked at all of my custom indicators. None of them even use the dispatcher function so something else is breaking my code. I'm going to try and restore a backup and see if that fixes the problem.
      DaveN

      Comment


        #4
        I tried to restore with a backup from two days ago but NT wouldn't complete the process. I get an error message saying the backup would corrupt my existing installation of NT. What in the heck is going on with this most recent beta release? I think you have some other code-breaking stuff beyond what you noted.
        DaveN

        Comment


          #5
          Also just want to point out why I did the NT8 installation when it wasn't needed. When you click on the message you post when running NT8, you get the following information at the link:

          Mandatory Update for All NinjaTrader Users
          NinjaTrader is required to change a SSL certificate that is used in validating your license resulting in a mandatory software update. All users must update to the latest release prior to Saturday, February 27th. Failure to do so will result in disruption of service.

          ************************************************** *********************************
          Please follow the steps below to proceed with the update in advance of Saturday, February 27th. All workspaces, NinjaScript files, and other user settings will be maintained.

          NinjaTrader 7 Update Instructions
          1.Close NinjaTrader 7 if it is currently running. If you attempt to update before closing NinjaTrader, a complete uninstall/reinstall will be required.
          2.Download NinjaTrader 7.0.1000.31
          3.Step through the install process & complete to resume using NinjaTrader.

          NinjaTrader 8 Update Instructions
          1.Close NinjaTrader 8 if it is currently running.
          2.Download NinjaTrader 8.0.0.9
          3.Step through the install process & complete to resume using NinjaTrader.

          Please note that a high volume of support inquiries are expected during this time however, if you have follow-up questions, please contact us at [email protected].

          ▲View an important notice for Windows XP, Windows Server 2003 Users
          ************************************************** ******************************************

          Why would you put a link to download an NT8 update if it wasn't necessary, particularly when it is embedded in the message stating that the update is mandatory?

          Very confusing indeed.

          DaveN

          Comment


            #6
            Chelsea,
            Either you are wrong about the NT8 9 release being mandatory, or your messaging is incorrect. I don't know which it is. If it isn't mandatory I would like to re-install NT8. Could you point me to it please?

            Below is the message from Mathew indicating that the NT* 9 release is in fact mandatory. Read it yourself below:

            We just released NinjaTrader Version 8.0.0.9 (Beta).

            This is a mandatory update for all NinjaTrader 8 Beta users.

            NinjaTrader is required to change a SSL certificate that is used in validating your license resulting in a mandatory software update.

            All users must update to version 8.0.0.9 prior to Saturday, February 27th. Failure to do so will result in disruption of service.

            This release also contains over 100 bug fixes from the previous beta release. There may be previously reported bugs which are still outstanding. You may see a list of all of the issues resolved in this build from the release notes here.

            You may download here.

            Comment


              #7
              What windows are you using?

              Comment


                #8
                Windows 7 Pro

                Comment


                  #9
                  Do I need to install the mandatory NT8 vers 9 , or not. If not, can you point me to version 8?
                  DaveN

                  Comment


                    #10
                    Hi DaveN,

                    Our support was not informed about the mandatory update for NinjaTrader 8 Beta 9. I am inquiring with our development to get an answer and then update the rest of our support.

                    Thank you for including that statement from matthew as he will be correct.

                    Regardless, the final release of NinjaTrader 8 will require this change with the dispatcher. May I confirm that you have changed your code for this code breaking change?

                    Also, keep in mind that the beta may have further code breaking changes that require scripts to be re-written.
                    Chelsea B.NinjaTrader Customer Service

                    Comment


                      #11
                      Hi DaveN,

                      Our development has let me know that NinjaTrader 8.0.0.9 is a mandatory update.

                      I apologize for any confusion this may have caused. (Our support understanding was that this change was included with 8.0.0.7, but this was incorrect.)
                      Chelsea B.NinjaTrader Customer Service

                      Comment


                        #12
                        I have confirmed that none of my custom scripts have the dispatcher code in them. However, when I install the new version 09, it locks up after a few minutes. I've uninstalled it and re-installed it three times now, and I get the same result. I can only conclude that there is some other code-breaking element in one of my scripts but without a list of code-breaking elements I can't find it. Can I get that list?
                        DaveN

                        Comment


                          #13
                          Hi DaveN,

                          Try starting NT8 in safemode without the workspace loading.

                          To do this hold the Ctrl key as you click the NT8 icon to start NinjaTrader 8.

                          In safe mode without the workspace does NinjaTrader still freeze?
                          Can you open a chart with no indicators applied?

                          Below is a link to the code breaking changes.
                          http://ninjatrader.com/support/helpG...ng_changes.htm

                          A link to the pecific changes with 8.0.0.9.
                          http://ninjatrader.com/support/helpG...us/8_0_0_9.htm

                          And a link to the Multi-Threading considerations where the dispatcher information was updated about BeginInvoke().
                          http://ninjatrader.com/support/helpG...-threading.htm
                          Last edited by NinjaTrader_ChelseaB; 02-22-2016, 04:41 PM.
                          Chelsea B.NinjaTrader Customer Service

                          Comment


                            #14
                            Originally posted by daven View Post
                            I have confirmed that none of my custom scripts have the dispatcher code in them. However, when I install the new version 09, it locks up after a few minutes. I've uninstalled it and re-installed it three times now, and I get the same result. I can only conclude that there is some other code-breaking element in one of my scripts but without a list of code-breaking elements I can't find it. Can I get that list?
                            DaveN
                            One wonder if NT8 can be trusted for live trades after 5 years of development. No reason to switch from NT7 until NT8 is formally released and bug free.

                            If you really have to use NT8, perhaps upgrade to free Windows 10, I had no problem with NT8 update on Windows 10.

                            Cheers!

                            Comment


                              #15
                              Can someone from support comment on this? Is there any reason to believe that NT8 will run better on 10 than windows 7, and if true will NT7 run as well on Windows 10 as it does on Windows 7? I am having no issues with NT7 and that is where I live trade so the last thing I want to do is screw NT7 up.
                              DaveN

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by olivares_alfre, Yesterday, 02:19 PM
                              2 responses
                              12 views
                              0 likes
                              Last Post NinjaTrader_Marco  
                              Started by hiikila, Today, 02:40 AM
                              0 responses
                              1 view
                              0 likes
                              Last Post hiikila
                              by hiikila
                               
                              Started by Beauregard, Yesterday, 11:50 PM
                              0 responses
                              13 views
                              0 likes
                              Last Post Beauregard  
                              Started by renkodan, Yesterday, 11:56 AM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by J_o_s, 04-04-2020, 11:17 PM
                              1 response
                              8 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Working...
                              X