Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

AssemblyName vs. strategy/indicator-name

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    AssemblyName vs. strategy/indicator-name

    Hello,
    (1) after I developed a new assembly, I want to re-import the exported assembly under a different name for checking purposes.
    I have renamed the .dll and made a new .zip before the re-import. I noticed, that the imported assembly has the new name, but the strategy has the old name, declared under the #name-property. Is it possible for the future, to have an option to choose, wether I want to have the strategy name as same as the assembly name?

    (2) I have notice the following issue: I have successfully imported a strategy assembly, that is listed in the strategy-list. When I have removed this assembly (Tools->Remove assembly) and then re-import the changed assembly, it listed again under strategy-list, but it is the old strategy with out the made changes. To fix this, I have to restart NT8. Is there an other way to avoid a restart after re-import the same (changed) assembly?

    Thanks.

    regards,
    Lutz
    Last edited by sigworks; 03-19-2016, 11:55 AM.

    #2
    Hello,

    Thank you for the questions.

    Unfortunately an assembly does not work in the way you are asking, also it would not be suggested to rename the files as that can be confusing on what its contents actually are.

    An assembly is a compiled collection of code which can be in a unprotected or protected state. There is no way to modify its contents after it is in assembly form and no way to tell the platform to use anything other than what it already does for getting the name from the file.

    for testing, you would simply need to remove the original source code temporarily so you can import the item or use a different PC/Virtual machine.

    The most simple way to test a compiled assembly would be:
    1. Export the item first as Source Code to a safe location.
    2. Next export the item to an Assembly to a different location.
    3. Click Tools -> Edit NinjaScript -> Strategy -> Select the file and delete it to remove the source code
    4. Now you can import the assembly for testing, when done testing use the File -> Utilites -> Remove NinjaScript Assembly menu to remove it.
    5. If you had completed the first step, you will still have the source code which you can now re import to continue working on the item.



    For compiled assemblies, because these are loaded into memory a restart would be required to load the new file.

    I am unsure of the process you are following as this generally only needs to be tested once after you are done working on the item and have exported it as a compiled assembly. In general most testing will be completed as source code which does not require a restart. Is there a specific reason you are exporting to compiled each time which would require a restart to load the new code?

    I look forward to being of further assistance.
    JesseNinjaTrader Customer Service

    Comment

    Latest Posts

    Collapse

    Topics Statistics Last Post
    Started by MonteK, Yesterday, 09:31 PM
    0 responses
    25 views
    0 likes
    Last Post MonteK
    by MonteK
     
    Started by nkhoi, Yesterday, 09:27 PM
    1 response
    11 views
    0 likes
    Last Post NinjaTrader_ChelseaB  
    Started by SuperDude123, Yesterday, 03:52 PM
    4 responses
    26 views
    0 likes
    Last Post NinjaTrader_ChelseaB  
    Started by ErikY, Yesterday, 01:16 PM
    1 response
    25 views
    0 likes
    Last Post NinjaTrader_ChelseaB  
    Started by BullyWig Trader, Yesterday, 12:42 PM
    1 response
    17 views
    0 likes
    Last Post NinjaTrader_ChelseaB  
    Working...
    X