• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Custom AddOn with add'l DLLs - type info error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Custom AddOn with add'l DLLs - type info error

    I am writing a custom addon which requires 3 additional DLLs besides the addon. When I copy these to the bin/Custom folder I get an error when NT loads -- it pops up an error msg saying:

    "Unable to retrieve type info for 'NinjaTrader.NinjaScript.AddonBase' from assembly 'otherRefedAssembly' Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information"

    Where: otherRefedAssembly is one of the additional assemblies my addon is referencing. How do I tell NT not to look at those DLLs?

    My AddOn works but having this error popup every time NT starts up is not going to make my users happy.

    Thanks for any assistance on this.

    #2
    Hello,

    Thank you for the question.

    I will need to look further into the error, would you be able to either provide a link to or submit the assembly causing the message for testing? If this is a private assembly please email me at platform support @ ninjatrader.com.

    I look forward to being of further assistance.
    JesseNinjaTrader Customer Service

    Comment


      #3
      Hi Jesse,

      I've attached a zip with the 3 dlls . The one it pops the message up on is GalaSoft.MvvmLight.Platform
      Last edited by EquityBoost; 05-23-2016, 12:38 PM.

      Comment


        #4
        Hello,

        Thank you for providing the files, I will see what I can determine after testing these.

        I look forward to being of further assistance.
        JesseNinjaTrader Customer Service

        Comment


          #5
          Hello,

          It seems the zip file does not have all the needed references, because this item is listed in NuGet's library we can use visual studio to discover the needed references.

          The error message specifically in this case is because the 3 assemblies being loaded also require other assemblies to be able to load.

          I composed a short video that goes over the steps to do this, likely in the future this process could assist in discovering references for other libraries you may use.

          http://screencast.com/t/ufVBWP3jzk

          I look forward to being of further assistance.
          JesseNinjaTrader Customer Service

          Comment


            #6
            Thanks Jesse,

            I had missed the Windows.System.Interactivity.dll.

            Appreciate your making the video!

            Brian

            Comment


              #7
              umesh,

              You should start a new topic because this topic doesn't have anything to do with your issue. I hope you get it resolved!

              Comment

              Latest Posts

              Collapse

              Topics Statistics Last Post
              Started by countjoemoney, Today, 01:16 PM
              0 responses
              10 views
              0 likes
              Last Post countjoemoney  
              Started by fx.practic, Today, 12:59 PM
              0 responses
              7 views
              0 likes
              Last Post fx.practic  
              Started by TheNomadicAspie, Today, 12:07 PM
              0 responses
              8 views
              0 likes
              Last Post TheNomadicAspie  
              Started by alcorr247, Today, 12:04 PM
              0 responses
              9 views
              0 likes
              Last Post alcorr247  
              Started by firstlanetech, Today, 11:24 AM
              1 response
              22 views
              0 likes
              Last Post firstlanetech  
              Working...
              X