• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

continuous contracts for Rithmic

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    continuous contracts for Rithmic

    can someone please tell me the symbols for continuous contracts on Rithmic?

    Thank you.

    #2
    Hello,

    You can type into the chart ES ##-## for a continuous S&P Emini contract, GC ##-## for a Comex Gold continuous contract.

    To add this to your default instrument list, go to the Control Center>Tools>Instrument Manager. Then select the ES contract, and under the Expiry drop down, scroll to the bottom and select ##-## then hit the < button to add it to your default list.

    Another option is to go to Control Center>Tools>Options and select the Data Tab. Under the Merge Policy dropdown you could select MergeNonBackAdjusted or MergeBackAdjusted. Then click on your chart and reload historical data. I have provided a link to our Helpguide which details the differences in Merge Policies.

    Note for any continuous contract you likely will have to right click on your chart>Data Series and set Days to Load=How many days of data you’d like to look at.

    See Understanding Merge Policy Section of our Helpguide:
    http://ninjatrader.com/support/helpG...rical_data.htm

    Please let us know if we may be of further assistance.
    Alan P.NinjaTrader Customer Service

    Comment


      #3
      Thanks Alan, but that solution is for NinjaTrader 7, for Ninja 8 doesn't work. How would be in Ninja 8 ?

      Comment


        #4
        Hello,

        Sorry for the oversight.

        Rithmic does not support continuous contracts written as ##-##. What you can do is go to Tools>Instruments> then find and select the contract you’re interested in seeing a continuous contract for, right click “edit”. Under the properties you’ll see Merge Policy. Set that to MergeBackAdjusted or MergeNonBackAdjusted. Note this only effect this contract.

        Alternatively you can have all you’re contracts default to a merge policy by changing the Global Merge Policy via Tools>Options select Market Data tab and set merge policy to MergeBackAdjusted or MergeNonBackAdjusted.

        Now pull up a chart for the symbol you’re interested in, right click on the chart>Data Series. Set ‘Days to Load’=to the amount of days you’d like to be included.

        I've included a link to the Merge Policy section of our helpguide:

        https://ninjatrader.com/support/help...rge_policy.htm

        Please let us know if we may be of further assistance.
        Alan P.NinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by ericson, Today, 08:14 PM
        0 responses
        5 views
        0 likes
        Last Post ericson
        by ericson
         
        Started by user1986, Today, 07:28 PM
        1 response
        7 views
        0 likes
        Last Post user1986  
        Started by jertrade, Today, 06:57 PM
        0 responses
        5 views
        0 likes
        Last Post jertrade  
        Started by Emma1, Today, 02:42 PM
        1 response
        17 views
        0 likes
        Last Post NinjaTrader_DrewO  
        Started by fx.practic, Today, 03:10 PM
        1 response
        6 views
        0 likes
        Last Post NinjaTrader_Jesse  
        Working...
        X