• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

How do I resolve NinjaScript Programming Errors?

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    How do I resolve NinjaScript Programming Errors?

    Applies to NinjaTrader 7

    You may come across various situations where your NinjaScript files will not compile. This can include situations such as:
    • You are trying to import a NinjaScript Archive File and you receive an error such as "You have custom NinjaScript files on your PC that have programming errors..."
    • You are new to NinjaScript development and somehow your files will no longer compile
    Because importing NinjaScript files requires compilation of your entire NinjaScript library you will first need to resolve the errors to allow for a successful compilation.

    1st Step in Resolving Errors:
    1. Backup NinjaScript files (File > Utilities > Backup, ensure that "NinjaScript Files" is checked and then press the "Run Backup" button) in version 6.5 or later
    2. Open any indicator via the menu Tools > Edit NinjaScript > Indicator
    3. Press the "F5" key on your keyboard to compile your NinjaScript library. A list of errors will appear at the bottom of the NinjaScript Editor along with the file name where each error is located.
    4. Determine if you no longer need the NinjaScript file with the errors. If you no longer need it, skip to step 9.
    5. Double click on the error message to open the NinjaScript with the errors. Try to resolve the error and recompile by pressing the "F5" key.
    6. If the error still exists in this file, "comment out" some or all of the content in the OnBarUpdate() method and recompile by pressing the "F5" key
    7. If errors still exist in this file, "comment out" some or all of the content in the Initialize() method and recompile by pressing the "F5" key
    8. If errors still exist in this file, "comment out" any properties that in the "Properties" region that may be causing the problems and recompile by pressing the "F5" key
    9. If errors still exist in this file, try to delete the indicator/strategy (See "To delete the erroneous file" instructions below)
    10. If another NinjaScript file references a file you wish to delete, open the file that references the file you wish to delete and "comment out" or delete the reference
    11. Repeat steps 2 through 10 for every NinjaScript that still has errors
    To delete the erroneous file:
    1. Tools > Edit NinjaScript > "Select either Indicator or Strategy depending on what type of file you want to delete
    2. Highlight the NinjaScript file you wish to delete and press the "Delete" button
    3. If another NinjaScript file references the file you wish to delete, you must first remove the reference to the file you wish to delete, see step 10 above
    4. Press the "Cancel" button to close the NinjaScript file dialog window
    How to "comment out" code:
    Commenting out code simply means to identify code which will be treated as a comment (not processed) as opposed to actual program code. This can be done by adding "//" in front of each line of code. Below is an example.

    Code:
    double myDouble = 5;
    // double myDouble = 5;
    2nd Step in Resolving Errors:
    If the above procedure does not resolve all errors, you may need to reinstall NinjaTrader.
    1. Backup any files you wish to back up (File > Utilities > Backup version 6.5 or later)
    2. Shut down NinjaTrader
    3. Uninstall NinjaTrader from the windows Control Panel Add/Remove Programs
    4. Manually delete the folder My Documents\<NinjaTrader Installation Folder>
    5. Clear you temporary internet files in your internet browser (browser cache)
    6. Reinstall the latest version of NinjaTrader from our website
    Last edited by NinjaTrader_Jesse; 06-03-2015, 11:59 AM.
    RayNinjaTrader Customer Service

    #2
    Applies to NinjaTrader 8

    You may come across various situations where your NinjaScript files will not compile. This can include situations such as:
    • You are trying to import a NinjaScript Archive File and you receive an error such as "You have custom NinjaScript files on your PC that have programming errors..."
    • You are new to NinjaScript development and somehow your files will no longer compile


    Because importing NinjaScript files requires compilation of your entire NinjaScript library you will first need to resolve the errors to allow for a successful compilation.

    1st Step in Resolving Errors:
    1. Backup NinjaScript files (Tools > Export > Backup File, ensure that "NinjaScript Files" is checked and then press the "Export" button) .
    2. Open the NinjaScript Editor via the menu New > NinjaScript Editor
    3. Press the "F5" key on your keyboard to compile your NinjaScript library or right click in the window and click "Compile". A list of errors will appear at the bottom of the NinjaScript Editor along with the file name where each error is located.
    4. Determine if you no longer need the NinjaScript file with the errors. If you no longer need it, skip to step 9.
    5. Double click on the error message to open the NinjaScript with the errors. Try to resolve the error and recompile by pressing the "F5" key.
    6. If the error still exists in this file, "comment out" some or all of the content in the OnBarUpdate() method and recompile by pressing the "F5" key
    7. If errors still exist in this file, "comment out" some or all of the content in the OnStateChange() method and recompile by pressing the "F5" key
    8. If errors still exist in this file, "comment out" any properties that in the "Properties" region that may be causing the problems and recompile by pressing the "F5" key
    9. If errors still exist in this file, try to remove the file from compilation or delete the file (See "To remove or delete the erroneous file" instructions below)
    10. If another NinjaScript file references a file you wish to delete, open the file that references the file you wish to delete and "comment out" or delete the reference
    11. Repeat steps 2 through 10 for every NinjaScript that still has errors



    To remove or delete the erroneous file:
    With NinjaTrader 8, we now have the option to remove a file from compilation but not delete it.
    This means all your code is intact but is not compiled so it will not produce errors. This also means the item is not available for use until you add it back into compilation.
    1. Open the NinjaScript Editor via the menu New > NinjaScript Editor
    2. Highlight the NinjaScript file you wish to prevent from being compiled, Right click on it and click "Exclude from Compilation".
    3. If another NinjaScript file references the file you wish to delete, you must first remove the reference to the file you wish to delete, see step 10 above
    4. You also have the option to completely delete the file as well, this is the same process as above except you would select "Remove" instead.


    2nd Step in Resolving Errors:
    If the above procedure does not resolve all errors, you may need to reinstall NinjaTrader.
    1. Backup NinjaScript files (Tools > Export > Backup File, ensure that "NinjaScript Files" is checked and then press the "Export" button) .
    2. Shut down NinjaTrader
    3. Uninstall NinjaTrader from the windows Control Panel Add/Remove Programs
    4. Manually delete or move the folder My Documents\NinjaTrader 8
    5. Reinstall the latest version of NinjaTrader from our website
    Last edited by NinjaTrader_Jesse; 06-11-2015, 11:10 AM.
    JesseNinjaTrader Customer Service

    Comment

    Latest Posts

    Collapse

    Topics Statistics Last Post
    Started by demo166130, Today, 08:26 AM
    1 response
    3 views
    0 likes
    Last Post NinjaTrader_JoshG  
    Started by demo166130, Today, 08:36 AM
    1 response
    3 views
    0 likes
    Last Post NinjaTrader_Jim  
    Started by demo166130, Today, 08:25 AM
    2 responses
    5 views
    0 likes
    Last Post NinjaTrader_JoshG  
    Started by YoutingChu, Today, 08:02 AM
    1 response
    4 views
    0 likes
    Last Post NinjaTrader_ChrisL  
    Started by ArchakovDenis, Today, 05:27 AM
    1 response
    6 views
    0 likes
    Last Post NinjaTrader_Jesse  
    Working...
    X