Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Disturbance in a chart's smooth operation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Disturbance in a chart's smooth operation

    I have several indicators using multiple additional series as input series. When I open a chart using a single DataSeries e.g. a 5min chart, there's no problem as long as I am loading sufficient days. The chart and the indicators run smoothly (using as additional series 60min, 120min,.. up to 720min).

    But when I open a chart and use two Data Series e.g. a 5Min chart, adding a 15min DataSeries, and then want to use my indicator, then the problem begins. The problem I run into is that it makes the charts flicker/freeze up briefly (for a few seconds) with little white boxes appearing at the top right corner of the chart. These show up either when loading the chart, when I change to another instrument or when I change a setting in one indicator in that chart. If I disregard this "disturbance", then after these few seconds, everything seems to run smoothly, but later on -sometimes after an hour and seemingly out of the blue-, the flicker/freeze up repeats/occurs and eventually can hang up NT altogether.

    I have tried all kind of things but have not managed to get this resolved. The Log tab in the ControlCenter, as well as Log and Trace files do not show anything.

    Do you have any suggestion?

    sandman

    #2
    Hello sandman,

    Thanks for the post.

    I'm not sure what is going on in the custom code. You would need to profile your code to see why it is causing performance issues.

    Below I will provide the link to the general performance tips for NinjaTrader:

    https://ninjatrader.com/support/help...ance_tips2.htm

    Reducing the days to load could help with this, but the code will need to be tested further to find the exact reason.

    Please let me know if I can assist further.
    Chris L.NinjaTrader Customer Service

    Comment


      #3
      The link you provided is for NT8. This is the forum's NT7 section which is also what I am using. Is there a separate link for NT7?

      sandman

      Comment


        #4
        Hello sandman,

        Sorry about that, here is the NT7 link:

        https://ninjatrader.com/support/help...ance_tips2.htm
        Chris L.NinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by Hyper, Today, 05:13 PM
        0 responses
        2 views
        0 likes
        Last Post Hyper
        by Hyper
         
        Started by NeverDownMoney, Today, 02:42 PM
        3 responses
        12 views
        0 likes
        Last Post NinjaTrader_ChrisL  
        Started by localappleseed, Today, 02:20 PM
        1 response
        13 views
        0 likes
        Last Post NinjaTrader_Jim  
        Started by asmmbillah, Today, 02:48 PM
        1 response
        19 views
        0 likes
        Last Post NinjaTrader_BrandonH  
        Started by KacemRhaz, Today, 01:31 PM
        3 responses
        15 views
        0 likes
        Last Post NinjaTrader_ChristopherD  
        Working...
        X