• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Targeting framework

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Targeting framework

    Hello,

    is it possible to change targeting framework from 3.5 to 4.5?
    I have tried it in the properties of the project in VS, it seemed it works.
    But when I used some libraries from the new version and compiled the scripts in NT compilator, there was an error that it's unknown functions or something like that..

    Please could you tell me the right procedure to change the targeting framework?

    Thanks a lot.

    #2
    Hello Luigo,

    Thanks for your post.

    We only support editing NinjaScripts in the NinjaScript Editor and do not offer a supported means to compile the custom NinjaScript assembly for NinjaTrader 7 in Visual Studio. Because of this we would not be able to support using a newer .NET version than what NinjaTrader 7 uses. (This also could create potential issues for legacy compatibility where these NinjaScripts may work on the newer .NET framework than what a client's NinjaScript Editor targets)

    That said, it is possible to use Visual Studio for source code editing, but you will still have to use the NinjaScript Editor to compile your changes. My colleague Jesse has a demonstration video showing the steps that can be taken to use Visual Studio for editing. References will need to be added for NinjaTrader.Core.dll and WilsonORMapper.dll. I'll provide a link to this video below.

    Jesse's demonstration for using Visual Studio with NinjaTrader 7 - http://www.screencast.com/t/eH7y5cedlzh

    I may also like to point out a thread where users have targeted a newer version of .NET with NinjaTrader 8. Keep in mind, this would be unsupported, but may be of interest to you.

    Targeting a different version of .NET for NT8 - https://ninjatrader.com/support/foru...ad.php?t=79605

    Please let us know if we can be of further assistance.
    JimNinjaTrader Customer Service

    Comment

    Latest Posts

    Collapse

    Topics Statistics Last Post
    Started by NinjaCustomer, Today, 10:06 AM
    0 responses
    2 views
    0 likes
    Last Post NinjaCustomer  
    Started by crabman777, Today, 09:52 AM
    1 response
    5 views
    0 likes
    Last Post NinjaTrader_Jesse  
    Started by Arkadiy_B, Today, 06:43 AM
    0 responses
    2 views
    0 likes
    Last Post Arkadiy_B  
    Started by leontancfa, Today, 06:09 AM
    1 response
    10 views
    0 likes
    Last Post NinjaTrader_PatrickG  
    Started by soulfx, 12-01-2017, 08:44 AM
    3 responses
    1,020 views
    0 likes
    Last Post NinjaTrader_EricB  
    Working...
    X