• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

New Install Problem.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New Install Problem.

    I have been running NinjaTrader on my laptop for several weeks with no issues.

    I just bought a Win 8 desktop, and installed Ninjatrader7 64b.

    It seems to run and connect fine, but none of the sounds work except "connected" and "connection lost".

    I've checked the settings general tab, and all the sounds are activated. I've gone to the sounds folder and played them with windows media player.

    Is there anything else I should check? Not sure why two alert sounds would work, and the rest not when they are all activated.

    Thanks for any help, I hope this is the right forum as its one of the few that sounded likely that i could start threads in.

    #2
    Hello,

    When you play them in Windows Media Player, do they all work, or just the two you mentioned?

    Can you double check that your sound mixer is not being muted when the other sounds should be playing?

    - Click on the Speaker Icon in your System Tray (next to the clock) and then from the small volume control window, click on "mixer" option at the bottom. This will brig up the Volume Mixer for your computer.

    Please note that you will only initially see the applications that are currently displaying sounds.

    If you do not see a NinjaTrader control at this time, please try placing a sim order to prompt the "order filled" sounds.

    Once a sound has been generated from NinjaTrader, you will see the volume control for NinjaTrader. Please make sure this hasn't be turned off/muted.
    MatthewNinjaTrader Product Management

    Comment


      #3
      "Sim101" shows up after hitting the speaker icon.

      When I place a sim order, the name changes to "confirm order placement" on the speaker menu... but no sound is played when the order is placed.

      I went back to check, all the sounds play in WMP.


      Comment


        #4
        Right click your Speaker icon near the Clock -> Select Playback Devices

        Select the Default Speakers or Default Device and press Configure.

        Set the Audio Channels to 'Stereo' in the Speaker Setup guide and then finish the guide.

        Restart NinjaTrader and try placing a SIM101 order to see if you hear any sounds.
        MatthewNinjaTrader Product Management

        Comment


          #5
          Done and no joy on the sound.

          Just not sure whats causing it...

          Is there a way I can save my Sim account data so I can reinstall NinjaTrader if needed? (I've been tracking it before I go to live trading.. Been doing really well so am about to want to go live.)

          Thanks for the assistance so far. Hopefully we can get it sorted out. It works on my ancient laptop, but not the new desktop. Wanted the more stable new computer for going on to live trading.



          EDIT: I also tried the above in both 64b and standard... nothing there, but was not expecting it to.
          Last edited by DD_Properties; 03-21-2013, 02:20 PM.

          Comment


            #6
            Hello,

            This is Cameron responding on behalf of Matthew.

            To backup your historical trade data, use the built in backup utilitie.

            You can access this Utility from the Control Center -> File -> Utilities -> Backup. The dialog window that appears has checkboxes for what you would like to backup and a location default to <My Documents>\Ninja Trader Backup\

            The following link is to our Help Guide on Backups.
            http://www.ninjatrader.com/support/h...up_archive.htm

            http://www.youtube.com/watch?v=zGCp9...ure=plpp_video
            CameronNinjaTrader Customer Service

            Comment


              #7
              Thank you, I'll back up my data, and uninstall, re-download, and reinstall.

              I'll report back if there are any changes.

              Thanks for the responses, most forum help is not so quick.

              Comment


                #8
                UPDATE: I figured out some of what is going on, though I dont know why NinjaTrader has an issue with it.

                My computer has built in sound on the motherboard. I installed a Samsung HDMI Monitor that can recieve its sound through the HDMI cable.

                I had the default sound device set to be the motherboard jack, with external speakers attached. This was fine in every program I have except NinjaTrader.

                When I disable "Stereo Speakers", and enable "HDMI Audio" NinjaTraders sound works fine through the monitor. Disabling "HDMI Audio" and re-enabling "stereo speakers" silences NinjaTrader again but all other programs/games work fine.

                This is a temporary solution as disabling/enabling audio devices based on what program I want to run is not very professional. Hopefully its just an overlooked setting in an .ini file or something.

                Comment


                  #9
                  Hello,

                  Which device is set to 'Default'?


                  Have you tried disabling the HDMI and restarting your PC?


                  What video card/device are you using? Are you able to access the Audio software or driver interface for this device?
                  CameronNinjaTrader Customer Service

                  Comment


                    #10
                    The stereo speakers are "default" when NinjaTraders sound is not working, but NinjaTrader sound works when I set the HDMI to be the default.

                    I'll try disabling the HDMI and restarting when I'm done trading for the day, I did disable the HDMI but did not restart, and that had no effect on NinjaTrader. It still had no sound.

                    Comment


                      #11
                      Disabling the HDMI Audio and restarting did nothing. Still no NinjaTrader sound till it was re-enabled and set as the device.

                      The video card that this cable is through is a GeForce GTX 650. The monitor just plugs into its HDMI port and gets audio (if enabled) and video through the HDMI cable.

                      Looking in my Device Manager...
                      Under "Audio inputs and outputs", There is a monitor icon labeled "NVIDIA High Definition Audio".

                      But I'm not sure why NinjaTrader would be trying to use this even when it is not the default, or even completely disabled. odd.

                      Comment


                        #12
                        Hello,

                        Unfortunately we aren't sure why NinjaTrader is trying too use HDMI instead of your sound card/speakers.

                        Can you check the Nvidia control panel to disable HDMI Audio?

                        Please see the steps below.

                        http://www.evga.com/support/faq/afmv...px?faqid=58741

                        You may need to restart both NinjaTrader and your PC.
                        CameronNinjaTrader Customer Service

                        Comment

                        Latest Posts

                        Collapse

                        Topics Statistics Last Post
                        Started by safbrathpro, Today, 05:51 AM
                        0 responses
                        4 views
                        0 likes
                        Last Post safbrathpro  
                        Started by abfefmu, Today, 05:33 AM
                        0 responses
                        4 views
                        0 likes
                        Last Post abfefmu
                        by abfefmu
                         
                        Started by bbdjad, Today, 04:36 AM
                        0 responses
                        4 views
                        0 likes
                        Last Post bbdjad
                        by bbdjad
                         
                        Started by mittie3, Today, 03:33 AM
                        0 responses
                        7 views
                        0 likes
                        Last Post mittie3
                        by mittie3
                         
                        Started by Againmain1, Today, 03:04 AM
                        0 responses
                        10 views
                        1 like
                        Last Post Againmain1  
                        Working...
                        X