Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Delete Indicator Plot

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Delete Indicator Plot

    How do I delete an indicator plot in a strategy? I don't want the MAs to show on the chart. Thanks.

    #2
    Originally posted by JerryA View Post
    How do I delete an indicator plot in a strategy? I don't want the MAs to show on the chart. Thanks.
    If you do not add the plots to your strategy then the plots will not appear.

    Comment


      #3
      Hello JerryA,

      You will need to remove and Add() methods from the Initialize() that are adding indicators. This is how they will get added to the chart for visual display.
      Cal H.NinjaTrader Customer Service

      Comment


        #4
        Thanks - that did it.

        Comment


          #5
          indicator plot doesn`t delete from the indicator pane

          Hi,

          can you guys suggest ho do i remove the plot from the indicator pane?I removed the Add() from the initialize region,reloaded the indicator but the plot is still in the lower pane and in the indicator menu,as well.

          Thanks
          Attached Files

          Comment


            #6
            Hello,

            Thank you for the question.

            This could be two different items.

            If you change anything in the Initialize section, you need to remove the indicator from the cart completely and apply the change. After doing this you can re add the indicator to refresh the indicator, a F5 or right click -> Reload NinjaScript will not refresh items changed in Initialize. Try this, if this does not resolve it then you may need to look in the properties section of the script.

            If the above did not resolve it look near the bottom of the script of if you have a Properties section look for a line similar to this:

            Code:
            public DataSeries SomePlotName
            {
            	get { return Values[0]; }
            }
            If you see a section like this, it may be the cause as well.

            I look forward to being of further assistance.
            JesseNinjaTrader Customer Service

            Comment


              #7
              Originally posted by NinjaTrader_Jesse View Post
              Hello,

              Thank you for the question.

              This could be two different items.

              If you change anything in the Initialize section, you need to remove the indicator from the cart completely and apply the change. After doing this you can re add the indicator to refresh the indicator, a F5 or right click -> Reload NinjaScript will not refresh items changed in Initialize. Try this, if this does not resolve it then you may need to look in the properties section of the script.

              If the above did not resolve it look near the bottom of the script of if you have a Properties section look for a line similar to this:

              Code:
              public DataSeries SomePlotName
              {
              	get { return Values[0]; }
              }
              If you see a section like this, it may be the cause as well.

              I look forward to being of further assistance.

              Still there,as you can see in the image attahced.I did as i was told,no Add() method in the initialize,no lines in the Properties section.Nothing,but HSDetect is still in the menu!
              Attached Files

              Comment


                #8
                Originally posted by outsource View Post
                Still there,as you can see in the image attahced.I did as i was told,no Add() method in the initialize,no lines in the Properties section.Nothing,but HSDetect is still in the menu!
                Did you remove the indicator first, and then put it back on the chart?

                Comment


                  #9
                  Originally posted by koganam View Post
                  Did you remove the indicator first, and then put it back on the chart?
                  When i`ve first done it - no.But then i repeated all the procedure suggested by support,but as you can see it`s still there.I even restarted the platform and re-booted machine.What else should i do,re-instal Windows?lol...kidding.

                  Comment


                    #10
                    The original indicator HSIdentify had a plot. Of course, it is possible to remove the plot. On order to make the changes effective you need to compile via F5. Then you need to remove the indicator from your chart and add it again.

                    If you still have the plot shown after this exercise, then it means that you did not compile correctly or did not remove and add the plot again.

                    Comment


                      #11
                      Hey guys are you have nothing to do,really?

                      Like i said,i did as i was told, - i removed everything named "Plot" from the code,then i compile the script.What do you mean i`ve compiled it incorrectly??It either compiles or not.Why don`t you take the trouble and check it instead of writtin that was already written multiple times..

                      Comment


                        #12
                        Originally posted by outsource View Post
                        Hey guys are you have nothing to do,really?

                        Like i said,i did as i was told, - i removed everything named "Plot" from the code,then i compile the script.What do you mean i`ve compiled it incorrectly??It either compiles or not.Why don`t you take the trouble and check it instead of writtin that was already written multiple times..
                        I have removed the lines as needed and the plot disappears.
                        Attached Files
                        Last edited by Harry; 03-26-2015, 12:25 PM.

                        Comment


                          #13
                          Originally posted by outsource View Post
                          Hey guys are you have nothing to do,really?

                          Like i said,i did as i was told, - i removed everything named "Plot" from the code,then i compile the script.What do you mean i`ve compiled it incorrectly??It either compiles or not.Why don`t you take the trouble and check it instead of writtin that was already written multiple times..
                          (emphasis mine in blue)
                          Actually I asked if you removed the indicator from the chart and reapplied it: not if you 'removed everything named "Plot" from the code'. If I misspoke, then please forgive me.

                          Comment

                          Latest Posts

                          Collapse

                          Topics Statistics Last Post
                          Started by Lloyd143, Today, 05:24 PM
                          1 response
                          18 views
                          0 likes
                          Last Post NinjaTrader_ShawnB  
                          Started by Hagar, Today, 04:38 PM
                          1 response
                          14 views
                          0 likes
                          Last Post NinjaTrader_ShawnB  
                          Started by [email protected], Today, 04:49 PM
                          0 responses
                          11 views
                          0 likes
                          Last Post bpatel20@gmail.com  
                          Started by forrestang, Today, 02:05 PM
                          3 responses
                          24 views
                          0 likes
                          Last Post NinjaTrader_ChrisL  
                          Started by harryodell55, Today, 01:30 PM
                          3 responses
                          27 views
                          0 likes
                          Last Post NinjaTrader_ChrisL  
                          Working...
                          X