• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Indicator window not displaying parameters

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Indicator window not displaying parameters

    Hello,

    I have added a custome indicator programmatically via my strategy code. The indicator loads and properly appears on the chart. However, when I right-click on the chart and select Indicators, the parameter/settings window is blank. I am therefore unable to modify any parameters.

    Attached are two images that display the indicator window with the settings correctly display (named Correct) and the empty window as generated from the strategy's addition of the indicator (named Incorrect).

    Can you please advise how I might get the indicator settings to display in the window when I add the indicator via my strategy code?

    Thank you.

    Click image for larger version

Name:	Correct.PNG
Views:	1
Size:	85.2 KB
ID:	903257

    Click image for larger version

Name:	Incorrect.PNG
Views:	1
Size:	77.0 KB
ID:	903258

    #2
    Hello,

    Thank you for the images.

    This would be expected because the indicator was added using script, its properties are purposefully removed so that the indicator is sure to match the strategy and the settings the strategy had provided.

    If you need to modify the settings, you would need to either change the settings in the strategy where you add the indicator, or do not add the indicator using script and manually add it to the chart.

    I look forward to being of further assistance.
    JesseNinjaTrader Customer Service

    Comment


      #3
      Your reply is completely logical, however, I am a bit puzzled because I have added indicators via script in numerous other strategies and the indicator window is still always populated.

      By virtue of adding the indicator via script, I do not actually need to modify the parameters, but was trying to understand the change in behavior as compared to the many other times I have done this.

      Thank you.

      Comment


        #4
        Hello,

        Thank you for the reply.

        You are correct in the sense that some indicators do display items in the properties menu, mainly just Plots when added from a strategy. In this case the selected indicator has nothing that could be configured when added by strategy so it is blank. If instead you added an SMA, you would see a single SMA plot listed.

        This could be due to the way that specific indicator is programmed or could be that it does not have any plots. Based on the first image I can not see if this does have any plots or not, I would assume not if they are not being displayed.

        Because this item does not have anything that will display when added from strategy, you could utilize Print statements from within the strategy and Print specific indicator values. This may not be the most desirable way to view the changes but would provide more insite than a blank properties grid. Also you could use DrawingObjects with the indicator values in question to get a visual display of the data on the chart of either an object or a text.

        I look forward to being of further assistance.
        JesseNinjaTrader Customer Service

        Comment


          #5
          Using Prints will work. I was just trying to understand if this behavior was unusual and indicative of a problem with my code.

          Comment


            #6
            Jesse,

            I had one follow-up question that relates to the same indicator, but deals with the actual appearance of the chart. When I load the indicator via my script or manually, I get a very compressed appearance that I cannot view well. This is shown in the attachment named Squished. The way the chart should appear is shown in the attachment named Correct.

            I suspect my issue has something to do with bar spacing and/or compression. Can you please suggest some chart parameters that I might consider changing to remedy the appearance of Squished?

            Thank you.

            Isaac

            Comment


              #7
              Indicator window not displaying parameters

              Sorry - it appears the attachments were not appended to my reply.

              Adding....
              Attached Files

              Comment


                #8
                Hello,

                Thank you for the question.

                I would agree with you now that I can see the images, this looks to be a bar spacing/bar size issue related to the indicator. If you need to increase the bar width or spacing to display this correctly this would be due to the way the script is programmed. There is no supported way to adjust the bar spacing and size from script so this is likely just using the chart defaults to start.

                For this specifically, if you can I would suggest reaching out to the author of this item to see if they have any other versions that include a fix for the spacing. Otherwise this would be a side effect of this specific indicator.

                I look forward to being of further assistance.
                Last edited by NinjaTrader_Jesse; 09-03-2015, 07:09 AM. Reason: new images were uploaded that changed the response
                JesseNinjaTrader Customer Service

                Comment


                  #9
                  Thank you.

                  I had just resent the attachments since they did not append in my prior post. See the post stamped at 9:05 am.

                  The issue is with the horizontal scaling, not the vertical. There is no "F" in the upper right corner and I have set AutoScale to both true and false, yet the issue persists. I have read the indicator code thoroughly and the chart properties are not being modified internally.

                  If I drag the horizontal scroll bar to the left, the issue improves. I just am not sure which setting this is modifying and would like to know how to do this programmatically.

                  Thank you.

                  Comment


                    #10
                    Hello,

                    I had edited my prior post to reflect the added images.

                    Regarding doing anything about this programatically, I don't believe there is anything that can be done on this item. Basically the way the author has created this is causing the X axis to change the way it does. To correct this the item would need to be re programmed in a way that does not cause this. I am unsure what code is being used that would control the X axis as there are no supported methods to compress the chart as you have pictured.

                    For this if you can I would recommend contacting the developer to see if they can correct this or at least know why this happens, otherwise there's not really anything that could be done to correct it other than manually correcting the chart back to how it was.

                    I look forward to being of further assistance.
                    JesseNinjaTrader Customer Service

                    Comment


                      #11
                      Originally posted by ivb73077 View Post
                      Sorry - it appears the attachments were not appended to my reply.

                      Adding....
                      Increase the barWidth.

                      Comment


                        #12
                        Thanks. Will give that a shot.

                        Comment


                          #13
                          The combination of BarSpacing and BarWidth fixed the problem.

                          Thanks.

                          Comment


                            #14
                            Originally posted by koganam View Post
                            Increase the barWidth.
                            Please take a look at the attached chart. Per koganam's suggestion, almost everything is working perfectly. However, note that the 13:03 bar (which is the one currently forming) does not display the footprint data as do all other bars.

                            Is there some setting (perhaps a margin) that is causing the current/live bar to truncate?

                            Thank you.
                            Attached Files

                            Comment


                              #15
                              Originally posted by ivb73077 View Post
                              Please take a look at the attached chart. Per koganam's suggestion, almost everything is working perfectly. However, note that the 13:03 bar (which is the one currently forming) does not display the footprint data as do all other bars.

                              Is there some setting (perhaps a margin) that is causing the current/live bar to truncate?

                              Thank you.
                              What is your CalculateOnBarClose setting?

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by spikeruk, Today, 01:49 PM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Started by Yandychang, Today, 02:16 PM
                              3 responses
                              11 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Started by priceisking, Today, 01:16 PM
                              1 response
                              6 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Started by kashyapjdave, 03-23-2017, 12:12 AM
                              11 responses
                              1,956 views
                              0 likes
                              Last Post forextrader2003  
                              Started by Gav_G, 07-26-2018, 04:29 PM
                              5 responses
                              422 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Working...
                              X