Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Compilation not taking effect

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Compilation not taking effect

    I have compiled a new version of my indicator and refreshed (F5) an existing chart. However, the old version of the indicator is still in effect on the chart.
    I also tried removing the indicator and applying it again, with the same result.

    In my indicator I have a DrawRay that is commented out in the new compiled version. However, this DrawRay still appears on my chart after the refresh.

    How do I delete (unregister) the old compilation? I thought this might force the chart to use the new compilation.

    thanks.

    #2
    Please try pressing F5 on chart.
    DierkNinjaTrader Customer Service

    Comment


      #3
      Maybe you could also try right click on chart->Drawing Tools->Remove All Draw Objects.
      Josh P.NinjaTrader Customer Service

      Comment


        #4
        I have tried F5 on the chart, and it did not work.
        I know how to manually remove the objects from the chart. My mention of the DrawRay was only to show that the new compilation was not taking effect.
        My workaround is to save the source of the updated indicator as a new name, delete the old indicator, then rename the new version of the indicator to the name that I previously deleted. When I add the new (renamed) indicator it works as it should.

        Comment


          #5
          That is odd because it should work to just remove the indicator from the chart and readding the indicator. Have you tried closing the chart and then just opening a new chart to see if the new version takes hold?
          Josh P.NinjaTrader Customer Service

          Comment


            #6
            >> I have tried F5 on the chart, and it did not work.
            Sorry, I'm on a loss. It does work here. May be your code change is not effective, since there is some condition (e.g. if statement) which is not triggered. You would need to debug you code: http://www.ninjatrader-support.com/v...ead.php?t=3418
            DierkNinjaTrader Customer Service

            Comment

            Latest Posts

            Collapse

            Topics Statistics Last Post
            Started by Jorge.andres.o, Today, 08:05 PM
            0 responses
            1 view
            0 likes
            Last Post Jorge.andres.o  
            Started by SuperDriveGuy, 10-23-2019, 07:13 AM
            23 responses
            1,346 views
            0 likes
            Last Post wadams
            by wadams
             
            Started by lmatiukas, Today, 07:09 PM
            1 response
            6 views
            0 likes
            Last Post lmatiukas  
            Started by ComfyCouch, Today, 06:04 PM
            0 responses
            17 views
            0 likes
            Last Post ComfyCouch  
            Started by Ousher, Today, 04:35 PM
            0 responses
            5 views
            0 likes
            Last Post Ousher
            by Ousher
             
            Working...
            X