Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Session Template, Indicator not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Session Template, Indicator not working

    Why would an indicator I made to spot outside reversal bars work on one session template, but not on another? Basically its just:

    if High0>High1 and Low0<Low1 and Close0>Open0

    DrawArrowUp



    Why would the session template matter? (The two I'm referring to are the "Use Instrument Settings" and my custom one to convert my chart into GMT)

    #2
    jmflukeiii, what exactly do you mean by 'does not work'? Do you see any errors in the Log tab once the study is applied to your charts?
    BertrandNinjaTrader Customer Service

    Comment


      #3
      Meaning it prints the arrows on the "Use Instrument Settings" session template, but does not print arrows on any other custom session templates I have. I'll check for errors

      Comment


        #4
        In the meantime Ninja is locking up everytime I start up now, completely unrelated to this indicator. Can someone help me with a quick solution to start just with a blank workspace open?

        Comment


          #5
          You can start with a fresh set of workspace by exiting NT completely and then going to Documents\NinjaTrader 7\workspaces and removing your .xml files from this folder, upon next startup NT creates a new blank workspace to use.
          BertrandNinjaTrader Customer Service

          Comment


            #6
            Thanks Bertrand.

            But back to the issue, why is my indicator not working on one session template, but working on another?

            Edit Nevermind, fixed it
            Thanks
            Last edited by jmflukeiii; 04-12-2012, 05:13 AM.

            Comment


              #7
              Sorry I would not know without giving the study a run jmflukeiii - you would need to debug your code leading to the results displayed to understand why they would work differently on the templates used.

              Did you check for log tab errors when applying the study? Anything noted?
              BertrandNinjaTrader Customer Service

              Comment


                #8
                Bertrand, thanks again - I added a If (CurrentBar < 2) and it started working. I'm not sure why it worked on one session template though but not the other before adding that line, but nonetheless, its working now. Thank you

                Comment


                  #9
                  Glad to hear, whenever you see unexpected behavior it's a good idea to check the Log tab in the Control Center first - the CurrentBars error you ran into would have also been noted there.
                  BertrandNinjaTrader Customer Service

                  Comment


                    #10
                    That's exactly what I did with your advice from yesterday. I got sidetracked because it kept locking, but thank you for your help.

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by op1031, Yesterday, 05:16 PM
                    1 response
                    8 views
                    0 likes
                    Last Post NT-Roland  
                    Started by sinpeople, Today, 07:20 AM
                    1 response
                    3 views
                    0 likes
                    Last Post NT-Roland  
                    Started by Frank1000, Today, 03:05 AM
                    1 response
                    7 views
                    0 likes
                    Last Post NT-Roland  
                    Started by ntdev, Today, 01:14 AM
                    4 responses
                    16 views
                    0 likes
                    Last Post ntdev
                    by ntdev
                     
                    Started by ct, Today, 02:22 AM
                    1 response
                    8 views
                    0 likes
                    Last Post NinjaTrader_Jason  
                    Working...
                    X