• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Add(RSI(20,3));

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Add(RSI(20,3));

    I've added the following code into the Initialize() section Add(RSI(20,3)) but when I back test the RSI indicator is not showing up

    #2
    Hello,

    Thank you for your post.

    Are there any errors or messages listed in the Log tab after running the Strategy Analyzer test? What do these messages report.
    Patrick H.NinjaTrader Customer Service

    Comment


      #3
      There are no error in the log file. I've spoken incorrectly and I apologize, what I should have said is I'm not seeing the RSI when I add the strategy to a chart. The only code I have is in the Initialize section and the code is Add(RSI(13,3)) I have no code in OnBarUpdate either.
      Last edited by d.allen101; 05-19-2014, 12:18 PM.

      Comment


        #4
        Hello d.allen101

        I just wanted to verify with you this is how your current code looks, you said that you have only the RSI in the initialize section with no other code in the strategy and it is not showing up correct?

        Code:
        protected override void Initialize()
        {
        CalculateOnBarClose = true;
        Add(RSI(13,3));
        }
        protected override void OnBarUpdate()
        {
        }
        Is this something that is not displaying in the chart only or is this not displaying at all in the chart or backtest?

        Also have you had the output window up when you load the strategy into the chart? is anything reported in the output such as an onBarUpdate error?

        I look forward to being of further assistance.
        JesseNinjaTrader Customer Service

        Comment


          #5
          I'm sorry for the mis-communication, it's not when I bast test that I don't see the indicator it's when I add the strategy to a chart that I'm not seeing the indicator.

          Comment


            #6
            Hello d.allen101,

            Thank you for clarifying that for me.

            Were you able to check the output window (not the log) to see if there is any error thrown when the strategy is enabled on the chart?

            Also in the chart in the top left where it displays the chart title and the strategy name, does this show (D) the_strategy_name or just the_strategy_name? The (D) would be if the strategy is disabled but added to the current chart.

            If at some point during the enabling of the strategy it has an error this would throw the strategy back into a disabled state and would not display anything.

            Please let me know if I may be of additional assistance
            JesseNinjaTrader Customer Service

            Comment


              #7
              Originally posted by d.allen101 View Post
              I'm sorry for the mis-communication, it's not when I bast test that I don't see the indicator it's when I add the strategy to a chart that I'm not seeing the indicator.
              After adding the Strategy to the chart, have you actually enabled the Strategy?

              Comment


                #8
                that was the problem. sorry for wasting everyone's time. Thanks

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by 7robert, Today, 12:23 PM
                0 responses
                4 views
                0 likes
                Last Post 7robert
                by 7robert
                 
                Started by autogenix, Today, 11:23 AM
                1 response
                7 views
                0 likes
                Last Post NinjaTrader_Jim  
                Started by pstrusi, Today, 11:34 AM
                1 response
                11 views
                0 likes
                Last Post NinjaTrader_Kate  
                Started by autogenix, Today, 11:19 AM
                1 response
                6 views
                0 likes
                Last Post NinjaTrader_Spencer  
                Started by martyn73, Yesterday, 04:31 PM
                3 responses
                21 views
                0 likes
                Last Post NinjaTrader_ChristopherJ  
                Working...
                X