• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

New Properties Not Showing Up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New Properties Not Showing Up

    I have an indicator that I have distributed to a few people. I recently upgraded it and added a few properties and removed a few properties. When the users install the new version, they do not see the new properties and the old ones are still visible.

    I have confirmed that they are using the new version. I have a read-only version property on the indicator that is showing the new version. I have also had them open the indicator's .cs file and they have confirmed that they are using the correct version that way as well.

    I am thinking that something must be persisted with the old version that is causing this to happen. In any case, whatever the cause, how can it be fixed?

    Changing the name of the indicator is NOT an option.

    Thank you.

    #2
    Hello Nedrob519,

    Do these clients have any templates saved of the indicator located in (My) Documents -> NinjaTrader 7 -> Templates -> Indicators

    If so, have then erase all these items.

    Additionally, have them load a blank chart without and chart templates being loaded try adding the indicator by itself.
    Cal H.NinjaTrader Customer Service

    Comment


      #3
      I am having the exact same issue.

      I deleted all my templates and workspace files.

      I then re-started Ninja and created a brand new chart. I put the indicator on the chart and 2 old properties are still showing up.

      http://snag.gy/mmUae.jpg

      I searched for the string "fib1618L" and it is not in the .cs file at all.

      Ninja is obviously persisting this data somewhere. Any ideas where to look next?

      Thanks.

      Comment


        #4
        Hello,

        Thank you for the question.

        I would like to take a look and see if the indicator is causing this or if something is being cached locally on your PC.

        Would it be an option to send me the indicator to test? If you do not wish to post it on the forum can you please email me at platformsupport @ ninjatrader.com in reference to ticket 1255622.

        I can test this on my end to see if the properties show up, if so I could look into the code to check if something is causing this, otherwise if it does not show up on my end we can take a look at your installation and find where that is coming from .

        I look forward to being of further assistance.
        JesseNinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by SAITON, Today, 09:03 PM
        0 responses
        1 view
        0 likes
        Last Post SAITON
        by SAITON
         
        Started by suprsnipes, Today, 08:26 PM
        0 responses
        5 views
        0 likes
        Last Post suprsnipes  
        Started by RobertoPaez, Today, 06:47 PM
        0 responses
        7 views
        0 likes
        Last Post RobertoPaez  
        Started by catinabag, Today, 06:45 PM
        0 responses
        4 views
        0 likes
        Last Post catinabag  
        Started by darkgreen, Today, 03:35 PM
        0 responses
        9 views
        0 likes
        Last Post darkgreen  
        Working...
        X