Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

loading data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    loading data

    OK so here is a problem I held off but can't really go on like that
    the problem happens almost all the time, but every now and then

    I have my workspace open, with lets say 6S, 3 windows
    and then when I want to change the instrument to some thing else from the drop down arrow, it'll say loading and won't show anything on the chart
    even if I try to open a new chart from the Control Center it will not load anything and will leave me with an empty chart till I restart NinjaTrader

    I managed to stomach this for a while but for goodness sakes there must be something you guys can do about it no?

    I have NT7 ver 7.0.1000.34

    thank you

    p.s. I do have an Idea now that I'm looking at the Control Center what the problem is
    I have 2 connections 1 with AMP and 1 with TD
    is there a way to tell NinjaTrader a certain instrument should always refer to a connection I chose?


    Thank you again

    Update:

    I have disconnected TD connection, try to reload all data for that instrument and no luck
    even trying to create a new chart, same problem till I restart NT
    Last edited by elgaza; 07-27-2017, 10:05 AM.

    #2
    I see that you're using an older and unsupported version of NinjaTrader 7 (7.0.1000.34). Please upgrade to the latest version (7.0.1000.35) and reset your instruments to make sure that your NinjaTrader has all updates.

    To upgrade NinjaTrader, please follow the steps below.
    • First get your license key from NinjaTrader under Help> License Key then exit NinjaTrader
    • Click on the link: http://ninjatrader.com/PlatformDirect
    • Enter your license key and press Submit
    • Select 'NinjaTrader 7'
    • Select 'Download'
    • Critical: Before running the installer, ensure NinjaTrader is closed.

    After the update, reset your instruments:
    • Disconnect from your data feed: NinjaTrader Control Center> File> Disconnect> Select your data feed.
    • Reset your Instruments: NinjaTrader Control Center> Tools> Options> Data tab> Reset Instruments>OK.
    • Shut down NinjaTrader

    What you're describing sounds like a cache issue, To delete the cache, follow the steps below.
    • Ensure NinjaTrader is shut down.
    • Open the Documents > NinjaTrader 7 > db folder.
    • Delete the sub-folder named 'cache'.
    • Restart NinjaTrader and test.

    Your connection order should not matter for this issue, however, here is some more detail about how multiple connections work in NinjaTrader 7:

    AMP is a CQG-based connection. CQG-based connections provide futures and indices data only into NinjaTrader. TD Ameritrade provides equities and indices data only into NinjaTrader.

    Please visit the following help guide page to learn more about multiple connections in NinjaTrader 7:

    http://ninjatrader.com/support/helpG...onnections.htm

    It is not possible to select a preferred data provider in NinjaTrader 7, but this can be done in NinjaTrader 8. Here is more information about that feature:

    http://ninjatrader.com/support/helpG...ataConnections
    Patrick G.NinjaTrader Customer Service

    Comment

    Latest Posts

    Collapse

    Topics Statistics Last Post
    Started by gravdigaz6, Today, 01:43 AM
    0 responses
    3 views
    0 likes
    Last Post gravdigaz6  
    Started by DayneSwift, Yesterday, 11:06 PM
    0 responses
    2 views
    0 likes
    Last Post DayneSwift  
    Started by AidanLawrence, Yesterday, 10:03 PM
    0 responses
    2 views
    0 likes
    Last Post AidanLawrence  
    Started by butt_toast, Yesterday, 09:47 PM
    0 responses
    3 views
    0 likes
    Last Post butt_toast  
    Started by GaryOz, Yesterday, 06:54 PM
    0 responses
    5 views
    0 likes
    Last Post GaryOz
    by GaryOz
     
    Working...
    X