• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Bitcoin Futures?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NinjaTrader_PatrickG
    replied
    thomson, there are two possibilities for why you would see historical data only and no real-time for BTC. One or both of the below could be causing BTC not to update in real-time in your case:
    • You're data feed is not enabled for real-time BTC data. If you're connected to a futures demo provided by CQG, it is expected that you would only receive historical BTC data. You would need a paid futures feed to receive real-time BTC data.
    • Your NinjaTrader 7 is out of date

    Potential cause #1 - Contact your broker/data provider and ensure you are enabled for real-time BTC data.

    Potential cause #2 - The mapping for BTC for all known supported futures providers is now built into NinjaTrader 7.

    You'll want to make sure you're running the latest version (7.0.1000.38 as of the date of this post) and that you've reset your instruments recently. You can check your version by going to Help > About.

    If you're not using 7.0.1000.38, please upgrade:
    • First get your license key from NinjaTrader under Help> License Key then exit NinjaTrader
    • Click on the link: http://ninjatrader.com/PlatformDirect
    • Enter your license key and press Submit
    • Select 'NinjaTrader 7'
    • Select 'Download'
    • Critical: Before running the installer, ensure NinjaTrader is closed.

    Whether you upgraded or not, complete a reset of your instruments to ensure your NinjaTrader database has all critical updates:
    • Disconnect from your data feed: NinjaTrader Control Center> File> Disconnect> Select your data feed
    • Reset your Instruments: NinjaTrader Control Center> Tools> Options> Data tab> Reset Instruments>OK
    • Restart NinjaTrader> Connect (NinjaTrader Control Center> File> Connect> Select your connection

    Leave a comment:


  • thomson
    replied
    How did you do that? I use CQG, it only has history data. How can I get real time data?
    Thanks,

    Leave a comment:


  • doctore
    replied
    Nevermind...mapping is BTC. Works great!

    Leave a comment:


  • doctore
    replied
    Any special mapping for Rithmic? Running nt7 .1000.37.Following your suggested steps, I have XBT in the Master List and XBT 02-18 in the Instrument List. But when I open a chart, when connected to my broker (ADM) via Rithmic, there is no data on the chart. Tried downloading data as well; no indication of success or failure. Tx in advance!!
    Last edited by doctore; 01-17-2018, 02:38 AM.

    Leave a comment:


  • meowflying
    replied
    They said it will be available this coming Friday.

    Originally posted by robje737 View Post
    Hi,

    I received an email yesterday from NT that this month, clients will be able to trade BTC/XBT via the ninja trader platform.

    Does NT have a specific date when we can start trading?

    Rgds,

    Rob

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    The NinjaTrader forums are for technical support only. The Brokerage Team does not have access to these forums.

    Please contact the NinjaTrader Brokerage Team directly for more information about trading these instruments with NinjaTrader Brokerage. Their contact phone and email are at the bottom of the image you attached.

    Here is another resource for contact information:

    http://ninjatrader.com/ContactUs

    Leave a comment:


  • robje737
    replied
    Hi,

    I received an email yesterday from NT that this month, clients will be able to trade BTC/XBT via the ninja trader platform.

    Does NT have a specific date when we can start trading?

    Rgds,

    Rob
    Attached Files

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    Mapping for BTC when using a CQG-based connection and NinjaTrader 7 currently requires some manual configuration:
    • Disconnect from your data provider
    • Tools > Instrument Manager
    • Locate and select 'BTC' > Edit > 'Misc' tab
    • Scroll down to the mapping section and locate your provider (CQG, Continuum, NinjaTrader Continuum)
    • You should see 'BRR'. Replace this with 'BTC' > OK > OK
    • Reconnect and test

    Keep in mind that real-time data being available will be dependent on if your connection is enabled for real-time data for the BTC instrument. Reach out to your data provider/broker directly for more infromation.

    Also, historical data is not yet available for this instrument from NinjaTrader, but it will be available tentatively beginning later today.

    Leave a comment:


  • meowflying
    replied
    Any special setting/symbol mapping for CQG?

    Originally posted by NinjaTrader_PatrickG View Post
    First, ensure you're on the latest version of NinjaTrader 7 (7.0.1000.37). You can check by going to Help > About.

    If not, please upgrade to the latest version:
    • First get your license key from NinjaTrader under Help> License Key then exit NinjaTrader
    • Click on the link: http://ninjatrader.com/PlatformDirect
    • Enter your license key and press Submit
    • Select 'NinjaTrader 7'
    • Select 'Download'
    • Critical: Before running the installer, ensure NinjaTrader is closed.

    Once on the latest version, you'll also want to reset your instruments to make sure your database receives all instrument update information:
    • Disconnect from your data feed: NinjaTrader Control Center> File> Disconnect> Select your data feed
    • Reset your Instruments: NinjaTrader Control Center> Tools> Options> Data tab> Reset Instruments>OK
    • Restart NinjaTrader> Connect (NinjaTrader Control Center> File> Connect> Select your connection

    After these steps, BTC will be available in the master instrument list.

    Depending on your data provider, you may need to edit the symbol mapping to properly receive data. If you let me know who you connect to I can provide specific instructions (if necessary).

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    First, ensure you're on the latest version of NinjaTrader 7 (7.0.1000.37). You can check by going to Help > About.

    If not, please upgrade to the latest version:
    • First get your license key from NinjaTrader under Help> License Key then exit NinjaTrader
    • Click on the link: http://ninjatrader.com/PlatformDirect
    • Enter your license key and press Submit
    • Select 'NinjaTrader 7'
    • Select 'Download'
    • Critical: Before running the installer, ensure NinjaTrader is closed.

    Once on the latest version, you'll also want to reset your instruments to make sure your database receives all instrument update information:
    • Disconnect from your data feed: NinjaTrader Control Center> File> Disconnect> Select your data feed
    • Reset your Instruments: NinjaTrader Control Center> Tools> Options> Data tab> Reset Instruments>OK
    • Restart NinjaTrader> Connect (NinjaTrader Control Center> File> Connect> Select your connection

    After these steps, BTC will be available in the master instrument list.

    Depending on your data provider, you may need to edit the symbol mapping to properly receive data. If you let me know who you connect to I can provide specific instructions (if necessary).

    Leave a comment:


  • ginx10k
    replied
    Any idea how to include the BitCoin CME futures contract into NT7 now?

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    outsource, I am unaware of a free source of real-time data for BTC or XBT.

    Leave a comment:


  • outsource
    replied
    is there a sim CME BTC data available to try out?

    Leave a comment:


  • sonia0101
    replied
    Originally posted by NinjaTrader_PatrickG View Post
    What contract month are you viewing?

    What is your NT7 merge policy? You can check by going to Tools > Options > Data tab.
    Hi Patrick, seems like all is good now I can get chart..In nt7 as well. Did not change a thing, but thanks for responding.

    Leave a comment:


  • ty555
    replied
    I found out it's probably because I am not receiving real time data to feed into my charts.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by Heavyweight_Prop, Today, 09:06 PM
1 response
5 views
0 likes
Last Post NinjaTrader_EricB  
Started by WHICKED, Today, 09:03 PM
0 responses
5 views
0 likes
Last Post WHICKED
by WHICKED
 
Started by saltminer, Today, 05:49 PM
0 responses
7 views
0 likes
Last Post saltminer  
Started by brunoviveiros, Today, 05:32 PM
0 responses
4 views
0 likes
Last Post brunoviveiros  
Started by shodson, Today, 05:00 PM
0 responses
2 views
0 likes
Last Post shodson
by shodson
 
Working...
X