• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Order Rejected: There is no market data available to drive the simulation engine

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NinjaTrader_PatrickG
    replied
    A reset of your instrument database should resolve this. To reset your instruments please follow the steps below.
    • Disconnect from your data feed: NinjaTrader Control Center> File> Disconnect> Select your data feed.
    • Reset your Instruments: NinjaTrader Control Center> Tools> Options> Data tab> Reset Instruments>OK.
    • Restart NinjaTrader> Connect (NinjaTrader Control Center> File> Connect> Select your connection.

    Leave a comment:


  • Atomic
    replied
    After much trouble, I now find that symbol RTY is not present on the newly installed version of Ninjatrader either. Only TF.

    Leave a comment:


  • Atomic
    replied
    I finally gave up and upgraded my OS to Win 10 Pro. NT 7 installs OK after that.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    Follow my steps to contact us as I mentioned in post #8

    Originally posted by NinjaTrader_PatrickG View Post
    Please email us at PlatformSupport[AT]NinjaTrader[DOT]com so we may provide you with a work-around.

    Leave a comment:


  • Aleksandrito
    replied
    Originally posted by Atomic View Post

    I tried turning off the firewall and antivirus; no luck. That has never been an issue in the past with this same computer.
    I've got same problem and dunno what to do

    Leave a comment:


  • Atomic
    replied
    Originally posted by NinjaTrader_PatrickG View Post
    This is typically the result of a local PC firewall blocking the NinjaTrader 7 installer from downloading the program. Please email us at PlatformSupport[AT]NinjaTrader[DOT]com so we may provide you with a work-around.
    I tried turning off the firewall and antivirus; no luck. That has never been an issue in the past with this same computer.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    This is typically the result of a local PC firewall blocking the NinjaTrader 7 installer from downloading the program. Please email us at PlatformSupport[AT]NinjaTrader[DOT]com so we may provide you with a work-around.

    Leave a comment:


  • Atomic
    replied
    Originally posted by NinjaTrader_PatrickG View Post
    You can download NinjaTrader without your license key by using your email here:

    https://ninjatrader.com/GetStarted

    Send a message to PlatformSupport[AT]NinjaTrader[DOT]com regarding your license key issue so the Licensing Team can look into the root issue in further detail. Make sure to include your license key and brief description of the issue (DO NOT include your license key on the forums).
    I am unable to download and run the new setup even though I've been running the Ninjatrader 7 platform on the same Windows 7 computer for years.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    You can download NinjaTrader without your license key by using your email here:

    https://ninjatrader.com/GetStarted

    Send a message to PlatformSupport[AT]NinjaTrader[DOT]com regarding your license key issue so the Licensing Team can look into the root issue in further detail. Make sure to include your license key and brief description of the issue (DO NOT include your license key on the forums).

    Leave a comment:


  • Atomic
    replied
    Originally posted by NinjaTrader_PatrickG View Post
    It sounds like you may be using an older version of NinjaTrader 7 which does not have the appropriate updates to the database. Please update NinjaTrader 7 and reset your instruments:

    First, to update NinjaTrader, please follow the steps below:
    • First get your license key from NinjaTrader under Help> License Key then exit NinjaTrader
    • Click on the link: http://ninjatrader.com/PlatformDirect
    • Enter your license key and press Submit
    • Select 'NinjaTrader 7'
    • Select 'Download'
    • Critical: Before running the installer, ensure NinjaTrader is closed.
    Lastly, to reset your instruments, please follow the steps below:
    • Disconnect from your data feed: NinjaTrader Control Center> File> Disconnect> Select your data feed
    • Reset your Instruments: NinjaTrader Control Center> Tools> Options> Data tab> Reset Instruments>OK
    • Restart NinjaTrader> Connect (NinjaTrader Control Center> File> Connect> Select your connection
    After these steps, you should be able to find RTY in your NinjaTrader Instrument Manager. Make sure to enable any TradeStation mapping in the RTY instrument.
    My license key no longer works.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    It sounds like you may be using an older version of NinjaTrader 7 which does not have the appropriate updates to the database. Please update NinjaTrader 7 and reset your instruments:

    First, to update NinjaTrader, please follow the steps below:
    • First get your license key from NinjaTrader under Help> License Key then exit NinjaTrader
    • Click on the link: http://ninjatrader.com/PlatformDirect
    • Enter your license key and press Submit
    • Select 'NinjaTrader 7'
    • Select 'Download'
    • Critical: Before running the installer, ensure NinjaTrader is closed.
    Lastly, to reset your instruments, please follow the steps below:
    • Disconnect from your data feed: NinjaTrader Control Center> File> Disconnect> Select your data feed
    • Reset your Instruments: NinjaTrader Control Center> Tools> Options> Data tab> Reset Instruments>OK
    • Restart NinjaTrader> Connect (NinjaTrader Control Center> File> Connect> Select your connection
    After these steps, you should be able to find RTY in your NinjaTrader Instrument Manager. Make sure to enable any TradeStation mapping in the RTY instrument.

    Leave a comment:


  • Atomic
    replied
    I am using RTY in Tradestation; I have RTY mapped to TF, which is the only R2k symbol I can find in NT.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    The TF instrument was delisted by ICE this past summer. I wouldn't expect any orders to TF to work. Most people have begun trading the equivalent CME instrument RTY.

    What version of NinjaTrader 7 are you using? Please provide the entire version number. This can be found under Help -> About (Example: 7.0.1000.X)

    Who are you connected to? This is displayed in green on lower left corner of the Control Center window.

    Do any errors persist if you trade to RTY instead of TF?

    Leave a comment:


  • Order Rejected: There is no market data available to drive the simulation engine

    I am sending orders to the NT platform using the SIM101 account and getting the subject message.
    Click image for larger version

Name:	ThereIsNoMarketData.PNG
Views:	5
Size:	4.1 KB
ID:	1038183Click image for larger version

Name:	ThereIsNoMarketDataA.PNG
Views:	4
Size:	3.4 KB
ID:	1038184

    I am trying to understand why this occurs. I am able to send orders and have them processed correctly during the night session, but during the day session, I'm getting orders rejected.

Latest Posts

Collapse

Topics Statistics Last Post
Started by Bionian, Today, 02:46 PM
2 responses
6 views
0 likes
Last Post NinjaTrader_Jesse  
Started by rwilliam, Today, 01:54 PM
1 response
10 views
0 likes
Last Post NinjaTrader_Jesse  
Started by franco12364, Today, 11:27 AM
1 response
10 views
0 likes
Last Post NinjaTrader_PaulH  
Started by YevhenShynkarenko, Today, 11:48 AM
4 responses
25 views
0 likes
Last Post NinjaTrader_ChrisL  
Started by NinjaTrader_ChrisL, Today, 11:21 AM
0 responses
21 views
0 likes
Last Post NinjaTrader_ChrisL  
Working...
X