• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Gap in chart

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Gap in chart

    Please see the attached two charts. The top one has this huge gap while the bottom one doesn't. For both Days Loaded is 35. And both use the Session template: Use instrument settings.

    If I open a fresh chart using one DataSeries with no template I also get this gap. If I use one of my chart templates, the gap is not there. However, when I then want to add a second DataSeries into the same chart, the gap appears again.

    What can I do to get rid of this gap?

    sandman
    Attached Files
    Last edited by sandman; 12-25-2017, 05:42 PM.

    #2
    Hello sandman,

    Thank you for your note.

    If you right click on the chart>reload historical data, does the issue go away?

    If not, if you remove the indicator then reload historical data, does this resolve?

    I look forward to your reply.
    Alan P.NinjaTrader Customer Service

    Comment


      #3
      Thanks AlanP.

      I did as you suggested but no go.

      I tried a brand new chart with no indicators at all. See attached image, left part - it has the gap. I then noticed the equidistant barspacing was set to false. I changed it to true and that resolved it for that chart. See image to the right.

      But now when I want to add a second DataSeries into the same chart, it creates the gap again. See image at the bottom.

      Any further suggestions?

      sandman
      Attached Files

      Comment


        #4
        Hello sandman,

        I was able to replicate and this looks like an issue with a misdefined holiday, Christmas.

        I will pass this along in the form of a bug report, for now I would suggest having equidistant to true to avoid the gaps.

        Please let us know if you need further assistance.
        Last edited by NinjaTrader_AlanP; 12-25-2017, 06:40 PM.
        Alan P.NinjaTrader Customer Service

        Comment


          #5
          Thanks, Alan. Somewhat glad that it's not something I did that caused it in my charts. I hope your people will be able to resolve it. It would be nice if you could keep an eye on it and post something here when it is indeed resolved.

          sandman

          Comment


            #6
            Hello sandman,

            I was incorrect in my previous post about the holiday misdefined. In NT7, session templates do not apply holidays.

            If you were to set your session template to default 24x7, and set equidistant to false, you will notice those gaps over the weekends.

            This is expected behavior when equidistant is set to false and the result of today's holiday.

            Please let us know if you need further assistance.
            Alan P.NinjaTrader Customer Service

            Comment

            Latest Posts

            Collapse

            Topics Statistics Last Post
            Ram by tonynt
            Started by tonynt, Today, 06:14 AM
            0 responses
            2 views
            0 likes
            Last Post tonynt
            by tonynt
             
            Started by pjsmith, Today, 04:10 AM
            0 responses
            3 views
            0 likes
            Last Post pjsmith
            by pjsmith
             
            Started by tonynt, Today, 02:21 AM
            0 responses
            8 views
            0 likes
            Last Post tonynt
            by tonynt
             
            Started by alstsion, Today, 12:55 AM
            0 responses
            2 views
            0 likes
            Last Post alstsion  
            Started by kandster, Yesterday, 11:49 PM
            0 responses
            3 views
            0 likes
            Last Post kandster  
            Working...
            X