• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Orders got rejected cause Sim101 suddenly with negative excess equity

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Orders got rejected cause Sim101 suddenly with negative excess equity

    Previous to any simulation, I set Initial cash to 10.000.000 and set all margin requirement to almost 0 in order to avoid problems. Still after a while I'm doing a simultaneous simulation with ES with just 1 contract ( e-mini ) suddenly, I began to have several rejections warnings, so I checked Sim101 and the excess equity went from 2.000.000 to aprox -2.000.000 ( in red ) I imagine that must be some corrupted file but this is happening even after a reinstallation of NT.

    Any ideas?

  • NinjaTrader_PatrickG
    replied
    Unfortunately this will not be addressed in NinjaTrader 7. All of our developmental efforts are focused on NinjaTrader 8. This does not occur in NinjaTrader 8.

    Leave a comment:


  • pstrusi
    replied
    Well, then good to be aware that the problem is cause some bug. This was driving me nuts dissecting my code looking for errors.

    Does Dev's team contemplate to fix it ? I must say that Ninjatrader 7 is a beast, fast and capable of heavy work, I hope you don't ditch it fast.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    Ah, yes - the key is trading to multiple asset classes in Sim101. Can you reproduce this issue if you connect to the forex data feed first and begin trading forex first?

    Leave a comment:


  • pstrusi
    replied
    Hi Patrick,

    I decided to do a complete clean reinstall of Ninjatrade 7. When I activated once again a simulation ( sim101 ) only trading with ES, it just worked fine, but when I add another simulation with another instrument, like $EURUSD ( EUR/USD ) then, eventually in few minutes, it began with this weird issue of :

    "12/13/2018 10:56:03 AM|0|32|IBpiers, Order has exceeded available account equity: Please reduce order size affected Order: Buy 1 Limit @ 2651.25 " but then you check the account sim101 and you have 5 million cash excess equity, and you don't any more info or warning message.....so, I suspect some bug there.

    Any ideas to be able to run multi-instrument simulation avoiding this issue?

    Leave a comment:


  • pstrusi
    replied
    Yes, some file must be very corrupted, even the position tab gives no info at all when there are 4 simultaneous same short positions.
    I'll do what you suggest.
    Thanks

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    If the issue persists, I would suggest a reset of the database (This can take longer depending on the size of your database file and your system).

    The following data will be removed.
    • Historical orders.
    • Historical executions.
    • Historical ATM strategy data.
    • Saved Strategy Analyzer backtest results.
    The following data will be maintained.
    • ATM strategy templates.
    • Historical chart data.
    Follow these steps:
    • Disconnect NinjaTrader from any open connections via File > Disconnect.
    • From the NinjaTrader Control Center window select the menu Tools > Options.
    • Select the 'Data' tab.
    • Press the 'Reset DB' button.
    • Press the 'OK' button.

    Leave a comment:


  • pstrusi
    replied
    Already done that several times, eventually it will repeat the issue.
    I just reset to 100 millions cash and reset once again
    Thanks anyway

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    You must reset the simulator for changes to be applied. Resetting a simulation account will clear all historical trade data from this account. Please follow the instructions below to reset a simulation account. (This can take longer depending on the size of your database file and your system.)
    • From the NinjaTrader Control Center window select the menu Tools> Options> Simulator.
    • Press the 'Reset' button.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by shishir_nse, Today, 11:02 AM
1 response
6 views
0 likes
Last Post NinjaTrader_ChelseaB  
Started by crazyhorse2393, Today, 07:31 PM
0 responses
9 views
0 likes
Last Post crazyhorse2393  
Started by Jschmelz, Today, 01:13 PM
1 response
9 views
0 likes
Last Post NinjaTrader_EricB  
Started by Newtrader101, Today, 12:37 PM
2 responses
13 views
0 likes
Last Post Newtrader101  
Started by Robert87, Yesterday, 11:07 AM
1 response
24 views
0 likes
Last Post NinjaTrader_ChelseaB  
Working...
X