• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

BUG scaling of the chart

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    BUG scaling of the chart

    when scaling, the value of the indicator varies from +600 to +860, but there is a value of 400, 200 and 0 on the chart. part of the graph is not used. from 0 to 600 there is no data. scaling always starts from zero if the value is greater than zero. But if the values are less than zero, everything is fine.

    fix the problem

    #2
    Hello KeenEdge,

    Thank you for your post.

    Can you detail the indicator your working with in your screenshot?

    Do you see the same behavior with SMA?

    I look forward to your response.
    Patrick H.NinjaTrader Customer Service

    Comment


      #3
      Originally posted by NinjaTrader_PatrickH View Post
      Hello KeenEdge,

      Thank you for your post.

      Can you detail the indicator your working with in your screenshot?

      Do you see the same behavior with SMA?

      I look forward to your response.

      this is my indicator, it shows cumulative Delta.
      perhaps the problem is only in my indicator, SMA works without problems Click image for larger version

Name:	my ind.png
Views:	0
Size:	61.0 KB
ID:	1043035
      Attached Files

      Comment


        #4
        KeenEdge,

        I suspect this is your indicator. If you can provide more details we may be able to help you debug this item. Are you AutoScaling that indicator?
        Josh G.NinjaTrader Customer Service

        Comment


          #5
          Originally posted by NinjaTrader_JoshG View Post
          KeenEdge,

          I suspect this is your indicator. If you can provide more details we may be able to help you debug this item. Are you AutoScaling that indicator?

          if you use one indicator, everything works. if you use two indicators (the second value is not assigned to N/A) - then it does not work and scaling does not work.

          Code:
          Add( new Plot(new Pen(Color.Teal, 1), PlotStyle.Line,"SumDelta")); // all work
          Add( new Plot(new Pen(Color.Blue, 1), PlotStyle.Line,"SimpleDelta")); // not use, not work. the second indicator that is not used should be removed


          I was able to solve the problem, you need to use only one indicator on the chart. if the two of them that is not working properly.

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by martyn73, Today, 05:27 PM
          0 responses
          5 views
          0 likes
          Last Post martyn73  
          Started by MichaelAlexander, 02-22-2017, 05:06 AM
          5 responses
          1,402 views
          0 likes
          Last Post NinjaTrader_ChelseaB  
          Started by walter739, Today, 11:56 AM
          3 responses
          10 views
          0 likes
          Last Post NinjaTrader_ChelseaB  
          Started by kevinfloresz, Today, 09:46 AM
          4 responses
          29 views
          0 likes
          Last Post kevinfloresz  
          Started by digibob, 12-13-2019, 10:01 PM
          7 responses
          20 views
          0 likes
          Last Post NinjaTrader_ChrisL  
          Working...
          X