• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

$NAS100 empty chart

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    $NAS100 empty chart

    Hi,

    I'm trying to open a chart of $NAS100 CFD with ninjatrader7 and Interactive Brokers. I have no problem with ninjatrader8, but with version 7 (7.0.1000.38) the chart is empty. After a minute loading data... the chart remains empty. I've tried to add symbol map IBUST100||||USD (like NT8) but then an error emerges "error on loading chart data...".

    Is $NAS100 CFD only available on NT8? Should I use a special configuration for NT7?

    TWS version is: 960.2g

    Thanks.

    #2
    This may be a limitation of NinjaTrader 7, however, we can try a few things to see if we can get it to work. Please clarify - when you added IBUST100||||USD to the Interactive Brokerage mapping for NAS100, were you connected to Interactive Brokers? Did you already have instrument loaded anywhere within NinjaTrader like an instrument or chart window?

    I see that you're running an older version of NinjaTrader 7. The newer version contains many critical updates to the database. Please update NinjaTrader 7 and reset your instruments:

    First, to update NinjaTrader, please follow the steps below:
    • First get your license key from NinjaTrader under Help> License Key then exit NinjaTrader
    • Click on the link: http://ninjatrader.com/PlatformDirect
    • Enter your license key and press Submit
    • Select 'NinjaTrader 7'
    • Select 'Download'
    • Critical: Before running the installer, ensure NinjaTrader is closed.
    Lastly, to reset your instruments, please follow the steps below:
    • Disconnect from your data feed: NinjaTrader Control Center> File> Disconnect> Select your data feed
    • Reset your Instruments: NinjaTrader Control Center> Tools> Options> Data tab> Reset Instruments>OK
    • Restart NinjaTrader> Connect (NinjaTrader Control Center> File> Connect> Select your connection
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Thanks Patrick,

      I have upgraded NT7 to last version, and I have reseted instruments.

      I have added $NAS100 to instrument list disconnected from IB, and no charts opened. Then I've opened a chart for NAS100 and it's still empty, after loading data for a moment nothing happens. Any other ideas?

      Comment


        #4
        I am also unable to successfully map this instrument in NinjaTrader 7 so it appears this is unfortunately a limitation of NinjaTrader 7. You'll need to use NinjaTrader 8 to receive CFD data from Interactive Brokers.
        Patrick G.NinjaTrader Customer Service

        Comment


          #5
          Thank you!
          Happy New Year!

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by levikNT, Today, 04:39 AM
          1 response
          12 views
          0 likes
          Last Post NinjaTrader_ChelseaB  
          Started by chartish, Today, 08:36 AM
          2 responses
          14 views
          0 likes
          Last Post chartish  
          Started by login_dejavu, Yesterday, 04:58 AM
          1 response
          14 views
          0 likes
          Last Post NinjaTrader_RyanS  
          Started by NinjaTrader_PaulH, Today, 07:40 AM
          0 responses
          4 views
          0 likes
          Last Post NinjaTrader_PaulH  
          Started by awesometrader, Today, 06:59 AM
          2 responses
          9 views
          0 likes
          Last Post awesometrader  
          Working...
          X