• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Mr C

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Mr C

    Hello- I have a multi instrument strategy that compiles ok and generates proper back test
    Results. I deployed the strategy live but it appears that it's not buying anything. There are many instruments in the strategy so I'm wondering if there's an upper limit. It's not on the IB side. It's something on the Ninjatrader side. Maybe there's something missing in my code or some sort of setting in the controls panel? Can someone help on this?
    Last edited by ciro1963; 01-17-2018, 09:52 PM.

    #2
    Hello ciro1963,

    Thanks for your post.

    Do you see any errors listed in the "Log" tab of the control center that relate to your strategy?

    In the strategies tab, does the strategy show that it is enabled?

    In the strategies tab, if the strategy is enabled, what color is the name of the strategy?

    Are you trading on a sim account or your live account?

    Note: We've observed that you start threads with the title of Mr. C. Please note that many people use the forum search function to find threads related to topics that may be of help to them which is one advantage of a users forum. If you want to find your own threads, there are other user tools you can use to find your own posts/threads. Please use the thread titles for the best advantage of all users by identifying the issue you are posting about. Thanks for your understanding.
    Paul H.NinjaTrader Customer Service

    Comment


      #3
      Multi Instrument Issues

      Ok I will be descriptive in the title.
      To answer the questions - yes the strategy is enabled and the color is green. It's set to a live IB account. I am also connected to my live Kinetic account ( paid subscription) as well as IB. There's a + sign right near the strategy under the strategies tab and when I click it I see no price info. Shouldn't I get some numbers here? Looks like all zeros. I will check the error logs.
      Last edited by ciro1963; 01-17-2018, 09:51 PM.

      Comment


        #4
        Hello ciro1963,

        Thanks for your reply.

        Can you post a screenshot of your strategies tab with the "+" expanded out so we can see what you see there?

        I was asking about the "log" tab of the control center which is the same thing as the logs themselves but more convenient to access in quickly looking for any apparent errors.
        Paul H.NinjaTrader Customer Service

        Comment


          #5
          Multi Instrument Issues

          Hi Paul,

          Please see attached. many thanks.

          Mr C
          Attached Files
          Last edited by ciro1963; 01-17-2018, 09:51 PM.

          Comment


            #6
            Multi Instrument Strategy Issues

            Here's the log
            Last edited by ciro1963; 01-17-2018, 07:06 PM.

            Comment


              #7
              Multi Instrument Issues

              Here's the log. thanks again.
              Attached Files
              Last edited by ciro1963; 01-17-2018, 09:52 PM.

              Comment


                #8
                Hello ciro1963,

                Thanks for your reply.

                It looks like your strategy has 37 long position on AMT, if price has not moved from the entry price you would not see any pnl information.

                As a check, please open up a chart of one of those instruments and verify that you are seeing real time data. Suggest using 1 minute bars and the indicator "bar timer".

                If you are getting real time data on the chart, we suggest testing your strategy on just one instrument if possible and observe its performance on the chart.
                Paul H.NinjaTrader Customer Service

                Comment


                  #9
                  My output window (via print statements) shows that the strategy is buying and selling stocks properly but for some reason those trades aren't actually taking place. Could it be the structure of the buy and sell statements?

                  I'm using...EnterLong(0, nShares[0],"BuyMkt0"); and ExitLong("BuyMkt0"); for bars 0. For bars 1 it's EnterLong(1, nShares[1],"BuyMkt1"); and ExitLong("BuyMkt1"); etc. nShares[] is an array and has an independent value for each instrument. Is this OK? It works with backtest with no issue.

                  Comment


                    #10
                    Hello ciro1963,

                    Thanks for your reply.

                    The structure looks correct otherwise it would not function in backtest.

                    Please let us know when you have:

                    "As a check, please open up a chart of one of those instruments and verify that you are seeing real time data. Suggest using 1 minute bars and the indicator "bar timer".

                    If you are getting real time data on the chart, we suggest testing your strategy on just one instrument if possible and observe its performance on the chart.
                    "
                    Paul H.NinjaTrader Customer Service

                    Comment


                      #11
                      Thanks for the reply. I changed it to a single strategy and it looks like it's working but when I go to 2 instruments and use simulated data and vary the secondary instrument using the slide bar such that it buys I get a buy order on the primary instrument. That's very strange.

                      Comment


                        #12
                        Hello ciro1963,

                        Thanks for your reply.

                        Please test on live data with just two instruments (on a simulation account) and observe the performance. Do you see separate trades?
                        Paul H.NinjaTrader Customer Service

                        Comment


                          #13
                          Yes I tried that. It's just the primary bars object that trading- not the second one. I pulled a chart on the second one and it is coming up and varying like the 1 st one via the slide bar

                          Comment


                            #14
                            Hello ciro1963,

                            Thanks for your reply.

                            I may not have been clear. Please test on a real time data feed (not the simulated data feed) using a simulation account (such as sim101).
                            Paul H.NinjaTrader Customer Service

                            Comment


                              #15
                              Ok I tried this. It looks like there are no buys on either 1 or 2 but my strategy via print statements show that I met entry criteria to buy. I'm looking at the executions tab to see if there are any buy orders. It was buying the 1st instrument when I was on simulated data however. I saw these buys in the executions. Strange thing is that when I run the full script with all instruments (88) live -my print statements show that I'm buying and selling positions just like what I would expect via backtesting. The only problem is that it's not buying anything in actuality.
                              Last edited by ciro1963; 01-19-2018, 02:05 PM.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Leeroy_Jenkins, Today, 03:52 AM
                              2 responses
                              10 views
                              0 likes
                              Last Post Leeroy_Jenkins  
                              Started by Leope, Today, 03:15 AM
                              1 response
                              6 views
                              0 likes
                              Last Post NinjaTrader_ChrisSch  
                              Started by Frook1951, Today, 03:09 AM
                              0 responses
                              5 views
                              0 likes
                              Last Post Frook1951  
                              Started by unlobotrader, Today, 02:46 AM
                              0 responses
                              5 views
                              0 likes
                              Last Post unlobotrader  
                              Started by greg6622, Today, 01:26 AM
                              0 responses
                              3 views
                              0 likes
                              Last Post greg6622  
                              Working...
                              X