• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Import Errors!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Import Errors!

    Hello I tried to Import an indicator and I got this message: "You have custom ninjascript files on your PC that have programming
    errors. These errors must be resolved before you can import a ninjascript archive file." What to do?

    Thanks

    #2
    I also uninstalled and reinstalled NT7 and still got this message.

    Comment


      #3
      Hello bderlorm,

      Thank you for posting.

      Please follow the instructions below to see where the errors are coming from after compiling the indicator. This will allow you to debug the indicator/strategy or remove it from your PC. If you are wondering why you receive an error when compiling only one indicator, it is because NinjaTrader always compiles all indicators and strategies - not just one. This is done to give you the highest runtime performance possible.

      For NinjaTrader 7:
      • Open NinjaTrader
      • From the Control Center select the Tools menu--> select the Edit NinjaScript menu item--> select Indicator
      • Select ANY indicator and double click on it (we need only to open and compile one script to see all compile errors for all files).
      • A new window will appear and you will need to right click in the window and select Compile to compile the indicators.
      • At the bottom of the window, a new section will appear where you can find the error locations.
      • From there you have the option to comment out offending code sections, remove the complete indicator or debug it to be able to compile again.

      If you are unsure as to what the error is indicating, please send me a screenshot of the NinjaScript File column and Error column fully visible (not to be confused with the Code column)

      To send a screenshot with Windows 7 or newer I would recommend using Window's, Snipping Tool.

      Click here for instructions

      Alternatively to send a screenshot press Alt + PRINT SCREEN to take a screen shot of the selected window. Then go to Start--> Accessories--> Paint, and press CTRL + V to paste the image. Lastly, save as a jpeg file and send the file as an attachment.

      Click here for detailed instruction

      We have also collected more comprehensive steps for resolving NinjaScript programming errors in this tip in our Help Guide:Please let us know if we may be of further assistance.
      Sergey S.NinjaTrader Customer Service

      Comment


        #4
        Im following the instruction and I dont see under Tools menu Edit ninjascript menu. I see Instrument manager, Historical data manager, session manager, hot key manager,
        account connection, option

        Comment


          #5
          Originally posted by NinjaTrader_SergeyS View Post
          Hello bderlorm,

          Thank you for posting.

          Please follow the instructions below to see where the errors are coming from after compiling the indicator. This will allow you to debug the indicator/strategy or remove it from your PC. If you are wondering why you receive an error when compiling only one indicator, it is because NinjaTrader always compiles all indicators and strategies - not just one. This is done to give you the highest runtime performance possible.

          For NinjaTrader 7:
          • Open NinjaTrader
          • From the Control Center select the Tools menu--> select the Edit NinjaScript menu item--> select Indicator
          • Select ANY indicator and double click on it (we need only to open and compile one script to see all compile errors for all files).
          • A new window will appear and you will need to right click in the window and select Compile to compile the indicators.
          • At the bottom of the window, a new section will appear where you can find the error locations.
          • From there you have the option to comment out offending code sections, remove the complete indicator or debug it to be able to compile again.

          If you are unsure as to what the error is indicating, please send me a screenshot of the NinjaScript File column and Error column fully visible (not to be confused with the Code column)

          To send a screenshot with Windows 7 or newer I would recommend using Window's, Snipping Tool.

          Click here for instructions

          Alternatively to send a screenshot press Alt + PRINT SCREEN to take a screen shot of the selected window. Then go to Start--> Accessories--> Paint, and press CTRL + V to paste the image. Lastly, save as a jpeg file and send the file as an attachment.

          Click here for detailed instruction

          We have also collected more comprehensive steps for resolving NinjaScript programming errors in this tip in our Help Guide:Please let us know if we may be of further assistance.
          Im following the instruction and I dont see under Tools menu Edit ninjascript menu. I see Instrument manager, Historical data manager, session manager, hot key manager,
          account connection, option

          Comment


            #6
            Hello bdelorm,

            Thanks for posting.

            I'm happy to check into this with you if you would please email us at PlatformSupport [AT] NinjaTrader [DOT] com. In your message please include a link to this forum thread, ticket number '2142046' and a message 'ATTN Sergey'.

            Thanks in advance; I look forward to resolving your inquiry.
            Sergey S.NinjaTrader Customer Service

            Comment


              #7
              Originally posted by NinjaTrader_SergeyS View Post
              Hello bdelorm,

              Thanks for posting.

              I'm happy to check into this with you if you would please email us at PlatformSupport [AT] NinjaTrader [DOT] com. In your message please include a link to this forum thread, ticket number '2142046' and a message 'ATTN Sergey'.

              Thanks in advance; I look forward to resolving your inquiry.
              Ok ill do that now

              Comment


                #8
                Hi Guys - trying to install this indy but getting the error pop-up described similar to post 1.
                Have tried checking as recommended but need help please. Your comments appreciated.
                Attached Files

                Comment


                  #9
                  Hello brian meade,

                  Thank you for posting.

                  Please follow the steps below to resolve your compile error:

                  Right-click within the NinjaScript Editor window and select "References".
                  If there is already a reference to NinjaTrader.Vendor.dll, select the reference. If there is not, skip to step 4.
                  Click "Delete" to remove the reference.
                  Click "Add"
                  Locate the NinjaTrader.Vendor.dll file for the file mentioned in the error and select it.
                  Click "Open" to add the reference.
                  Click "OK" and recompile.

                  If this does not resolve it, I'm happy to check into this with you if you would please email us at PlatformSupport [AT] NinjaTrader [DOT] com. In your message please include a link to this forum thread, ticket number '2142046' and a message 'ATTN Sergey'.

                  Additionally, please follow the steps below to manually attach your log and trace files to your response so I may investigate this matter further.
                  • Open your NinjaTrader folder under My Documents.
                  • Right click on the 'log' and 'trace' folders and select Send To> Compressed (zipped) Folder.
                  • Send the 2 compressed folders as attachments to this email.
                  • Once complete, you can delete these compressed folders.

                  Thanks in advance; I look forward to resolving this item.
                  Sergey S.NinjaTrader Customer Service

                  Comment


                    #10
                    greetings Sergey - grateful for help and fast response ( as usual ). Works a treat now . Cheers

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by Gav_G, Today, 01:41 PM
                    1 response
                    8 views
                    0 likes
                    Last Post NinjaTrader_ChelseaB  
                    Started by kweiss, Today, 01:21 PM
                    1 response
                    6 views
                    0 likes
                    Last Post NinjaTrader_ChelseaB  
                    Started by cutzpr, Today, 08:44 AM
                    1 response
                    4 views
                    0 likes
                    Last Post NinjaTrader_ChelseaB  
                    Started by Burak, Yesterday, 10:40 PM
                    1 response
                    3 views
                    0 likes
                    Last Post NinjaTrader_ChrisL  
                    Started by AdmiralUptick, Today, 05:35 AM
                    1 response
                    15 views
                    0 likes
                    Last Post NinjaTrader_ChelseaB  
                    Working...
                    X