Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

error importing file

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    error importing file

    i get this error after importing an indicator. NT is now locked in this state so I can't import any other indicators until its resolved. However, I have no idea how to fix the programming errors....
    Attached Files

    #2
    Hello ryebank,

    This can sometimes occur after importing if a system indicator that starts with the @ symbol is replaced by an older version from the importable package.

    Follow these steps to import the NinjaScript:
    1. Download the script to your desktop, keep it in the compressed .zip file.
    2. From the Control Center window select the menu File > Utilities > Import NinjaScript
    3. Select the downloaded .zip file
    4. NinjaTrader will then confirm if the import has been successful.


    Critical *Note that on any files that say "File already exists on your PC" that start with an "@" symbol are the ones that came preloaded inside of NinjaTrader so you would say "No" so that you do not override those files.


    Please follow the instructions below to see where the errors are coming from after compiling the indicator. This will allow you to debug the indicator/strategy or remove it from your PC. If you are wondering why you receive an error when compiling only one indicator, it is because NinjaTrader always compiles all indicators and strategies - not just one. This is done to give you the highest runtime performance possible.
    • Open NinjaTrader
    • From the Control Center select the Tools menu--> select the Edit NinjaScript menu item--> select Indicator
    • Select any indicator and double click on it (we need only to open and compile one script to see all compile errors for all files).
    • A new window will appear and you will need to right click in the window and select Compile to compile the indicators.
    • At the bottom of the window a new section will appear where you can find the error locations.
    • From there you have the option to comment out offending code sections, remove the complete indicator or debug it to be able to compile again.

    If you are unsure as to what the error is indicating, please send me a screenshot of the error with the error column fully expanded so that I may read the entire error message.
    (Click and drag on the small faint separator between column heads to expand that column)

    To send a screenshot with Windows 7 or newer I would recommend using Window's Snipping Tool.

    Click here for instructions

    Alternatively to send a screenshot press Alt + PRINT SCREEN to take a screen shot of the selected window. Then go to Start--> Accessories--> Paint, and press CTRL + V to paste the image. Lastly, save as a jpeg file and send the file as an attachment.

    Click here for detailed instruction

    Please let me know if you would like assistance resolving the error.
    Chelsea B.NinjaTrader Customer Service

    Comment


      #3
      Hello ryebank,

      Thank you for your post.

      Please follow the instructions below to see where the errors are coming from after compiling the indicator. This will allow you to debug the indicator/strategy or remove it from your PC. If you are wondering why you receive an error when compiling only one indicator, it is because NinjaTrader always compiles all indicators and strategies - not just one. This is done to give you the highest runtime performance possible.

      For NinjaTrader 7:

      Open NinjaTrader
      From the Control Center select the Tools menu--> select the Edit NinjaScript menu item--> select Indicator
      Select ANY indicator and double click on it (we need only to open and compile one script to see all compile errors for all files).
      A new window will appear and you will need to right click in the window and select Compile to compile the indicators.
      At the bottom of the window, a new section will appear where you can find the error locations.
      From there you have the option to comment out offending code sections, remove the complete indicator or debug it to be able to compile again.

      If you are unsure as to what the error is indicating, please email platformsupport[at]ninjatrader[dot]com with a screenshot of the NinjaScript File column and Error column fully visible (not to be confused with the Code column). Please make sure to reference ticket number 1869825 in your reply.

      To send a screenshot with Windows 7 or newer I would recommend using Window's, Snipping Tool.

      Click here for instructions

      Alternatively to send a screenshot press Alt + PRINT SCREEN to take a screen shot of the selected window. Then go to Start--> Accessories--> Paint, and press CTRL + V to paste the image. Lastly, save as a jpeg file and send the file as an attachment.

      Click here for detailed instruction

      We have also collected more comprehensive steps for resolving NinjaScript programming errors in this tip on our forums - http://www.ninjatrader.com/support/f...ead.php?t=4678

      Please let us know if we may be of further assistance.

      Comment


        #4
        thanks i was able to rename the "type" file for the offending indicator

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by trader3000a, Today, 03:30 PM
        0 responses
        1 view
        0 likes
        Last Post trader3000a  
        Started by trader3000a, Today, 02:22 PM
        0 responses
        2 views
        0 likes
        Last Post trader3000a  
        Started by kaywai, Today, 12:05 PM
        0 responses
        54 views
        0 likes
        Last Post kaywai
        by kaywai
         
        Started by DTSSTS, 01-14-2022, 02:53 PM
        3 responses
        25 views
        0 likes
        Last Post NinjaTrader_ChelseaB  
        Started by SuperDude123, Today, 05:17 AM
        2 responses
        19 views
        0 likes
        Last Post SuperDude123  
        Working...
        X