• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Data Loading Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Data Loading Issue

    Ever since I started using the September contracts for the new micro eminis the contracts reload from the beginning which takes about 5 minutes to refresh. All other contracts in every other instrument only loads the new data and fills the remainder with the historical data on the system as it should take a few seconds. I have the merge adjusted policy on in global settings and as far as I can see have the proper parameters to load the historical data. Any ideas as to what may be happening here?

    #2
    I forgot to mention I am using IB data

    Comment


      #3
      What version of TWS are you using?

      How many 'days to load' are you using on this chart?

      What interval type is the chart? For example, 5 minute, 1 day, 4 Renko, etc.

      Does this symptom persist after clearing your cache? To delete the cache, follow the steps below.
      • Shut down NinjaTrader.
      • Open the Documents > NinjaTrader 7 > db folder.
      • Delete the sub-folder named 'cache'.
      • Restart NinjaTrader and test.
      Patrick G.NinjaTrader Customer Service

      Comment


        #4
        974.4i, 60 min chart interval asking for for 60 days of load data. I deleted the cache and problem still persists.

        Comment


          #5
          Here is a screen shot
          Attached Files

          Comment


            #6
            I notice a few things:
            1. The description of the MES instrument is not what I would expect it to be. Did you manually create this instrument? Or did you edit this instrument's settings?
            2. You're using an unsupported version of TWS. Does the symptom persist if you use 960.2g? Here is a direct download link
            3. Does the symptom persist if you reduce the days to load to 5?
            Patrick G.NinjaTrader Customer Service

            Comment


              #7
              Yes I created it because it was not listed. The settings are correct though. What would you expect it to be? I have another chart on the same screen that is 5 days to load for 5 minute data and it loads immediately but the 60min chart does not. What do you mean supported when you say v. 960.2g....everything else works with the version i'm using. The only instruments that do not work are the new micros which I created. Is there a way to get NT7 to get the MES, MNQ, etc default settings from NT7?

              Comment


                #8
                We added the new micro contracts to NinjaTrader 7 but it required you to uninstall, reinstall, then reset your instruments. While I agree that your settings look correct, you have a configuration which is non-standard and therefore I am unsure what, if anything, this could be contributing to the symptoms.

                Using an unsupported version of TWS can also cause unknown symptoms.

                Before we start digging in the installed files, let's see what happens on a blank workspace:

                To delete the cache, follow the steps below.
                • Shut down NinjaTrader.
                • Open the Documents > NinjaTrader 7 > db folder.
                • Delete the sub-folder named 'cache'.
                Please take the following steps to force NinjaTrader to start without your saved workspace. You will have the option to reopen these after our tests.
                • Ensure NinjaTrader is shut down.
                • Navigate to (My) Documents\NinjaTrader 7\workspaces
                • Delete the file named "_Workspaces.XML". DO NOT delete the 'workspaces' folder - only delete the '_Workspaces.XML' file within the 'workspaces' folder
                • After deleting this file, restart NinjaTrader which should startup without any workspaces.
                • Once NinjaTrader has started on just the control center, please open a new chart with no custom bar types/indicators/templates and test for issues.
                Please let me know the results of this test.
                Patrick G.NinjaTrader Customer Service

                Comment


                  #9
                  All recommendations completed and still same issue so I assume its something to do with the new contracts.

                  Comment


                    #10
                    We have not received any other reports of this specific symptom with Interactive Brokers users. I suspect one of the items I've mentioned is still contributing to this symptom you're experiencing.

                    Did you download, install, and use the supported version of TWS?

                    Here are the steps to obtain the new micro contracts from our servers:

                    An uninstall, reinstall, and instrument reset is necessary to receive these new symbols. This is required even if you're using the latest version of NinjaTrader 7.0.1000.40. Please follow the following steps (this will not affect or remove your custom files or settings):
                    • Copy your license key from the Control Center > Help > License Key window.
                    • Close all running applications.
                    • Uninstall NinjaTrader within Windows Control Panel.
                    • Once these steps are completed, download and install NT7 from the link below.
                    Once installed, reset your instruments:
                    • Disconnect from your data feed: NinjaTrader Control Center> File> Disconnect> Select your data feed.
                    • Reset your Instruments: NinjaTrader Control Center> Tools> Options> Data tab> Reset Instruments> OK.
                    • Restart NinjaTrader
                    After the instrument reset, you should find these new instruments within the NinjaTrader Instrument Manager.
                    Patrick G.NinjaTrader Customer Service

                    Comment


                      #11
                      As I said, All those recommendations were completed and still the same results. tws 960.2 uninstalled and reinstalled NT7, reset the instruments, restarted NT7. Still same issue but only with those instruments. I will delete the historical data for those instruments and retry I suppose to see if that works?

                      Comment


                        #12
                        If you can't resolve the issue, please send me your log and trace files so that I may look into what occurred.

                        You can do this by going to the Control Center-> Help-> Mail to Platform Support

                        Ensuring 'Log and Trace Files' is checked will include these files. This is checked by default.

                        Please reference the following ticket number in the body of the email: 2195014 ATTN PatrickG
                        Patrick G.NinjaTrader Customer Service

                        Comment


                          #13
                          Deleted instruments affected, repaired database, reloaded historical data. went to another instrument and it loaded within 5 seconds. Went back to MES and still same issue of asking for a full reload of all data.

                          Comment


                            #14
                            We discovered that using a 'days to load' setting which extended beyond the instrument's first trade date (for MES that is 05/05/19) was the root cause of the slow loading symptom. When requesting historical data only from within the range that the instrument had existed (as of today, 54 days), the loading time was normal. This also seems to be isolated to Interactive Brokers as we tested Kinetick which experienced no issue with >54 days to load on MES 09-19.
                            Patrick G.NinjaTrader Customer Service

                            Comment

                            Latest Posts

                            Collapse

                            Topics Statistics Last Post
                            Started by Venom, Yesterday, 01:05 PM
                            1 response
                            20 views
                            0 likes
                            Last Post NinjaTrader_ChrisSch  
                            Started by thgamey, Today, 02:05 AM
                            2 responses
                            13 views
                            0 likes
                            Last Post thgamey
                            by thgamey
                             
                            Started by yeshujbp, Yesterday, 02:40 PM
                            1 response
                            11 views
                            0 likes
                            Last Post NinjaTrader_PaulH  
                            Started by sardana, Today, 05:52 AM
                            1 response
                            4 views
                            0 likes
                            Last Post NinjaTrader_PaulH  
                            Started by Mykro, Yesterday, 04:58 PM
                            1 response
                            11 views
                            0 likes
                            Last Post NinjaTrader_PaulH  
                            Working...
                            X