• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NinjaTrader 7 and IB Gateway

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    NinjaTrader 7 and IB Gateway

    Hello,

    I am aware that NinjaTrader 7 does not officially support IB Gateway, however I used it in 2014-2015 with no issues. I need to trade at IB again and use Ninja 7 (my strategies are not ported to 8 for now), and had difficulties connecting this time. When I just installed Gateway, Ninja would not even connect, it was giving me an error that c:\jts.....\tws.exe file was missing. I then loaded TWS.

    Here are the steps that I now need to perform to connect:
    1) Connect to IB Gateway manually
    2) Connect to IB from Ninja. This opens TWS login pad
    3) Cancel TWS login pad
    4) I am now connected.

    Is there any better way?

    Thanks,
    redduke

    #2
    You're correct that it is not officially supported, but there are users who use NinjaTrader 7 with IB Gateway without issue.

    What it sounds like you have 'auto logon' enabled in your Interactive Brokers connection. In NinjaTrader 7, this is hard-coded to look for Interactive Brokers TWS (not Gateway). There is no way to auto logon to IB Gateway in NinjaTrader 7.

    A less complicated way to do what you're doing would be:
    • Disable 'auto logon' within your Interactive Brokers connection
    • If you've entered login credentials, remove those as well
    • Open IB Gateway and login
    • Connect to IB in NinjaTrader
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Hi Patrick,

      Thanks for your reply. It was a bit better, but I still got TWS login screen (all credentials were blank) and I just clicked cancel. Should I uninstall TWS? Or I would need to keep clicking on cancel (not a big deal of course)

      Thanks

      Comment


        #4
        If TWS is popping up when you are initiating the connection from within NinjaTrader, this means that 'auto logon' is still enabled in the connect and/or credentials are entered in the connection.

        Can you confirm that you disabled 'auto logon' and removed the credentials?
        Patrick G.NinjaTrader Customer Service

        Comment


          #5
          Yes, it is. Please see attached screen shot.
          Attached Files

          Comment


            #6
            I see, thanks. This may be the best scenario since there is no way to force NinjaTrader 7 to switch to Gateway instead of TWS.
            Patrick G.NinjaTrader Customer Service

            Comment


              #7
              Thanks for confirming. It just found it is a bit odd that behavior changed and wanted to make sure my steps are correct.

              I only wish porting code from 7 to 8 would be easy. Facing a major rewrite of 1000s lines of source code.

              Comment

              Latest Posts

              Collapse

              Topics Statistics Last Post
              Started by swcooke, Today, 09:20 AM
              4 responses
              13 views
              0 likes
              Last Post swcooke
              by swcooke
               
              Started by chartish, Today, 08:21 AM
              2 responses
              7 views
              0 likes
              Last Post chartish  
              Started by xbionicx, Today, 01:12 AM
              1 response
              11 views
              0 likes
              Last Post NinjaTrader_JoshG  
              Started by NinjaCustomer, Today, 07:52 AM
              2 responses
              6 views
              0 likes
              Last Post NinjaCustomer  
              Started by tradr, Today, 07:45 AM
              2 responses
              8 views
              0 likes
              Last Post tradr
              by tradr
               
              Working...
              X