• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Help with stop loss

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Help with stop loss

    Is there a way to set NT to send my stop loss order as a limit order instead of a market order?
    I just switched brokers and had to start using NT. I had been using one of your competitors with my old broker. And was able to use limit orders for my stop, so far using NT stop loss has cost me from one to four ticks on all but one of my orders. Using the old platform for nearly 4yrs. and trading almost everyday I was always able to get filled on my stop at the price I wanted.

    #2
    Hello,

    Thank you for your post.

    Are you entering your orders as ATM Strategies?

    These are limit orders by default.

    Please right click in your SuperDOM and choose properties. Make sure "use stop market for stop loss orders" is set to false.

    If you are entering them manually, make sure you are using just a middle mouse click, which is a stop limit.
    Ray SNinjaTrader Customer Service

    Comment


      #3
      The orders are being entered using an ATM strategy. And, "use stop market for stop loss orders" is set to false. But, I am getting filled as if it was a market order not a limit order.

      Comment


        #4
        Just to confirm, your orders are being entered as "market" in your orders tab of the Control Center?
        Ray SNinjaTrader Customer Service

        Comment


          #5
          The stop side of the ATM 1st shows as STOP then when its filled it changes to MARKET....

          Comment


            #6
            I reviewed the screenshots you sent me.

            The reason this is happening is becuase you are using a simulated stop.

            The simulated stop keeps the stop on your computer, not at the broker like a normal stop, and triggers when ask volume falls below your input of 10000. If the price runs below your simulated stop, it automatically triggers a stop at market. Disable your simulated stop if you wish for it to stop being entered at market.
            More information on simulated stop: http://www.ninjatrader-support.com/HelpGuideV6/Overview12.html
            Ray SNinjaTrader Customer Service

            Comment


              #7
              I thought I had to have a volume trigger set in the Simulated Stop area in order to enter a negative limit order-(for example). Am I wrong in this???

              Comment


                #8
                The volume for the Simulated Stop needs to be a positive value.
                VinceNinjaTrader Customer Service

                Comment


                  #9
                  OK...I disabled the SS by setting it "0"...I then entered a short and watched the order window...the Stop Limit was placed but in the order window it showed the Stop at 1194.50 and the Limit at 1199.5-(20) ticks away from my stop, so I will not get filled at my stop price on a regular basis but somewhere between the stop price and limit....This is the subject of my original post...using another platform for over 4 years and having my my stop limit orders set with no "wiggle room"...in other words the stop and limit set at the same price...I was always filled at my price and not a tick or more away....again, I was always filled at my stop price....This makes NT much costlier to trade not only do I have to pay a higher rental fee for the software but I also, will lose ticks on my stop limit orders on a regular basis.....Is there a way to for me to set the limit offset so that I don't lose those extra ticks???

                  If you give me the argument that you do it so that I can be assured of a fill at some price on my Stop Limit orders...I will remind you that trading nearly everyday for over 4yrs. and not having the wiggle room never cost me a fill and I always(not sometimes) got my fill!!!

                  Comment


                    #10
                    Hello beyondMP,

                    I believe you sent me the same inquiry via email. Please see my response to that email. I suggest to continue our correspondence via the email.
                    JasonNinjaTrader Customer Service

                    Comment


                      #11
                      How to Disable Simulated Stop???

                      In my Stop strategy the simulated stop is set to zero - I thought that disabled the simulated stop but it doesn't. How do I disable the simulated stop???

                      Comment


                        #12
                        Hello SawDr,

                        A value of zero does disable simulated stops as per your ATM strategy.

                        I suspect you have 'Simulated Order' enabled as per the right click menu in the SuperDOM. Please right click in the SuperDOM and disable 'Simulated Order'.
                        JasonNinjaTrader Customer Service

                        Comment


                          #13
                          Originally posted by NinjaTrader_Jason View Post
                          Hello SawDr,

                          A value of zero does disable simulated stops as per your ATM strategy.

                          I suspect you have 'Simulated Order' enabled as per the right click menu in the SuperDOM. Please right click in the SuperDOM and disable 'Simulated Order'.
                          "simulated order" is not checked. This is crazy because I have another ATM with a stop that has "50" in the volume trigger and that ATM stop DOES NOT come in as simulated - what is going on?

                          Comment


                            #14
                            Could you please send me a screenshot of the ATM strategy that uses zero for the Simulated Stop - Vol trigger, once the ATM strategy is triggered and working in the SuperDOM.

                            I am not sure what is causing this on your end. I tested it on my end and it works as expected.
                            JasonNinjaTrader Customer Service

                            Comment

                            Latest Posts

                            Collapse

                            Topics Statistics Last Post
                            Started by Yandychang, Today, 02:16 PM
                            0 responses
                            2 views
                            0 likes
                            Last Post Yandychang  
                            Started by priceisking, Today, 01:16 PM
                            1 response
                            4 views
                            0 likes
                            Last Post NinjaTrader_PaulH  
                            Started by kashyapjdave, 03-23-2017, 12:12 AM
                            11 responses
                            1,956 views
                            0 likes
                            Last Post forextrader2003  
                            Started by Gav_G, 07-26-2018, 04:29 PM
                            5 responses
                            422 views
                            0 likes
                            Last Post NinjaTrader_PaulH  
                            Started by spikeruk, Today, 01:49 PM
                            0 responses
                            5 views
                            0 likes
                            Last Post spikeruk  
                            Working...
                            X