Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Orders stay "Pending" in two of my charts!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • M_ichel
    replied
    OK Chris. I've submitted a ticket and I'll keep you posted when I get an answer. Thanks.

    Leave a comment:


  • NinjaTrader_ChrisL
    replied
    Hello M_ichel, thanks for your reply.

    I would recommend reaching out to Interactive Brokers to see if they know anything about the issue. Everything is set up properly on the NinjaTrader side, and other instruments are working so It seems the problem might be on their end/your account on their end.

    I look forward to hearing of your results.

    Leave a comment:


  • M_ichel
    replied
    Hi Chris.
    I installed .42 and retried (I'm using Stop Limit orders, by the way, although this does not seem to have anything to do with the problem). I retried and got the same problem.
    For your info, the order status (as displayed in TWS) is "transmitted not yet acknowledged".
    Then I tried with my live account. This works fine.
    So the problem seems related to the GC contract (as stated earlier, YM and CL work fine) in the Interactive Brokers simulated account...

    Should I pursue this with Interactive Brokers?

    Thanks.

    Leave a comment:


  • NinjaTrader_ChrisL
    replied
    Hello M_ichel, thanks for your reply.

    My apologies, I didn't notice you posted in the NinjaTrader 7 forum section. 7.0.1000.42 is the latest version of NinjaTrader 7. Please install the newest version and test again.

    I look forward to hearing of your results.

    Leave a comment:


  • M_ichel
    replied
    Hi Chris.

    I'm on version 7.0.1000.41 (which I believe is the latest Version 7).

    There are no errors noted in the log.
    A log entry for a GC 04-21 order I tried to place states that it is "Pending". I cancelled it using TWS..

    Hope this helps.

    Leave a comment:


  • NinjaTrader_ChrisL
    replied
    Hello M_ichel, thanks for your reply.

    The GC 04-21 is the correct contract, so it should not work any differently than other markets. Please make sure you are running NinjaTrader version 8.0.23.2 by going to Help>About. If you are not on the current version, please run the installer from the link below:

    https://ninjatrader.com/GetStarted

    Do you see any errors in the Log tab of the Control Center regarding the CG instrument?

    I look forward to hearing from you.

    Leave a comment:


  • M_ichel
    replied
    Hi Chris.

    TWS version: 978.21
    API read-only is OFF.

    Here's additional info I have just added to my original post (you were quick!)

    Edit at 10h56: After more research, I have found that the problem appears to be with the market I'm trading (GC, the 04-21 contract). There is no problem with the charts. I can't manage orders placed in the GC market in any of my charts... Is there something wrong with this market??? It was working OK as of yesterday...Orders for CL or YM appear to work fine.
    Thanks.

    Leave a comment:


  • NinjaTrader_ChrisL
    replied
    Hello M_ichel, thanks for your note.

    Can you confirm the version of TWS or Gateway that you are using? You must run either supported version from our help page:

    https://ninjatrader.com/ConnectionGu...nnection-Guide

    Also, go into TWS>Global Configuration>API> ensure that Read-Only API is off.

    I look forward to assisting.

    Leave a comment:


  • M_ichel
    started a topic Orders stay "Pending" in two of my charts!

    Orders stay "Pending" in two of my charts!

    Hi.
    All of a sudden, in two of my charts, all the orders I place (in my paper trading account at Interactive Brokers) stay "Pending". If I place limit orders, I can't cancel or modify them in the NinjaTrader environment: I have to go to the Interactive Brokers environment to cancel them.
    If I place the orders in the NinjaTrader "SIM" account, they get treated OK.
    These two charts were added recently, using my "standard" Chart template. When I place orders in my older charts (theoretically setup the same way), the trades get executed normally.
    I assume I screwed up a parameter...but which???
    I'm using ChartTrader.
    Thanks!

    Edit at 10h56: After more research, I have found that the problem appears to be with the market I'm trading (GC, the 04-21 contract). There is no problem with the charts. I can't manage orders placed in the GC market in any of my charts... Is there something wrong with this market??? It was working OK as of yesterday...Orders for CL or YM appear to work fine.
    Last edited by M_ichel; 01-28-2021, 09:59 AM.

Latest Posts

Collapse

Topics Statistics Last Post
Started by torch2k, Today, 10:17 AM
0 responses
2 views
0 likes
Last Post torch2k
by torch2k
 
Started by successnow, Today, 09:42 AM
2 responses
14 views
0 likes
Last Post successnow  
Started by jeff_dw, Today, 09:55 AM
0 responses
5 views
0 likes
Last Post jeff_dw
by jeff_dw
 
Started by Photon66, Today, 09:49 AM
0 responses
8 views
0 likes
Last Post Photon66  
Started by PWillard, Today, 08:45 AM
1 response
5 views
0 likes
Last Post NinjaTrader_Spencer  
Working...
X