Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NT7 and IB 978.2c

Collapse
This topic is closed.
X
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    NT7 and IB 978.2c

    Hi,

    I received the following message when I launched IB's TWS yesterday.

    "The version of the application you are running, 978.2, needs to be upgraded, as it will be desupported on 20220110. The minimum supported version at that time will be 981.3. The new version can be downloaded here."

    What does this mean for NT7 users? Is this the end of the road for NT7 with TWS or will NT7 be supported with the same version as NT8?

    Regards
    Kay Wai

    #2
    Hello Kay Wai,

    Thank you for reporting.

    I will let development know that the current supported TWS version for NinjaTrader 7 will not be supported anymore January 10th 2022. I will forward the suggestion to support version 981.3 or later.
    JasonNinjaTrader Customer Service

    Comment


      #3
      I'm in the same situation. Please let us know A.S.A.P what TWS version is the latest compatible with NT7, automated Algos with NT7 need to be on.

      Thanks !

      Comment


        #4
        Thank you Jason

        Comment


          #5
          Same message here!
          Is there anything we could do to ease the memory and CPU usage on NT8? Every time I try it it consumes 1.2 - 1.6 gigs of ram compared to NT7 340 MB ram for the same amount of charts and with NT8 on very active mornings I sometimes lock up for a few seconds to minutes?
          Also how long are you going support NT7?

          Cheers

          Comment


            #6
            Hello,


            How long will you continue to support NinjaTrader 7?

            No end date for support of NinjaTrader 7 has been scheduled. This will be dynamic based on client usage and connection technology API support. For comparison, NinjaTrader 6.5 was supported for an additional 5 years following the release of NinjaTrader 7.

            Please let us know if we may be of further assistance.
            Ryan S.NinjaTrader Customer Service

            Comment


              #7
              Dear NT Team, unfortunatly I am still trying to convert all of my setups to NT8 so I will need a working NT7 for a considerable time. You should never upgrade again without a conversion utility even if it is not perfect, still better than to be on your own. And of course I got the same message to from IB as the others. So please do all you can that we can still trade after the 10th of january.Click image for larger version

Name:	Bild_2021_11_30_17_45_19_146.png
Views:	141
Size:	15.5 KB
ID:	1180022

              Comment


                #8
                The are currently no plans to update the supported version of TWS for use with NinjaTrader 7. We are unsure what 'desupported' means, so you may find that TWS 978.2 continues to function without issue beyond Interactive Brokers 'desupported' date. You may want to contact Interactive Brokers to learn more about what to expect if you choose this path.

                You may also download and use the supported version for NinjaTrader 8 which is TWS 985.1g. We have not tested NinjaTrader 7 with TWS 985.1g, so the behavior and compatibility are unknown. The latest version supported can always be found in the connection guide:Here is a direct download link:
                Patrick G.NinjaTrader Customer Service

                Comment


                  #9
                  It seems like we are being forced in an underhanded way to transition to NT8.
                  If anyone has or is thinking of testing the newer TWS versions on NT7 can you let us know if everything is working as expected?

                  Thanks

                  Comment


                    #10
                    i really hope the support for NT7 could last as long as possible as multithread NT8 is not only unsuitable for my use but also i have tons of NT7 indicators won't be able to convert into NT8.

                    Comment


                      #11
                      Originally posted by futuretrader8 View Post
                      i really hope the support for NT7 could last as long as possible as multithread NT8 is not only unsuitable for my use but also i have tons of NT7 indicators won't be able to convert into NT8.
                      While there is no planned specific date to end support for NinjaTrader 7 at this time, it would be wise for you to install NinjaTrader 8 now and seek out add-ons that are exact replicas or close analogies to the one's you're used to in NinjaTrader 7. The end of support for NinjaTrader 7 is not a potential - it's an eventuality. Making sure you're prepared for that ahead of time will certainly ease the transition. You can learn more here:
                      Patrick G.NinjaTrader Customer Service

                      Comment


                        #12
                        Originally posted by NinjaTrader_PatrickG View Post
                        The are currently no plans to update the supported version of TWS for use with NinjaTrader 7..................................

                        You may also download and use the supported version for NinjaTrader 8 which is TWS 985.1g. We have not tested NinjaTrader 7 with TWS 985.1g, so the behavior and compatibility are unknown. The latest version supported can always be found in the connection guide:Here is a direct download link:
                        Thanks for a potential solution to this problem but in order to have a reliable system working, we need to be sure about this proposed TWS version 985.1g for NT7. You've been always pretty fast solving urgent and delicate issues like this one. Looking forward for your suggestions.

                        Comment


                          #13
                          The ultimate solution will be to use NinjaTrader 8. No NinjaTrader 7 solution is planned.
                          Patrick G.NinjaTrader Customer Service

                          Comment


                            #14
                            As you can read through this thread, many users ( like myself ) have posted Ninjatrader 7 continues to be the preferred platform because the transition to Nnjatrader 8 has not been possible for many technical reasons. Ninjatrader 7 is active and supported, and this critical issue is related to Interactive Brokers, one of the biggest and most used brokers by the Ninjatrader 7 community. I don't think that neglecting this problem is a wise decision. I hope you can do your best and help us.

                            Comment


                              #15
                              Originally posted by pstrusi View Post
                              because the transition to Nnjatrader 8 has not been possible for many technical reasons. ...and this critical issue is related to Interactive Brokers, one of the biggest and most used brokers by the Ninjatrader 7 community. I don't think that neglecting this problem is a wise decision. I hope you can do your best and help us.
                              totally agree with these points. multithread approach of NT8 has turned out not to be so rosy comparing with NT7, and no other broker could compete with IB for its reliability and scale. your team has already dealt with 985 version of TW with NT8, so it should not be a big deal to patch a few minor changes in its NT7 core dll. this small effort could save big fame of your company.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by marcmclean, Today, 08:18 AM
                              0 responses
                              1 view
                              0 likes
                              Last Post marcmclean  
                              Started by trader3000a, Today, 06:16 AM
                              1 response
                              4 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Started by akwash72m, Today, 05:39 AM
                              1 response
                              12 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Started by Devside_Victor, Today, 06:32 AM
                              1 response
                              5 views
                              0 likes
                              Last Post NinjaTrader_Kate  
                              Started by Doctor JR, Today, 06:57 AM
                              1 response
                              4 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Working...
                              X