• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Alert condition on indicator not rearming

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Alert condition on indicator not rearming

    I have an alert set on a plot value of indicator in MarketAnalyzer.
    It is set to play a sound every 5 seconds.

    The alert fires the first time, but then after the rearm time elapses,
    the alert does not fire again.

    I have verified that the condition which causes the alert is still
    true by hard coding it to be so.

    Attached is screen shot of my alert settings.

    Did I set it up wrong, or misunderstand how it works?

    Thanks,
    -Gary
    Attached Files

    #2
    Hello Gary,

    Can you please select a default NinjaTrader sound file, such as Alert1, Alert2, etc. Check if the alarm will trigger each 5 seconds when its condition appears true.
    JasonNinjaTrader Customer Service

    Comment


      #3
      Using Alert1.wav the result is the same.
      It alerts correctly the first time and then does not alert again.

      -Gary

      Comment


        #4
        Hello Gary,

        Please try once more using the default settings as per the sounds folder. I suspect the changes you made in the sounds folder are related.

        Please uninstall/re-install NinjaTrader. You will save all settings and data.

        Uninstall NinjaTrader via the Windows Control Panel-->Add/Remove Programs (XP), Programs and Features (Vista).

        Clear your browser cache and download and install NinjaTrader 6.5 at the link below.
        http://www.ninjatrader.com/webnew/do...g_software.htm

        Remove the current alert and create a new one using a default NinjaTrader sound. Check if the alert triggers as expected.
        JasonNinjaTrader Customer Service

        Comment


          #5
          I have attached a simple little indicator that forces a -1 value into a plot.
          I then set up market analyzer with an alert as shown in the attached screen shot. The Alert1.wav is played upon the initial load and then never rearms.

          Can you try this in your environment using my settings to verify that it works there?

          Thanks,
          Gary
          Attached Files

          Comment


            #6
            Hello Gary,

            I tested it on my end and I experienced the same outcome; the alert only triggers the first time.

            If you setup an alert using a default indicator, such as the SMA, does the alert function work as expected?
            JasonNinjaTrader Customer Service

            Comment


              #7
              Jason,

              I tried an alert on the SMA>0 and it fires and rearms correctly.

              Then I tried the new version of the attached program which essentially does:
              protected override void OnBarUpdate()
              {
              count -= .01; //count is a private double starting at -1.0.
              Status.Set(count);
              }

              The alert rearms correctly when the value is changing!

              I appears that the rearm feature of the alert does not work unless
              the plotted value changes.

              The original behavior that highlighted this problem is that I have an indicator that will continuously set a -1 value after an error has
              occurred.
              I want the alert to continue to fire until the user has responded.

              Seems like a bug to me.

              -Gary
              Attached Files

              Comment


                #8
                Thanks Gary, I'll give this a test and get back to you.
                BertrandNinjaTrader Customer Service

                Comment


                  #9
                  Gary, thanks for raising this one and the scenario - this will be fixed with NinjaTrader 7
                  BertrandNinjaTrader Customer Service

                  Comment


                    #10
                    What seesion template are you using in your MA? Please right click in it and change for example to the Default 24 / 7 in it's properties, then the value should update as expected for this point in time of the trading day.
                    BertrandNinjaTrader Customer Service

                    Comment


                      #11
                      Bertrand,

                      you are really fast! Coincidentally I noticed that just a second before your reply ;-)

                      Nevertheless,
                      THANK YOU!

                      Comment


                        #12
                        You're welcome & thanks for the kind words - great it's working for you.
                        BertrandNinjaTrader Customer Service

                        Comment

                        Latest Posts

                        Collapse

                        Topics Statistics Last Post
                        Started by seagraph, Today, 03:27 PM
                        0 responses
                        11 views
                        0 likes
                        Last Post seagraph  
                        Started by dedouglas, Today, 02:54 PM
                        1 response
                        10 views
                        0 likes
                        Last Post NinjaTrader_Jesse  
                        Started by elkhatabi, 08-01-2019, 06:36 PM
                        5 responses
                        52 views
                        0 likes
                        Last Post NinjaTrader_RyanL  
                        Started by mr_trade, Today, 01:01 PM
                        4 responses
                        17 views
                        0 likes
                        Last Post mr_trade  
                        Started by Renorail, Today, 12:31 PM
                        1 response
                        12 views
                        0 likes
                        Last Post NinjaTrader_PaulH  
                        Working...
                        X