• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

OpenTick issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NinjaTrader_Ray
    replied
    You should be able to chart the $ADDDIFIN. You would need to add it as an instrument via the Instrument Manager. Take a look at some of the other index instruments to see the data you need to include. Don't forget to add the correct OpenTick symbol mapping.

    Leave a comment:


  • NinjaTrader_Dierk
    replied
    Thanks for letting the community know.

    Leave a comment:


  • thrunner
    replied
    Originally posted by NinjaTrader_Ray View Post
    Within the Instrument Manager, add $ADVN to your default instrument list.
    Thank you NT_Ray, that worked. BTW for newbies like me, eventhough it isn't currently possible to calculate the spread between 2 instruments within one chart, it is possible to use the symbol $ADDIFFN in Opentick (with NYSE subscription $1/month) to see the difference (spread) between ADVN and DECL in NT6. The new version of NT6 (6.0.1000.2) also supports delay dataserver in Opentick.

    Leave a comment:


  • NinjaTrader_Ray
    replied
    Within the Instrument Manager, add $ADVN to your default instrument list. This initializes the instrument if it was not already in the database before. You can then remove it after that. Make sure you have the correct symbol map for this instrument in the Misc tab which is located after double clicking on the $ADVN instrument that you added.

    Leave a comment:


  • thrunner
    replied
    Is it possible to get $ADVN and $DECL

    Is it possible to get $ADVN and $DECL with NT6 and Opentick.

    Using $TICK as an example of instrument under instrument manager, I added $ADVN and NYSE as the exchange (also subscribed to NYSE with Opentick).

    When I tried to open the new instrument as a chart, I get the error "you need to select an instrument" error.

    Is this a NT6 or Opentick problem? One user has reported that Opentick supports $ADVN, although I am not sure what software he is using to get the data.

    Leave a comment:


  • Drew
    replied
    Also finding gaps in open tick date

    fwiw - I also found a gap in open tick data for YM in the same time frames as Ray reported from May 9-May 10th. I have placed a ticket with open tick.

    Leave a comment:


  • NinjaTrader_Ray
    replied
    scjohn,

    We were able to reproduce the behaviour on our side. The problem is that OpenTick tick data for ER2 and even ES stops at 10:05 Mountain time on May 9th. There is no tick data after that time.

    Since they offer a free service, its possible that there are bad ticks and missing data. This is something they are working on improving.

    Leave a comment:


  • scjohn
    replied
    I opened a 120 tick chart using File | New | Chart. I did NOT get a Retrieving data message so I will assume that no call to OpenTick was made.

    I have attached several screen shots. All were taken after the 120 tick chart was created.

    Note in the New 150 tick chart and the 5 tick chart, the data gap in today's data between the time that I shut down NT, which was at 9:57 An and when I started NT back up again. And yes I did see a message saying that ER2 data was being gotten. The black arrow on the 120 tick chart shows the 1st bar real time bar on the just created 120 tick chart.

    I recorded a video of everything I did and I can make that video available on my wkikispace if you wish to see it.
    Attached Files

    Leave a comment:


  • NinjaTrader_Ray
    replied
    What happens if you open another chart, without any indicators, 150 tick for ER2, several days back. Do you get the data gap as well?

    Leave a comment:


  • scjohn
    replied
    I switched to a 5-tick chart and the last 5-tick bar on 05/08/07 is 2:53:49. This is 1 hour and 15 minutes before the session endsfor ER2 ends. The next 5-tick bar is for 05/09/07 with a time stamp of 12:11:40 AM. I have no 5-tick bars between those two bars. I hope you are not trying to tell me that there were no trades in that time frame, because there was. Just bring up the ER2 using another data feed.

    Yesterday I shut down NT at 4:00 PM and my 150 tick chart had bars up to the 4:00 PM shut down. This morning, I started NT, around 9:20 AM. The workspace was restored and I had data till 4:00 PM. I went and started the OpenTick connection. The 150 tick chart went blank and said down loading data for ER2. When the chart reappeared, all data from approximately10:28:47 on 05/09/07 was deleted/missing. That is the time stamp for the last bar that I have for 05/09/07. The 1st time stamp for 05/10/07 is 9:20:42. I switch to a 5-tick chart and there are no bars between those 2 times.

    I have attached a current image of my 150 - tick chart. I changed the day separator to be black so that you can clearly see where 05/09/07 ends and 05/10/07 begins.
    Attached Files

    Leave a comment:


  • NinjaTrader_Dierk
    replied
    Right, so the first tick of the new session/day was close to the close of the previous session/day. The following ticks just made big moves. You can verify by checking out a 1 tick series. -> expected behaviour

    Leave a comment:


  • scjohn
    replied
    My session settings are the default: Session begins: 12:00 AM Session End: 12:00 AM

    So I guess the answer to b is - pulling up a chart in the midst of a session because there is only 1 session.

    Leave a comment:


  • NinjaTrader_Dierk
    replied
    - what are your session settings?
    - had you
    (a) pulled up your chart before the session begun so this erroneous bar was built of real time data OR
    (b) is this a result as you requested past tick data for the current session by pulling up a chart in the midst of a session

    Thanks

    Leave a comment:


  • scjohn
    replied
    Attached is a chart of ER2 150 tick. Look for the tan arrow on the chart. This is the type of bar I get every morning.
    Attached Files

    Leave a comment:


  • NinjaTrader_Ray
    replied
    1) NT always reloads data for the current day, this is to ensure that the data is up to date

    2) What NT version are you using? Unfortunately I am having a hard time understanding this. A screenshot would be helpful.

    3) Yes, this can happen since the OT feed can be extremely slow to load historical data. This can then cause a potential gap. They are working on improving their service in this aspect.

    4) I am not aware of this.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by itrader46, Today, 03:24 PM
3 responses
7 views
0 likes
Last Post NinjaTrader_ChelseaB  
Started by MercuryRed, Today, 03:24 PM
0 responses
10 views
0 likes
Last Post MercuryRed  
Started by beobast, Today, 01:56 PM
1 response
4 views
0 likes
Last Post NinjaTrader_Jesse  
Started by daigo1, Today, 02:21 PM
2 responses
6 views
0 likes
Last Post daigo1
by daigo1
 
Started by Zapzap, Today, 02:24 PM
1 response
11 views
0 likes
Last Post NinjaTrader_ChelseaB  
Working...
X