• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

OpenTick issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    OpenTick issues

    Some so called 'problems" I am having with OpenTick.

    1. I goto Tools | Historical Data |Reload, setup the fields on the Reload Historical Data window (selected tick data) and click OK. The data is downloaded and then I click Close. I then File | New | Chart. In the Format Data Series window I set the Interval Settings to 150 tick. Click OK. It appears the NT goes out and downloads the data again. Why? What exactly is the point/use of Historical Data | Reload? Are the two suppose to interact with each other?

    2. File | New | Chart. In Format Data Series set Interval setting to 150 tick. Click OK. Data is downloaded. For the past several days, when I do this in the morning, the data always end around 3:00 PM (Eastern Time). The first bar for today always starts at the time that I opened the chart. This always results in the 1st bar for today having the range that seems to cover the entire overnight activity. When one moves to the next day and repeats the procedure, the previous days "missing data" is now there.

    3. Real Time Data is missing between the time the download is started and the time it is finished. This is most evident when downloading 1-minute bars. The bars that appear between the time it takes to download will always be doji bars - Open = High = Low = Close. Hmmm - did not check to see what the volume was.

    4. I have not been able to verify this but I have been told, at least for ER2, that OpenTick sends about 20% less ticks in the same time period than Trade Station does. I do not subscribe to TS so I can not verify this.

    #2
    1) NT always reloads data for the current day, this is to ensure that the data is up to date

    2) What NT version are you using? Unfortunately I am having a hard time understanding this. A screenshot would be helpful.

    3) Yes, this can happen since the OT feed can be extremely slow to load historical data. This can then cause a potential gap. They are working on improving their service in this aspect.

    4) I am not aware of this.
    RayNinjaTrader Customer Service

    Comment


      #3
      Attached is a chart of ER2 150 tick. Look for the tan arrow on the chart. This is the type of bar I get every morning.
      Attached Files

      Comment


        #4
        - what are your session settings?
        - had you
        (a) pulled up your chart before the session begun so this erroneous bar was built of real time data OR
        (b) is this a result as you requested past tick data for the current session by pulling up a chart in the midst of a session

        Thanks
        DierkNinjaTrader Customer Service

        Comment


          #5
          My session settings are the default: Session begins: 12:00 AM Session End: 12:00 AM

          So I guess the answer to b is - pulling up a chart in the midst of a session because there is only 1 session.

          Comment


            #6
            Right, so the first tick of the new session/day was close to the close of the previous session/day. The following ticks just made big moves. You can verify by checking out a 1 tick series. -> expected behaviour
            DierkNinjaTrader Customer Service

            Comment


              #7
              I switched to a 5-tick chart and the last 5-tick bar on 05/08/07 is 2:53:49. This is 1 hour and 15 minutes before the session endsfor ER2 ends. The next 5-tick bar is for 05/09/07 with a time stamp of 12:11:40 AM. I have no 5-tick bars between those two bars. I hope you are not trying to tell me that there were no trades in that time frame, because there was. Just bring up the ER2 using another data feed.

              Yesterday I shut down NT at 4:00 PM and my 150 tick chart had bars up to the 4:00 PM shut down. This morning, I started NT, around 9:20 AM. The workspace was restored and I had data till 4:00 PM. I went and started the OpenTick connection. The 150 tick chart went blank and said down loading data for ER2. When the chart reappeared, all data from approximately10:28:47 on 05/09/07 was deleted/missing. That is the time stamp for the last bar that I have for 05/09/07. The 1st time stamp for 05/10/07 is 9:20:42. I switch to a 5-tick chart and there are no bars between those 2 times.

              I have attached a current image of my 150 - tick chart. I changed the day separator to be black so that you can clearly see where 05/09/07 ends and 05/10/07 begins.
              Attached Files

              Comment


                #8
                What happens if you open another chart, without any indicators, 150 tick for ER2, several days back. Do you get the data gap as well?
                RayNinjaTrader Customer Service

                Comment


                  #9
                  I opened a 120 tick chart using File | New | Chart. I did NOT get a Retrieving data message so I will assume that no call to OpenTick was made.

                  I have attached several screen shots. All were taken after the 120 tick chart was created.

                  Note in the New 150 tick chart and the 5 tick chart, the data gap in today's data between the time that I shut down NT, which was at 9:57 An and when I started NT back up again. And yes I did see a message saying that ER2 data was being gotten. The black arrow on the 120 tick chart shows the 1st bar real time bar on the just created 120 tick chart.

                  I recorded a video of everything I did and I can make that video available on my wkikispace if you wish to see it.
                  Attached Files

                  Comment


                    #10
                    scjohn,

                    We were able to reproduce the behaviour on our side. The problem is that OpenTick tick data for ER2 and even ES stops at 10:05 Mountain time on May 9th. There is no tick data after that time.

                    Since they offer a free service, its possible that there are bad ticks and missing data. This is something they are working on improving.
                    RayNinjaTrader Customer Service

                    Comment


                      #11
                      Also finding gaps in open tick date

                      fwiw - I also found a gap in open tick data for YM in the same time frames as Ray reported from May 9-May 10th. I have placed a ticket with open tick.

                      Comment


                        #12
                        Is it possible to get $ADVN and $DECL

                        Is it possible to get $ADVN and $DECL with NT6 and Opentick.

                        Using $TICK as an example of instrument under instrument manager, I added $ADVN and NYSE as the exchange (also subscribed to NYSE with Opentick).

                        When I tried to open the new instrument as a chart, I get the error "you need to select an instrument" error.

                        Is this a NT6 or Opentick problem? One user has reported that Opentick supports $ADVN, although I am not sure what software he is using to get the data.

                        Comment


                          #13
                          Within the Instrument Manager, add $ADVN to your default instrument list. This initializes the instrument if it was not already in the database before. You can then remove it after that. Make sure you have the correct symbol map for this instrument in the Misc tab which is located after double clicking on the $ADVN instrument that you added.
                          RayNinjaTrader Customer Service

                          Comment


                            #14
                            Originally posted by NinjaTrader_Ray View Post
                            Within the Instrument Manager, add $ADVN to your default instrument list.
                            Thank you NT_Ray, that worked. BTW for newbies like me, eventhough it isn't currently possible to calculate the spread between 2 instruments within one chart, it is possible to use the symbol $ADDIFFN in Opentick (with NYSE subscription $1/month) to see the difference (spread) between ADVN and DECL in NT6. The new version of NT6 (6.0.1000.2) also supports delay dataserver in Opentick.

                            Comment


                              #15
                              Thanks for letting the community know.
                              DierkNinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by U0000999, Today, 05:44 AM
                              0 responses
                              1 view
                              0 likes
                              Last Post U0000999  
                              Started by lakman184, Today, 05:41 AM
                              0 responses
                              2 views
                              0 likes
                              Last Post lakman184  
                              Started by lilupwab, Today, 04:50 AM
                              0 responses
                              4 views
                              0 likes
                              Last Post lilupwab  
                              Started by MarkFrench1991, Today, 03:47 AM
                              0 responses
                              9 views
                              0 likes
                              Last Post MarkFrench1991  
                              Started by EddyEd, Today, 03:47 AM
                              0 responses
                              7 views
                              0 likes
                              Last Post EddyEd
                              by EddyEd
                               
                              Working...
                              X