• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Connecting with V6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Connecting with V6

    I had V5 connecting to Interactive Brokers. Worked fine. V6 keeps giving me a log on failure. Two messages come up on the log."IB adaptermessageloop: Unable to convert msg "ATI to an intrger id" "Unable to convert msg "False" to an integer id. When I disconnect my IB connection "NINJA_IB" there is next to it "no error".
    Now I also find V5 will not connect. The log message is Message loop. No connection could be made because the target machine actively refused it.
    Some where I read to disconnect other connections to IB but there is not any other connection. I have been over the instal notes again and again.
    Help. Regards lance

    #2
    - What TWS version are you using?
    - Is this an IB demo or an IB live account?
    DierkNinjaTrader Customer Service

    Comment


      #3
      Connecting V6

      My IB build is 872.6 May 18 2007 and it is a live account. ie I trade with IB. Lance

      Comment


        #4
        I suppose you are on NT6R2, no?

        Could I connect to your live account and see what's going on? If so, then please PM me your account credentials to "dierk AT ninjatrader DOT com". Thanks
        DierkNinjaTrader Customer Service

        Comment


          #5
          Checking on Ninja version. be back soon.

          Comment


            #6
            Version 6. SHould I be on 6.2??? Lance. PS trade the DAX

            Comment


              #7
              Should be 6.0.1000.2
              DierkNinjaTrader Customer Service

              Comment


                #8
                Yes, I have 6.0.1000.2 What IB details would you require? Lance

                Comment


                  #9
                  - screenshot of your settings in Tools->Account connections-
                  - password

                  Thanks
                  DierkNinjaTrader Customer Service

                  Comment


                    #10
                    Also: please make sure you are on TWS 870 or later. Thanks
                    DierkNinjaTrader Customer Service

                    Comment


                      #11
                      TWS is 872.6. Will send private message. Lance

                      Comment


                        #12
                        In aprivate message what is your reciprient name. dierk AT etc doesn't work, neither does <<removed>>/ Lance

                        Comment


                          #13
                          a) "dierk AT ninjatrader DOT com" is my official email address.
                          b) I removed the correct mail string from your post, since spam robots grab email strings from web sites.
                          c) I just sent myself a mail which worked fine.
                          d) Sent you forum PM which alternate mail address.
                          DierkNinjaTrader Customer Service

                          Comment


                            #14
                            I previousely lodged a problem with Ver 6. I have had a lot of discussions with Chris and we got excited when it worked over a week ago. The following Monday - same problem and I hadn't changed anything. Have been using Ver 5 since then. Now I have a Ver 5 Problem I lost connection with IBrokers due to a connection failure. Now I keep getting a message: Duplicate Order i.d.(103) when I try to place an order. Have tried closing everything and restarting but still have same problem and message. Lance

                            Comment


                              #15
                              >> Duplicate Order i.d.(103) when I try to place an order
                              There is no resolution to this on NT5. This is a IB TWS problem which NT can not work around.

                              We have not seen it with NT6 yet. I suggest updating to NT6. Please contact again our support team it you need assistance on updating to NT6.

                              As you then are on NT6, we need to understand what is going wrong there.
                              DierkNinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by tradykat, Today, 04:12 PM
                              0 responses
                              2 views
                              0 likes
                              Last Post tradykat  
                              Started by UncleRyan, Today, 03:43 PM
                              2 responses
                              5 views
                              0 likes
                              Last Post UncleRyan  
                              Started by ttodua, Today, 03:39 PM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by NtFan, Today, 02:05 PM
                              1 response
                              15 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by n8dogg59, Today, 01:48 PM
                              1 response
                              11 views
                              0 likes
                              Last Post NinjaTrader_Manfred  
                              Working...
                              X