• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Installing NinjaTrader 6 on a network drive

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Installing NinjaTrader 6 on a network drive

    Installing NinjaTrader on a network drive, meaning <my documents> or <program files> is located on a network share. The best resolution is to relocate your "My Documents" locally, please see below.

    NinjaTrader 7
    Installing on a network drive is NOT supported. As the database technology is SQL CE, which does not support use from a network drive.

    Resolution:

    Relocating "My Documents", so that the directory is stored locally on your machine and not on the network
    -Corporate/Work environment, please contact your IT department.
    -Home User, open user's home folder (located under Start menu> right-click "My Documents" > select "Properties" > 'Location' tab > Move > Select a location on your local "C:" drive
    -After relocating "My Documents" NinjaTrader will need to be reinstalled.


    NinjaTrader 6.5
    - You may experience one or more of the issues below:
    - indicators are not visible as you pull up the indicator box on chart
    - you could not connect to your provider/broker and NinjaTrader reports that <my documents> or <program files> paths or parts of it are invalid

    Resolution 1:

    Relocating "My Documents", so that the directory is stored locally on your machine and not on the network
    -Corporate/Work environment, please contact your IT department.
    -Home User, open user's home folder (located under Start menu> right-click "My Documents" > select "Properties" > 'Location' tab > Move > Select a location on your local "C:" drive
    -After relocating "My Documents" NinjaTrader will need to be reinstalled.

    Resolution 2:If you cannot relocate “My Documents”, usually due to a corporate/work environment

    The problem is that .NET will not load DLLs which are not local to the machine. You need to increase the trust level of the local network (intranet) to fix this problem.
    a) Start->Settings->Control Panel->Administrative Tools->Microsoft .NET Framework 2.0 Configuration->My Computer->Runtime Security Policy (see <image1>)
    b) Click on: Adjust internet zone> Next -> Local Intranet
    c) Adjust the level of trust to Full Trust (see <image2>)

    You may experience that the options above are not available on your machine. You then would need to install the .NET 2.0 SDK from here:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=fe6f2099-b7b4-4f47-a244-c96d69c35dec&displaylang=en
    Attached Files
    DierkNinjaTrader Customer Service

Latest Posts

Collapse

Topics Statistics Last Post
Started by johnnybegoode, 01-14-2019, 07:24 PM
13 responses
540 views
0 likes
Last Post seeseea
by seeseea
 
Started by henit, Today, 09:10 AM
0 responses
14 views
0 likes
Last Post henit
by henit
 
Started by Hagar, Yesterday, 06:52 PM
1 response
11 views
0 likes
Last Post NinjaTrader_ChrisL  
Started by vivekniwas, Yesterday, 04:56 PM
1 response
12 views
0 likes
Last Post NinjaTrader_ChrisL  
Started by heguilar, Today, 07:30 AM
1 response
6 views
0 likes
Last Post NinjaTrader_ChrisL  
Working...
X