• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Fast Market ATM issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Just sent that information to your attention at support (at) ninjatrader (dot) com. I also included the previous log/trace files from 3/10 which had already been sent.

    I'm happy to keep sending new information as I have additional incidences, but I would like to know if any diagnosis is close at hand from the last information I sent.

    Thanks!

    Comment


      #17
      Hi Pipskateer,

      I am going to be doing some testing on my end to attempt to replicate this issue and will follow up as soon as I have concluded testing.

      Thank you for your patience.
      Christopher J.NinjaTrader Customer Service

      Comment


        #18
        I have been unable to reproduce this on my end but would like to continue testing in the morning when the market is more volitile.

        If you don't mind tomorrow morning can you please set your update interval to 0 by right mouse click within your Chart-->Properties-->Display update interval-->Set to 0-->Click Ok.

        Please let me know if you notice a difference with the setting changed and I will post after doing further testing as well.
        Christopher J.NinjaTrader Customer Service

        Comment


          #19
          I have done as you asked and will monitor. I am not surprised that you couldn't duplicate the issue, given the weak volume and PA this week. I notice this more often on CL crude oil, but occasionally see it with GC gold.

          I just have an overall sense this issue is related to whatever process NT uses to execute its DEMO fills. My colleagues who are trading live using my identical ATM settings are not seeing this issue occur until they cease live trading and return to demo at some point in the day. I have not traded this ATM live and won't until it is resolved or until I can confirm it is strictly limited to demo mode trading. Unfortunately, while this gets sorted, my license expiration date marches forward. ATM trading is not optional for my trading system.

          Another issue I am noticing that may or may not be related has to do with many of my limit orders getting filled at one or two ticks BETTER than where they were placed. If these were LIVE trades, I suspect it would not be occurring at all. This seems to be happening quite often, though I have only recently noticed it through a peer trade review process. I will continue to monitor this as well, as I suspect this is also related to NT's demo fill "engine". I seem to remember someone posting about this recently...will do a search for relevant threads.

          Thank you!

          Comment


            #20
            Yes, a quick search and I found the post by MiniDowTrader regarding premature fills:

            http://www.ninjatrader-support2.com/...81&postcount=7

            This issue was never fully addressed and what the poster describes is EXACTLY what I'm seeing. And as well, I do NOT have "enforce immediate fills" checked in TOOLS>OPTIONS>SIMULATOR tab.

            I think this issue and my ATM issue are somehow related, but that's just a gut feeling. I'll wait for you guys to figure it out.

            Thanks!

            Comment


              #21
              Hi Chris,

              Per your request, I changed the display refresh interval to "0" and, although it speeds up the display lag on showing what the ATM is doing, it doesn't rectify the issue. I still have orders that hit substantial profit levels that are well within the ATM's programmed parameters to adjust the SL to protect profits, but it just doesn't always happen. My first trade today hit 6 ticks profit which should have had at least 4-5 ticks protected by the ATM. I managed to salvage only 1.

              I guess no one is complaining since it's "only demo"?? Surely I'm not the only person seeing this phenomenon?? If I could have some assurance this is only present on DEMO mode, I'd sure feel a lot better about it.

              Comment


                #22
                Hi Pipskateer,

                Our development team is investigating this issue and I will report as soon as we have additional information.

                Thank you for your patience.
                Christopher J.NinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by Erhard, Today, 04:24 AM
                2 responses
                17 views
                0 likes
                Last Post Erhard
                by Erhard
                 
                Started by rontronimous, Yesterday, 05:55 PM
                2 responses
                20 views
                0 likes
                Last Post rontronimous  
                Started by brunoviveiros, Today, 04:26 AM
                0 responses
                3 views
                0 likes
                Last Post brunoviveiros  
                Started by StevenNelson, 11-19-2019, 05:39 AM
                3 responses
                22 views
                0 likes
                Last Post brucerobinson  
                Started by guidoisot, Today, 03:01 AM
                0 responses
                8 views
                0 likes
                Last Post guidoisot  
                Working...
                X