• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Unable to connect to database 'Provider=Microsoft.Jet. etc. Unrecognized db format...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Unable to connect to database 'Provider=Microsoft.Jet. etc. Unrecognized db format...

    Have been running NT for months with absolutely no problems. All of a sudden got this message when start up. Have Microsoft .NET Framework 3.5 SP1, which is the latest version. Am attaching a copy of the error message displayed by Ninja Trader. Thanks for any help.
    Attached Files

    #2
    Hello Brenda,

    Can you please send me your latest log and trace files. You can find these files at the following locations.

    Start Menu--> My Documents--> NinjaTrader 6.5--> Log--> log.20100319.txt for today. (log.yyyymmdd for any other date)

    Start Menu--> My Documents--> NinjaTrader 6.5--> Trace--> trace.20100319.txt for today. (trace.yyyymmdd for any other date)

    Please send them to support[at]ninjatrader[dot]com, reference this forum thread and put 'Attn Jason' in the subject header.
    JasonNinjaTrader Customer Service

    Comment


      #3
      Hi Jason,

      Thank you very much for your prompt reply. I just e-mailed logs and traces for today the 19th (I retried unsuccessfully), yesterday (the first time the problem happened) and the 17th when I had no problems. Please let me know if you need any more info. Thanks for everything.

      Brenda

      Comment


        #4
        Hello Brenda,

        I did receive your trace and log files, and please let us know if you have not received my response, or if the issue still persists.

        In my reply, based on the log and trace files, I had you to rename the database. To rename the DB:
        • Shutdown NinjaTrader and Go to the Start Menu
        • Select My Documents--> NinjaTrader 6.5--> DB--> NinjaTrader.MDB.
        • Right click on NinjaTrader.MDB and select "Rename."
        • Name it "NewNinjaTrader.MDB."
        • Then restart the software.
        Ryan O.NinjaTrader Customer Service

        Comment


          #5
          Hi Ryan,

          My apologies for not responding sooner to your helpful message. I did what you said and was able to run Ninja Trader again. Thank you so much. Had to recreate my charts, but what the heck, I think I had too much data anyways and it just got too crowded. I am now trying to keep just the data that I'm using. If it happens again I know what to do. By the way, I imagine that deleting the database would also work, wouldn't it?

          Ryan, I have another problem sometimes. I add a new stock with Instrument Manager and then I try to get a chart of that stock and I get "Error in requesting historical data from IB: No security definition has been found for the request(200)" One of the symbols that that is happening with is the S&P Index (^SPX), which in fact I was able to get before I had the database problem. This security is defined in my IB simulation program, so I don't understand. Other securities are: ACH, GDX, UPL, PCX and others. All these are American Securities. This always happened with foreign securities such as PBR, but now am able to get PBR. I'm lost!

          Comment


            #6
            Hi,

            Within NinjaTrader the SP500 index is called SP500. Can you please reset your instruments and then chart that symbol in NinjaTrader. To reset your instruments please: go to the Tools menu, select the Options menu item, select the Misc tab, and then click on 'Reset Instruments'.


            As for the other instruments please start typing on an open chart to change the symbol from the command line. This will also add the symbol to the database if it is not present already.
            Ryan O.NinjaTrader Customer Service

            Comment


              #7
              Hi Ryan, did all you said and got the exact same results. Ninja Trader does not recognize SP500, SPX, nor ^SPX. Got error messages with the same symbols as before. Also did not make any difference typing them on the chart. It's very frustrating.

              Comment


                #8
                Hi Brenda,

                Can you please check whether you get data for those symbols in IB. If so please right click on the instrument and select Contract-->Details.

                With the contract symbol please go to Tools-->Instrument Manager and for the instrument please input what is available from IB in the symbol mapping for IB within the NinjaTrader symbol mapping. Please see the following link for editing instruments.
                http://www.ninjatrader-support.com/H...ingInstruments
                Ryan O.NinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by sandman55, Yesterday, 08:00 PM
                2 responses
                8 views
                0 likes
                Last Post koganam
                by koganam
                 
                Started by ArmKnuckle, Today, 01:44 AM
                2 responses
                12 views
                0 likes
                Last Post koganam
                by koganam
                 
                Started by TazoTodua, Today, 04:35 AM
                4 responses
                11 views
                0 likes
                Last Post koganam
                by koganam
                 
                Started by BobyGill, Yesterday, 03:48 PM
                7 responses
                41 views
                0 likes
                Last Post NinjaTrader_ChelseaB  
                Started by itrader46, Today, 07:46 AM
                1 response
                6 views
                0 likes
                Last Post NinjaTrader_Kate  
                Working...
                X