Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

No charts in NT6.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    No charts in NT6.5

    Hi,

    I was using combination NT6.5 (current ver) with ZenFire demo for trial period with no problem of accessing historical data for TF 12-09. However, recently I had to reinstall my Windows 7 64bit due to system failure. Now when I installed it and run it does following:

    Immediately after start it throws for all graphs on workspace - TF xx-yy cant be found in database with OK button. I thought thats ok, because I'm not connected to ZenFire yet.

    So I created connection with NEW (to be sure not using expired details) details and succesfully connected with gren light in left bottom. I created custom instrument for TF 03-10 (Nybot, but tried ICE too), open chart with this instrument and... nothing. Just white empty graph with anything particular in it. And that applies for all instruments.

    I have double checked I have Windows Update portion for Framework 3.5 2.0 is already in system by default. I'm really struggling here... Any help is really welcome. Will check this thread every few hours. THANK YOU for looking into this.
    Attached Files

    #2
    Hi ZOLLINO,

    Thank you for your post.

    On each chart can you please right click and select Format Data Series and then in the ensuing window please let us know what the Range Settings are for the charts.
    Ryan O.NinjaTrader Customer Service

    Comment


      #3
      Ok, 1st of all I do create new instrument TF 03-10 (Nybot). Than open new chart - with that instrument. Placing my template, for 1000 VOLUME, date range 01 Dec 2009 - current date. In fact it should display real data from 11.dec2009 until march 2010. but nothing.

      If I right click on opened chart after clicking ok, it won't display anything. Also there is no title for this graph window like it was loading anything. What I have also noticed in log is following:

      19:10:54 - Connection to Ninja Trader historical market data server lost: Cannot access disposed object. Object name: 'ProcessForm'

      19:11:04 - Connection to Ninja Trader historical market data server established.

      Thanks for prompt reply.

      Comment


        #4
        Hi ZOLLINO,

        Thank you for that clarification. In testing that specific contract I see the same thing on my end for the TF contract. This indicates that data is not present for tick based indicators.

        I tested the minute interval and there is historical data for minutes, but not for tick based intervals like a Volume chart.
        Ryan O.NinjaTrader Customer Service

        Comment


          #5
          Thanks Ryan, unfortunately I'm getting the same result for 15mins chart when choosing Format data series as well.

          Would you be so kind to post me a step by step walkthrough from starting NT6.5 to displaying chart with actual data in it? I will follow your steps to see if it works for myself.

          Comment


            #6
            Hi ZOLLINO,

            If you go to File-->New-->Chart and then set your Format Data Series to be the same as the attached screenshot then you should receive historical data.

            If no data plots can you please forward your log and trace files to support[at]ninjatrader[dot]com and please reference this thread.

            Trace files will be located by going to My Documents->NinjaTrader 6.5->Trace-> trace.2010xxxx.txt
            Log files will be located by going to My Documents->NinjaTrader 6.5->Log->log.2010xxxx.txt
            Attached Files
            Ryan O.NinjaTrader Customer Service

            Comment


              #7
              I'm opening the chart the very same way but no data plots. Blank window opens without title or anything and hang for like 5mins. Trace and logs sent to email mentioned. I hope you will be in touch? I'll be checking thread for additional updates. Thanks again for your efforts.

              Comment


                #8
                Anything new on this topic? Have you received the logs? Do you think switch to NT7 would help?

                Comment


                  #9
                  HI ZOLLINO,

                  Unfortunately, I did not receive the log and trace files. If you could resend them to support[at]ninjatrader[dot]com I will review those.

                  Please reference this thread, and put ATTN Ryan O.

                  Also, if possible can you please provide a screenshot the of the ensuing chart based on the data series settings you provided in the screenshot earlier.
                  Ryan O.NinjaTrader Customer Service

                  Comment


                    #10
                    Just sent with subject:

                    ATTN: RYAN O. - No charts in NT6.5 - http://www.ninjatrader.com/support/f...ad.php?t=32096

                    Ryan
                    have you received my email? Any suggestions? Thank you
                    Last edited by ZOLLINO; 08-06-2010, 02:28 AM.

                    Comment


                      #11
                      Thanks for reply to my email. I will follow up instructions as soon as I will get to my PC to try this out. Fingers crossed.

                      Comment


                        #12
                        Hi Ryan,

                        Unfortunately this didn't help and I'm still getting empty chart window with anything being downloaded as data.

                        Comment


                          #13
                          Hi,

                          I downloaded latest updates from Windows Update (don't think this really matters) and removed Ninja Trader 6.5 from all my folder locations on any hard drives. Also I have removed any registry entry involving NT. Reinstalled the program without placing my templates and workspaces there. Loaded TF 03-10 and I've got the Data plot now!

                          I believe that what I was doing wrong was that immediately after installation I have copied my templates and workspaces over to c:\users\.. and this caused mismatch or some kind of problem. I think this is resolved now.

                          Comment


                            #14
                            Well,

                            For some reason graphs are still empty when I want to select range or volume data plot for TF 03-10. However, I was able to work on VOL2000 data plots for TF 12-09 before I reinstalled my PC. Is problem on my side or is it due to some change in zenfire data? It's kind of useless to have just time oriented data plots.

                            Anyone else having the same issue?

                            Comment


                              #15
                              Hello ZOLLINO,

                              Thank you for your post.

                              The contracts TF 12-09 & TF 03-10 are both expired contracts which is why that charts are blank. You will need to use the current front-month for this TF instrument (TF 09-10). You may need to roll your instruments forward.

                              Here are the instructions for rolling forward futures contract in NinjaTrader:
                              http://www.ninjatrader-support.com/H...uturesContract

                              For Adding/Removing Instruments to your instrument list(s), please check out the following:
                              http://www.ninjatrader-support.com/H...ingInstruments

                              Please let me know if this does not resolve the issue.
                              ChipNinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by rufat, Yesterday, 09:24 PM
                              1 response
                              15 views
                              0 likes
                              Last Post NinjaTrader_Jason  
                              Started by TRADEONECLIC, Yesterday, 10:05 PM
                              0 responses
                              24 views
                              0 likes
                              Last Post TRADEONECLIC  
                              Started by BrennanSalibrici, 12-17-2020, 11:55 PM
                              3 responses
                              45 views
                              0 likes
                              Last Post StealthM93  
                              Started by coopgrafik, Yesterday, 07:56 PM
                              0 responses
                              9 views
                              0 likes
                              Last Post coopgrafik  
                              Started by MisterGee, Yesterday, 07:55 PM
                              0 responses
                              9 views
                              0 likes
                              Last Post MisterGee  
                              Working...
                              X